Remontée d’etat des capteurs de fenêtre MiHome

Tags: #<Tag:0x00007f24485a8bd8> #<Tag:0x00007f24485a8138>

Bonjour à tous,

Sous Jeedom j’ai mes capteurs de fenêtre qui restent « parfois figés » à un état ouvert. Peut être fermé parfois mais c’est moins visible.

J’ai essayé le refresh mais cela ne ramène pas de changement d’état. Pour que l’état se « resynchronise » je dois ouvrir puis fermer la fenêtre… pas idéal pour gérer les scénarios…

Dans MiHome l’état des fenêtres (ouvert/fermé) est toujours correct…

Dès ides d’où cela pourrait provenir ?

Exemple dans la vidéo.
L’état est ouvert alors que la fenêtre est fermée, je tente une synchronisation manuelle qui n’aboutie pas et quand vous entendez un bruit, ce sont mes stores et cela indique que j’ai ouvert puis fermé la fenêtre. Comme par magie, l’état se Resynchronise

Merci de votre lecture et votre aide

Bonjour,

Tu utilise quoi comme gateway zigbee?

Bonjour,

J’utilise la gateway Xiaomi. D’ailleurs dans l’application de Xiaomi (MiHome), les statuts sont toujours correctes. Du coup je penche sur un problème de remontée d’infos entre la passerelle et jeedom mais je ne comprends pas.

Merci beaucoup

Les problèmes de retard de remontées sont généralement dû à un souci de communication réseau

Est-ce que nous serions pas sur un problème d’environnement plutôt ?
Tu précises que lors que tu bouges les rideaux cela fonctionne et au bruit ce sont des rideaux à lamelle métallique non ?
Sur la vidéo on ne voit pas bien la position du capteur mais il pourrait y avoir une confusion du capteur lié au rideau.

Ce qui est étonnant c’est que ce capteur est à 7m de la gateway et sans mur épais entre les deux.

De même il ne s’agit pas d’un retard de remontée, mais d’une non remontée. Le statut reste à ouvert jusqu’à la prochaine actualisation provoquée par l’ouverture/fermeture de la fenêtre…
D’ailleurs dans MiHome, le statut est ok
… A quel genre de problème de communication pensez vous?
Merci

Bonjour,

Merci de ton intérêt, les rideaux n’interviennent pas dans la gestion de la remontée d’infos. Lorsque tu les entends, c’est parce que j’ouvre puis referme la fenêtre (seul moyen d’actualiser le statut)

Par ailleurs, je précise que le statut dans l’application MiHome est correcte… le soucis viendrait de la communication entre le statut MiHome et le statut Jeedom…

Sur quel type de machine est installé Jeedom?
Ce Jeedom est en ethernet ou en wifi?
Possible d’avoir une copie de la page santé de Jeedom?

Jeedom est sur un Rpi 3b sur SSD et branché en ethernet

Par exemple actuellement toutes mes fenêtres sont fermées mais le système en considère 2 d’ouverte.

image image

J’ai purgé le log du Plugin relancé les dépendances et les démon.

Voici le Log après avoir Refresh manuellement mes capteurs dans mon dashboard

J’ai une ligne d’erreur par Refresh réalisé

image

tu n’as rien modifié sur ton Wifi ? je sais que sur le routeur asus il fallait activer le broadcast pour que ca fonctionne

Non je n’ai rien modifié. Mon routeur fait un reboot tout les dimanche soir mais à par ça… ras de ce côté.

Le broadcast?

il y avait un sujet sur l’ancien forum https://forum.jeedom.com/viewtopic.php?p=707449

En gros je coris que ca permet aux appareils ne communiquer entre eux sur le reseau

Merci mais là… c’est trop complexe pour moi. J’ai lu les premiers échanges… je suis dans la galaxie…

tu as quoi comme routeur ?

Je dis même des bêtises.

C’est mon routeur wifi qui reboot 1 fois par semaine.

Le rpi étant en ethernet, il reboot pas. Le routeur c’est celui de mon FAI du coup . Red SFR

ok donc c’est la box de ton FAI qui gere le wifi.
si ca ne le faisait pas avant y a pas de raison que ca ne fonctionne plus aujourd’hui.
essaye peut etre de rebooter jeedom et la box.

Non justement, la box de mon FAI ne gère que la partie Ethernet. Le wifi est géré par un routeur dédié.

Mais mon rpi est branché en ethernet…

Oui mais xiaomi est sur le wifi. C’est quoi l’appareil qui gère le wifi.

C’est un routeur dédié Tenda Nova Mw6