Redémarrage fréquent nécessaire du rpi 3 / jeedom

Bonjour,
Je ne sais pas trop où poster ceci , j’espère que je suis au bon endroit.
J’ai installé la v4 de jeedom sur un RPI3 avec un ssd, un rflink et une zigbeemqtt.
J’ai très fréquemment (à peu près tous les deux ou trois jours) besoin de redémarrer le RPI, car jeedom devient inaccessible / non responsif et plante.
Je pensais que cela était dû à des erreurs I/O car initailement j’avais fait l’installation sur une clé sd mais le problème persiste avec le changement en SSD.
QUelqu’un aurait il une idée d’où provient ce bug où de l’endroit où je pourrais trouver des infos / logs /debugs pour me mettre sur la piste ?
Dans ceux de jeedom, je n’ai rien trouvé qui m’éclaire vu mon niveau en programmation.

Merci beaucoup.

Bonjour,
Affiche tes logs et état de santé de la Jeedom si tu veux de l’aide.
Sinon,.c’est compliqué

1 J'aime

Merci pour la réponse.
Justement le pb est que je ne sais pas trop où chercher ni du coup quelle catégorie de log regarder.
Ci-dessous l’un qui s’intitule “http error” (les autres on l’air relatives a des plugins spécifiques ou ne semblent pas poser de pb):

[Fri Dec 27 09:09:48.346536 2019] [:error] [pid 22114] [client 3.24.139.246:41794] script ‘/var/www/html/elrekt.php’ not found or unable to stat
[Fri Dec 27 09:55:15.392032 2019] [:error] [pid 31407] [client 94.191.10.105:59222] script ‘/var/www/html/elrekt.php’ not found or unable to stat
[Wed Dec 25 14:13:07.234035 2019] [mpm_prefork:notice] [pid 642] AH00163: Apache/2.4.25 (Raspbian) OpenSSL/1.0.2t configured – resuming normal operations
[Wed Dec 25 14:13:07.234955 2019] [core:notice] [pid 642] AH00094: Command line: ‘/usr/sbin/apache2’
[Sun Dec 29 10:44:45.546963 2019] [access_compat:error] [pid 1657] [client 193.37.255.114:34494] AH01797: client denied by server configuration: /var/www/html/sitemap.xml
[Sun Dec 29 12:36:40.927883 2019] [:error] [pid 1657] [client 23.94.182.3:48800] script ‘/var/www/html/elrekt.php’ not found or unable to stat
[Mon Dec 30 10:05:10.415731 2019] [:error] [pid 3403] [client 5.188.210.101:54886] script ‘/var/www/html/echo.php’ not found or unable to stat, referer: https://www.google.com/

Dans la partie santé de Jeedom j’ai ceci (avec des lignes rouges pour “swapiness” et “swap”:

Système à jour OK Cron actif OK
Scénario actif OK Démarré OK 2019-12-28 12:12:22
Date système (dernière heure enregistrée) OK 2019-12-30 13:52:46 (2019-12-30 13:00:03) Droits sudo OK
Version Jeedom 4.0.35 Version PHP 7.0.33-0+deb9u6
Version OS Linux raspberrypi 4.19.66-v7+ #1253 SMP Thu Aug 15 11:49:46 BST 2019 armv7l GNU/Linux [9.11] Version database 10.1.38-MariaDB-0+deb9u1
Espace disque libre 88 % Espace disque libre tmp 98 %
Mémoire disponible 55 % (Total 926 Mo) Mémoire suffisante 0
Erreur I/O 0 Swap disponible 86 % (Total 100 Mo)
Swapiness 60 % Charge 1.57 - 1.8 - 1.77
Configuration réseau interne OK Configuration réseau externe NOK
Persistance du cache OK (2019-12-30 13:30:06) Apache private tmp OK
Plugins OK

Merci !

Salut,

Les erreurs php (elrekt sitemap etc) n’ont en principe pas de lien avec ton problème. => Attaque pirate?

Swap et swappiness sans doute pas non plus.

Regarde dans les logs des plugins également

Bonjour,
Pour les erreurs php j’ai copié le fichier jail.local posté dans l’autre fil, merci de l’info.
J’ai aussi modifié les paramètres pour que swapiness et swap cessent d’apparaître en rouge, à tout hasard, même si j’ai vu que ce n’était pas forcément nécessaire ni absolument sans incidence.
Le bug étant réapparu cette nuit, cela confirme que ces erreurs n’y étaient pour rien.

Voici les logs que j’ai (désolé c’est long) :

http error :

[Mon Dec 30 19:32:33.997455 2019] [mpm_prefork:notice] [pid 750] AH00163: Apache/2.4.25 (Raspbian) OpenSSL/1.0.2t configured – resuming normal operations
[Mon Dec 30 19:32:33.998609 2019] [core:notice] [pid 750] AH00094: Command line: ‘/usr/sbin/apache2’

rflink (je ne comprends pas bien pourquoi il me demande de d/l le dernier firmware qui est déjà installé vers minuit) :

[2019-12-30 22:07:31][DEBUG] : 10;NewKaku;85da18fd;;ON;
[2019-12-30 22:07:31][INFO] : 10;NewKaku;85da18fd;;ON;
[2019-12-30 22:07:31][DEBUG] : 10;NewKaku;814008b3;;ON;
[2019-12-30 22:07:31][INFO] : 10;NewKaku;814008b3;;ON;
[2019-12-30 22:07:32][DEBUG] : Trame non utilisable 20;07;OK;
[2019-12-30 22:07:33][DEBUG] : Trame non utilisable 20;08;OK;
[2019-12-30 23:12:58][DEBUG] : 10;NewKaku;85da18fd;;OFF;
[2019-12-30 23:12:58][INFO] : 10;NewKaku;85da18fd;;OFF;
[2019-12-30 23:12:59][DEBUG] : Trame non utilisable 20;09;OK;
[2019-12-30 23:14:58][DEBUG] : 10;NewKaku;814008b3;;OFF;
[2019-12-30 23:14:58][INFO] : 10;NewKaku;814008b3;;OFF;
[2019-12-30 23:14:59][DEBUG] : Trame non utilisable 20;0A;OK;
[2019-12-31 00:00:05][DEBUG] : Recherche firmware http://www.nemcon.nl/blog2/fw/update.jsp?ver=1&rel=48
[2019-12-31 00:00:06][DEBUG] : Download http://www.rflink.nl/fw/48/RFLink.cpp.hex in /var/www/html/plugins/rflink/resources/rflink/RFLink.cpp.hex for release 48
[2019-12-31 08:16:19][DEBUG] : 10;NewKaku;85da18fd;;ON;
[2019-12-31 08:16:19][INFO] : 10;NewKaku;85da18fd;;ON;
[2019-12-31 08:16:19][DEBUG] : 10;NewKaku;814008b3;;ON;
[2019-12-31 08:16:19][INFO] : 10;NewKaku;814008b3;;ON;
[2019-12-31 08:16:20][DEBUG] : Trame non utilisable 20;0B;OK;
[2019-12-31 08:16:21][DEBUG] : Trame non utilisable 20;0C;OK;
[2019-12-31 09:27:19][INFO] : Arrêt du service rflink
[2019-12-31 09:27:19][INFO] : Lancement du démon rflink
[2019-12-31 09:27:19][DEBUG] : Lancement démon rflink : nice -n 19 nodejs /var/www/html/plugins/rflink/resources/rflink.js http://127.0.0.1:80/plugins/rflink/core/api/rflink.php?apikey=OfBW9d1WABbiPfYpk2kVkn7Ssq8L8tvY /dev/ttyACM1 none debug
[2019-12-31 09:27:19][INFO] : Démon rflink lancé
[2019-12-31 09:27:22][DEBUG] : Trame non utilisable 20;01;MiLight=OFF;NO NRF24L01;
[2019-12-31 09:27:24][INFO] : 10;STATUS;
[2019-12-31 09:27:24][DEBUG] : Status 20;02;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=ON;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
[2019-12-31 09:40:21][DEBUG] : Protocole Aster ID 0ffc

rflink node :

Tue Dec 31 2019 08:27:21 GMT+0000 (Greenwich Mean Time) - Jeedom url : http://127.0.0.1:80/plugins/rflink/core/api/rflink.php?apikey=OfBW9d1WABbiPfYpk2kVkn7Ssq8L8tvY, gwAddress : /dev/ttyACM1
Tue Dec 31 2019 08:27:21 GMT+0000 (Greenwich Mean Time) - server bound on 8020
Port open
Tue Dec 31 2019 08:27:22 GMT+0000 (Greenwich Mean Time) - 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
Tue Dec 31 2019 08:27:22 GMT+0000 (Greenwich Mean Time) - Send Value : 20;00;Nodo RadioFrequencyLink - RFLink Gateway V1.1 - R48;
Tue Dec 31 2019 08:27:22 GMT+0000 (Greenwich Mean Time) - 20;01;MiLight=OFF;NO NRF24L01;
Tue Dec 31 2019 08:27:22 GMT+0000 (Greenwich Mean Time) - Send Value : 20;01;MiLight=OFF;NO NRF24L01;
Tue Dec 31 2019 08:27:22 GMT+0000 (Greenwich Mean Time) - Got response Value : 200
Tue Dec 31 2019 08:27:22 GMT+0000 (Greenwich Mean Time) - Got response Value : 200
Tue Dec 31 2019 08:27:24 GMT+0000 (Greenwich Mean Time) - Server connected
Tue Dec 31 2019 08:27:24 GMT+0000 (Greenwich Mean Time) - 20;02;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=ON;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
Tue Dec 31 2019 08:27:24 GMT+0000 (Greenwich Mean Time) - Send Value : 20;02;STATUS;setRF433=ON;setNodoNRF=OFF;setMilight=ON;setLivingColors=OFF;setAnsluta=OFF;setGPIO=OFF;setBLE=OFF;setMysensors=OFF;
Tue Dec 31 2019 08:27:24 GMT+0000 (Greenwich Mean Time) - Got response Value : 200
Tue Dec 31 2019 08:40:21 GMT+0000 (Greenwich Mean Time) - 20;03;Aster;ID=0ffc;SWITCH=01;CMD=ON;
Tue Dec 31 2019 08:40:21 GMT+0000 (Greenwich Mean Time) - Send Value : 20;03;Aster;ID=0ffc;SWITCH=01;CMD=ON;
Tue Dec 31 2019 08:40:21 GMT+0000 (Greenwich Mean Time) - Got response Value : 200

ampli Pioneer :

Activation du daemon ampli_pioneer PARAMS : (IP : 192.168.1.96 port : 23) 09:27:00
[2019-12-31 09:27:00][ERROR] : L103 Daemon ERROR Connection refused(111)
Daemon ERROR Connection refused(111)
kill: (2098): No such process
kill: (2100): No such process
Activation du daemon ampli_pioneer PARAMS : (IP : 192.168.1.96 port : 23) 09:30:06
[2019-12-31 09:30:06][ERROR] : L103 Daemon ERROR Connection refused(111)
Daemon ERROR Connection refused(111)
kill: (8383): No such process
kill: (8385): No such process
[2019-12-31 09:30:38][ERROR] : Impossible de lancer le démon ampli_pioneer_Daemon
Activation du daemon ampli_pioneer PARAMS : (IP : 192.168.1.96 port : 23) 09:35:06
[2019-12-31 09:35:06][ERROR] : L103 Daemon ERROR Connection refused(111)
Daemon ERROR Connection refused(111)
kill: (19069): No such process
kill: (19071): No such process
[2019-12-31 09:35:37][ERROR] : Impossible de lancer le démon ampli_pioneer_Daemon
Activation du daemon ampli_pioneer PARAMS : (IP : 192.168.1.96 port : 23) 09:40:06
[2019-12-31 09:40:06][ERROR] : L103 Daemon ERROR Connection refused(111)
Daemon ERROR Connection refused(111)
kill: (32544): No such process
kill: (32546): No such process
[2019-12-31 09:40:38][ERROR] : Impossible de lancer le démon ampli_pioneer_Daemon
Activation du daemon ampli_pioneer PARAMS : (IP : 192.168.1.96 port : 23) 09:45:06
[2019-12-31 09:45:06][ERROR] : L103 Daemon ERROR Connection refused(111)
Daemon ERROR Connection refused(111)
kill: (13724): No such process
kill: (13726): No such process
[2019-12-31 09:45:38][ERROR] : Impossible de lancer le démon ampli_pioneer_Daemon

Bonjour naboleo et merci pour ton aide,

juste pour le cas où d’autres personnes seraient intéressées, le pb semble avoir disparu depuis quelques temps.

cela coïncide à peu près avec plusieurs mises à jour de jeedom v4 et avec les modifications faites plus haut (swap et fail2ban) mais il est difficile d’en tirer une conclusion…

Bonne journée.

1 J'aime