Provoqué / Programmé qui reste actif quand on change de déclencheur

Tags: #<Tag:0x00007f3853b4ddd0>

Hello,

Je viens de remarquer un truc : quand on passe le déclencheur d’un scénario de « les deux » à « programmer », par exemple, il faut absolument supprimer les événements déclencheurs, sinon ils restent actifs, mais on ne les voit plus à l’écran.

Est-ce voulu ou pas du tout ?
Parce que j’ai mis un moment à trouver ce qui fermait mes volets à 3h du mat :slight_smile:

Hello,
Bien vu ça. Je ne qualifierait pas cela de voulu effectivement.

! Excellent point a vérifier je note précieusement.

Çà peut aider a résoudre des affaires mystérieuses.

Merci.

@Jeedom-Team

Bonjour,
Comme d’habitude sans log ou quoique ce soit qui me permet au moins de commencer a chercher nous considérons qu’il n’y a aucun soucis.

Je ne vois pas en quoi des logs peuvent aider, vu qu’il s’agit d’un souci d’interface homme / machine.
Idéalement, quand on passe de « les deux » à « programmer », par exemple, ca devrait soit supprimer les déclencheurs provoqués, soit préciser que ça ne supprime pas l’action du déclencheur, soit ne pas cacher le déclencheur provoqué.

Je te mets une vidéo qui montre le souci, mais je vois pas bien ce qu’on peut avoir de plus…
https://streamable.com/ogamw3

Mettre la log par exemple mais c’est vrai que je suis vraiment mal placé pour te dire que la log pourrait m’aider a résoudre le probleme…

La le faite que ca reste en mémoire sur l’interface n’est pas le soucis et c’est volontaire, le soucis c’est que vu ce que tu dis ca declenche encore le scénario et ca seul la log peut m’aider a le comprendre. Après tu fais comme tu veux j’essaye juste d’aider mais tu es mieux placer que moi pour savoir ce qu’il me faut pour résoudre le soucis.

Tu veux la log du scénario qui se déclenchait tout seul ?

[2020-08-21 21:30:02][SCENARIO] Start : Lancement provoque par le scenario  : [Volets][Volets][Fermeture des volets avec le soleil].
[2020-08-21 21:30:02][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-08-21 21:30:02][SCENARIO] Lancement du scénario : Fermer les volets du bas options : []
[2020-08-21 21:30:02][SCENARIO] Lancement du scénario : Fermer les volets du haut options : []
[2020-08-21 21:30:02][SCENARIO] Fin correcte du scénario
------------------------------------
[2020-08-22 03:00:05][SCENARIO] Start : Scenario execute automatiquement sur evenement venant de : [Parametrage][Ephemerides][coucher_soleil].
[2020-08-22 03:00:05][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-08-22 03:00:05][SCENARIO] Lancement du scénario : Fermer les volets du bas options : []
[2020-08-22 03:00:05][SCENARIO] Lancement du scénario : Fermer les volets du haut options : []
[2020-08-22 03:00:05][SCENARIO] Fin correcte du scénario
------------------------------------
[2020-08-22 21:28:02][SCENARIO] Start : Lancement provoque par le scenario  : [Volets][Volets][Fermeture des volets avec le soleil].
[2020-08-22 21:28:02][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-08-22 21:28:02][SCENARIO] Lancement du scénario : Fermer les volets du bas options : []
[2020-08-22 21:28:02][SCENARIO] Lancement du scénario : Fermer les volets du haut options : []
[2020-08-22 21:28:02][SCENARIO] Fin correcte du scénario
------------------------------------
[2020-08-23 03:00:06][SCENARIO] Start : Scenario execute automatiquement sur evenement venant de : [Parametrage][Ephemerides][coucher_soleil].
[2020-08-23 03:00:06][SCENARIO] Exécution du sous-élément de type [action] : action
[2020-08-23 03:00:06][SCENARIO] Lancement du scénario : Fermer les volets du bas options : []
[2020-08-23 03:00:06][SCENARIO] Lancement du scénario : Fermer les volets du haut options : []
[2020-08-23 03:00:06][SCENARIO] Fin correcte du scénario

Le virtuel en question qui se met à jour à 3h du mat et qui lancait mon scénario en mode furtif :
Capture d’écran 2020-08-24 à 21.04.43

Que faut-il d’autre ?

Tu es sur d’avoir bien sauvegarder le changement de mode, je viens de revoir tout le code et je vois pas comment c’est possible autrement, c’est filtré au niveau de la requete SQL directement.

Oui, j’avais bien sauvegardé, ce qui d’ailleurs est logique parce que si je n’avais pas sauvegardé, au reload de la page, il m’aurait affiché le select réglé sur « Les deux », non ?
Je suis peut-être tombé sur une faille spaciotemporelle qui a fait que ca a merdé sur ce coup là uniquement.
Mais c’est étrange quand même ^^

Peut être une histoire de cache