Problèmes Boutons/Relais sonoff 4ch pro

Tags: #<Tag:0x00007fe31a15e208> #<Tag:0x00007fe31a15e140>

Salut a tous
J’ai bien cherché mais je n’ai pas trouvé…

J’ai un petit soucis sur l’utilisation d’un Sonoff pro ch4 flashé espeasy.
Je suis sous jeedom V4, sur nuc intel.

J’ai configuré mes 4 relais et 4 boutons.
Les relais fonctionnent bien, meme la remontée d’etat.
(Je n’ai pas de remonté d’etat des boutons qui restent à 1 mais a la limite je m’en fous…)

switch K5 en 1111, K6 0000, S6 en 1

j’ai mis des rules pour que lorsque suis l’appui des boutons physiques le relais s’activent ou se désactivent séparément.

Mais voila ce que j’obtiens : le bouton 1 associé au relais 1 active les relais 1,2,3.
le boutons 2 et 3 n’activent rien du tout et le bouton 4 active et désactive le relai 4 correctement…

Si quelqu’un a une idée je suis preneur…

Merci!

On System#Boot do
 gpio,12,0
 gpio,5,0
 gpio,4,0
 gpio,15,0
endon

//Gestion du wifi
on WiFi#Connected do
GPIO,13,0
notify 1,"Connexion wifi ok sur %ssid% IP: %ip% "
endon

On B1#B1=0 do 
  if [R1#R1]=0
    gpio,12,1
  else
    gpio,12,0
  endif

On B2#B2=0 do 
  if [R2#R2]=0
    gpio,5,1
  else
    gpio,5,0
  endif

On B3#B3=0 do 
  if [R3#R3]=0
    gpio,4,1
  else
    gpio,4,0
  endif
endon

On B4#B4=0 do 
  if [R4#R4]=0
    gpio,15,1
  else
    gpio,15,0
  endif
endon

image
image
image

Salut,

est ce vraiment un problème du plugin jeedom ? Tu ne passes pas par jeedom pour activer une sortie sur appui d’un bouton physique ?

Il manque plusieurs « endon » dans ta règle. Exemple:

Il n’y a donc pas de Endon à la fin de B1 ni de B2. Donc quand tu appuies sur B1, ça active les relais 1,2,3. Pour B4, ta regle est bonne.

Rhaaaa le boulet !
Je teste ça rapidement…
Merci !

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.