Probleme sur un scenario

Tags: #<Tag:0x00007fa7980391b0>

Bonjour,
dans un scenario, j’utilise l’état du mode du thermostat pour déclencher ou pas une programmation.

image

A l’utilisation j’ai ce message d’erreur

Citation
image
et dans les logs du scenario:

Citation
image

Mais dans le testeur d’expression, j’ai bien le résultat

Citation
image
J’ai essayer de créer un nouveau thermostat, mais cela fait toujours cette erreur.
Ce scénario fonctionnait depuis quelque temps sans ces problèmes.
J’ai aussi le même problème sur un autre scénario qui fait référence au mode du thermostat.
Je ne vois pas l’erreur qui peut provoquer cela.
Merci de vos reponses

Bonjour,

Et pourtant… le résultat du testeur d’expression est bien incorrect… car votre expression est aussi incorrect (cela devrait retourner false ou true)
- Mais cela se joue à un détail !

La ' qui termine vos comparaisons n’est pas la même que celle qui la commence. C’est comme si vous aviez utilisé un copier / coller différent du début à la fin.
-\ l’une est droite, l’autre courbée

Voici la même qui fonctionne :

#[Sécurité][Mode sécurité][Mode]# == 'Absence' && (#[Chauffage][Thermostat][Mode]# == 'Confort' || #[Chauffage][Thermostat][Mode]# == 'Confort matin')

Remplacez vos ’ par celle-ci :
' (ou saisissez celle de votre clavier en prenant la même partout).

1 J'aime

Je viens d’essayer de refaire l’ecriture de la fonction « Si » mais j’ai toujours cette erreur

2021-07-22 09:03:53 scenario Expression non valide [#647# != ' Vacances '] trouvée dans le scénario : [programmation][Maison][Prog Chauffage ], résultat : Aucun != ' Vacances '

cela fait comme si il ne trouvait pas le Mode.

Pour l’histoire des guillemets, j’utilise pour ne pas me tromper, la fonction recherche d’une commande pour sélectionner la commande et je rempli les cases demandées, et j’ai vu cette petite différence de guillemets.

La, c’est une autre erreur, le #647# indique que la commande n’est pas bonne. C’est un autre problème.
Elle n’est certainement pas sauvegardée partout. Pour être utilisée dans le testeur d’expression, ou un scénario, il faut que la commande soit sauvegardé AVANT de lancer le testeur d’expression (sinon, il ne la connais pas, il faut alors le relancer, pareil pour les scénarios).

C’est une commande enfin le thermostat qui est en fonctionnement depuis un certain temps et qui est sauvegardé.
Dans le testeur d’expression on voit bien que la commande est reconnue puisque l’on voit : Confort !=‹ Vacances › && Confort != ‹ Off ›
Pourquoi le testeur voit la commande mais pas le scénario ?
En voyant #647# j’ai eu l’idée de recréer un autre thermostat pour essayer et cela a fait le même problème avec un autre numéro, bien sur.

C’est qu’il y a quelque chose de mal écrit ou mal placé.
Si cela fait ça, c’est que Jeedom n’arrive pas à traduire le nom de la commande vs son ID.

Je n’arrive a plus rien comprendre, pour être plus sur, j’ai désinstallé le plugin et refait l’installation, et je me retrouve toujours avec cette erreur en faisant un scénario simpliste.

Citation
image
Et toujours dans les log du scénario :
Citation
image
Expression invalide mais voit bien le mode du thermostat.
et dans le centre de message d’erreur
Citation
image
je n’arrive pas a voir où est l’erreur.

Hello …

Eco sans ' c’est pour jeedom pas pareil que 'Eco'
Pour la commande manquante, elle doit être visible dans les commandes orphelines
A voir si l’option de quotes automatiques y est pour quelque chose…

En tout cas, que le testeur trouve autre chose que le scénario, ça arrive de temps en temps, ils partagent pas le même code, c’est(était) pénible

Bizarrement, j’ai des " pour l’évaluation de la commande depuis mon scénario :
image

(testé avec == 'Eco' et == "Eco")

Je ne sais pas où il va chercher ta valeur du coup si la commande est manquante ?

Et comme pour remplir le SI, tu as bien fait rechercher la commande et sélectionné la commande, je ne comprends pas trop tes logs

Ca y est, grâce a Naboleo j’ai pu retrouver le scenario en fonctionnement, c’est bien a cause de l’option des quotes automatiques, celle ci était décochée, manœuvre que j’ai effectué il n’y a pas très longtemps, suite a une lecture d’un certain poste sur le forum.
Je comprends mieux maintenant car ce scenario fonctionnait depuis un certain temps, je n’avais pas fait le lien entre les quotes auto et ce problème. Maintenant je n’arrive pas a comprendre la raison de l’option de des quotes auto ou pas, car cela apporte plus de soucis, il faudrait que je retrouve le sujet sur le forum.

Pour vous répondre a Noodom, je faisait bien la démarche de rechercher la commande et en remplissant les cases demandées.
Les " sont bien réapparus après l’option cochée.
Un grand Merci à tous …

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.