Problème renouvellement LetsEncrypt

Bonsoir à tous,

Je rencontre un problème lors du renouvellement de mon LetsEncrypt sur raspberry.

J’ai déjà renouvelé plusieurs fois mon certificat sans problème mais je ne sais pas pourquoi aujourd’hui ça coince.


raise ReadTimeoutError(self._pool, None, ‹ Read timed out. ›)
ReadTimeoutError: HTTPSConnectionPool(host=‹ files.pythonhosted.org ›, port=443): Read timed out.
=====================================================

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip
output.

Consult https://certbot.eff.org/docs/install.html#problems-with-python-virtual-environment
for possible solutions.
You may also find some support resources at https://certbot.eff.org/support/ .

Auriez-vous une idée ?

J’ai relancé la commande en ajoutant --default-timeout=1000 :

sudo /etc/certbot-auto renew --default-timeout=1000

Et j’ai maintenant l’erreur :

Collecting python-augeas==0.5.0 (from -r /tmp/tmp.jD2YMPcDvb/letsencrypt-auto-re quirements.txt (line 113))
Downloading https://files.pythonhosted.org/packages/41/e6/4b6740cb3e31b8225209 9994cea751c648b846aa7874343c31d68c2215be/python-augeas-0.5.0.tar.gz (90kB)
Collecting pytz==2020.1 (from -r /tmp/tmp.jD2YMPcDvb/letsencrypt-auto-requiremen ts.txt (line 115))
Could not find a version that satisfies the requirement pytz==2020.1 (from -r /tmp/tmp.jD2YMPcDvb/letsencrypt-auto-requirements.txt (line 115)) (from versions : )
No matching distribution found for pytz==2020.1 (from -r /tmp/tmp.jD2YMPcDvb/let sencrypt-auto-requirements.txt (line 115))
=====================================================

Certbot has problem setting up the virtual environment.

We were not be able to guess the right solution from your pip
output.

Salut…

Le message d’erreur est clair et n’a rien à voir avec un timeout…
Tu ne lances pas le renouvellement du certificat dans les même conditions que lors de la création : venv
Le plus simple c’est de retrouver la manip de l’époque
Sinon tu dois avoir quelque part un répertoire venv quelque part
Dans le pire des cas, tu repars de 0 et tu refais un certificat.
Et si tu n’y arrives vraiment pas, tu t’offres le pack dns de jeedom

Bizarre pourtant j’ai toujours lancé mon renouvellement de la même façon et ça n’a jamais posé problème. Où se trouve ce répertoire venv et que dois-je y faire du coup ?

Je viens de relancer la commande à l’identique (sudo /etc/certbot-auto renew) et ça a fonctionné normalement…
les mystères de l’informatique :grinning:
Merci en tout cas

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.