Problème installation dépendances

Tags: #<Tag:0x00007f283ada8a90>

Exact !
les tickets pour les plugins tiers sont possibles, c’est la réponse du dev que jeedom ne garanti pas

OK, vous avez raison et vu l’ambiance ici, je ne vais pas m’attarder alors.

Je pensais pouvoir trouver des solutions sans me sentir agressé et visiblement c’est pas possible. J’ai toujours été poli et courtois, je ne me suis jamais pris pour une lumière ou un expert linux. Si la règle c’est ça, alors je ne vais pas perdre mon temps.

Il ne me semble pas t’avoir agressé et @Mips non plus.

Le premier message de @lunarok est certes un peu sec mais pas agressif non plus. C’est toi qui l’a attaqué dans ta réponse sur le SAV.

Après si tu ne veux pas continuer on ne va pas te forcer, mais si tu veux de l’aide on est toujours là.

1 J'aime

Même pas que les payants, un utilisateurs avec un pack (donc par exemple une box) il peut faire du ticket sur des plugins tiers gratuits

J’attends que ça de l’aide ! Pas de leçons de morale ou de propos hors sujet.

Ma réponse « hors sujet principal » était donc une réponse à un propos faux de ta part, que @Poumi a corrigé et que je confirmais.
Cela me semble important de ne pas laisser le moindre doute sur un propos faux, cela évitera de répandre une rumeur; ca c’était pour la leçon de morale, vu qu’on se fait accuser, j’ai le droit de la faire…

Pour revenir au sujet principale, (non tu n’as pas « perdu » 7€; btw, sache que le montant du plugin n’est pas le montant que l’on reçoit en tant que dev :wink: ), peux-tu exécuter chacune des commandes suivantes et nous donner le résultat, ceci afin de vérifier les versions de pythons installées;

python --version
pip --version
python2 --version
pip2 --version
python3 --version
pip3 --version

edit: le résultat attendu pour python --version et python2 --version est le même et est Python 2.7.13.
pour python3 cela doit retourner une version de python 3, la 3.4 ou 3.5 à priori selon ta version de debian.
pour les commandes pip, la version python retournée doit correspondre à la version de la commande python.

Et voilà :

jeedom@JEEDOMSVR:~$ python --version
Python 2.7.13
jeedom@JEEDOMSVR:~$ pip --version
pip 9.0.1 from /usr/lib/python2.7/dist-packages (python 2.7)
jeedom@JEEDOMSVR:~$ python2 --version
Python 2.7.13
jeedom@JEEDOMSVR:~$ pip2 --version
pip 9.0.1 from /usr/lib/python2.7/dist-packages (python 2.7)
jeedom@JEEDOMSVR:~$ python3 --version
Python 3.5.3
jeedom@JEEDOMSVR:~$ pip3 --version
pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.5)

Question bête: tu as des erreurs dans http.error?
Tu as installé les dépendances d’autres plugins ou c’est le premier que tu installe?
C’est peut-être un problème plus global que sur le plugin.

Pas d’erreur, mis à part le deprecation (qui n’est donc a priori pas une erreur).

J’ai plein d’autres plugins et protocoles avec dépendances et je n’ai jamais rencontré ce problème…

J’ai, entre autres, zwave, rflink, deconz… tout est fonctionnel

Alors là je sèche…
L’installation des dépendances se fait bien mais elles restent en NOK et pas d’erreur nulle part…
Je sais pas comment ça fonctionne derrière pour le passage en OK, du coup je vais laisser la main si quelqu’un a une idée :cry:

Ok merci. Tu m’as trouvé un peu offensif mais je t’aime bien quand même

Capture d’écran 2020-03-21 à 10.11.56
Voilà ce qui m’a induit en erreur, il est bien écrit dans le démon que les dépendances ne sont pas installées, alors qu’elles le sont dans le log…

Je pense vraiment qu’il y a un problème avec ton plugin. Donc si tu peux m’aider au moins sur le forum, sachant que tu ne réponds pas au ticket jeedom que j’ai ouvert…

Hello,

Merci, j’ai mis à jour pip et j’ai relancé les dépendances. Dépendances installées mais toujours NOK.

Pour info :

jeedom@JEEDOMSVR:~$ python --version
Python 2.7.13
jeedom@JEEDOMSVR:~$ pip --version
pip 20.0.2 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)
jeedom@JEEDOMSVR:~$ python2 --version
Python 2.7.13
jeedom@JEEDOMSVR:~$ pip2 --version
pip 20.0.2 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)
jeedom@JEEDOMSVR:~$ python3 --version
Python 3.5.3
jeedom@JEEDOMSVR:~$ pip3 --version
pip 9.0.1 from /usr/lib/python3/dist-packages (python 3.5)

Par contre dans la log, il me dit que Python 2.7 n’est plus maintenu et qu’il faudrait l’upgrader… Tu en penses quoi ?

@scolaone

Log installe dépendances ?

$ pip list

akenad :slight_smile:

********************************************************
*             Installation des dépendances             *
********************************************************
Atteint:1 http://security.debian.org/debian-security stretch/updates InRelease
Ign:2 http://ftp.fr.debian.org/debian stretch InRelease
Atteint:3 http://ftp.debian.org/debian stretch-backports InRelease
Atteint:4 http://ftp.fr.debian.org/debian stretch-updates InRelease
Ign:5 http://ftp.de.debian.org/debian stretch InRelease
Atteint:6 http://ftp.fr.debian.org/debian stretch Release
Atteint:7 http://ftp.de.debian.org/debian stretch Release
Atteint:8 https://deb.nodesource.com/node_12.x stretch InRelease
Atteint:9 https://repo.mosquitto.org/debian stretch InRelease
Lecture des listes de paquets…
Installation des dépendances apt
Lecture des listes de paquets…
Construction de l'arbre des dépendances…
Lecture des informations d'état…
libffi-dev is already the newest version (3.2.1-6).
libssl-dev is already the newest version (1.1.0l-1~deb9u1).
python-cryptography is already the newest version (1.7.1-3+deb9u2).
python-dev is already the newest version (2.7.13-2).
python-pip is already the newest version (9.0.1-2+deb9u1).
Le paquet suivant a été installé automatiquement et n'est plus nécessaire :
linux-image-4.9.0-8-amd64
Veuillez utiliser « sudo apt autoremove » pour le supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
********************************************************
*             Installation terminée                    *
********************************************************

PIP list :

DEPRECATION: Python 2.7 reached the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 is no longer maintained. A future version of pip will drop support for Python 2.7. More details about Python 2 support in pip, can be found at https://pip.pypa.io/en/latest/development/release-process/#python-2-support
Package                       Version    
----------------------------- -----------
astroid                       1.6.2      
backports-abc                 0.5        
backports.functools-lru-cache 1.5        
beautifulsoup4                4.5.3      
blessings                     1.6.1      
blinker                       1.3        
bluepy                        1.1.2      
chardet                       2.3.0      
configparser                  3.5.0      
construct                     2.10.54    
coverage                      4.5.1      
cryptography                  1.7.1      
Cython                        0.25.2     
docutils                      0.13.1     
duplicity                     0.7.11     
enum-compat                   0.0.3      
enum34                        1.1.6      
futures                       3.2.0      
html5lib                      0.999999999
idna                          2.2        
ipaddress                     1.0.17     
isort                         4.3.4      
keyring                       10.1       
keyrings.alt                  1.3        
lazy-object-proxy             1.3.1      
libopenzwave                  0.3.1      
lockfile                      0.12.2     
Louie                         1.1        
lxml                          3.7.1      
mccabe                        0.6.1      
nose                          1.3.7      
nose-html                     1.1        
nose-progressive              1.5.1      
numpy                         1.12.1     
oauthlib                      2.0.1      
openzwave                     0.3.1      
paramiko                      2.0.0      
Pillow                        4.0.0      
pip                           20.0.2     
pyasn1                        0.1.9      
pycrypto                      2.6.1      
Pygments                      2.2.0      
pygobject                     3.22.0     
PyJWT                         1.4.2      
pylint                        1.8.3      
pyOpenSSL                     16.2.0     
pyserial                      3.2.1      
pyudev                        0.21.0     
pyxdg                         0.25       
requests                      2.12.4     
roman                         2.0.0      
SecretStorage                 2.3.1      
setuptools                    33.1.1     
singledispatch                3.4.0.3    
six                           1.10.0     
tornado                       5.0.1      
urllib3                       1.19.1     
urwid                         2.0.1      
webencodings                  0.5        
wheel                         0.29.0     
wrapt                         1.10.11    

Si :

$ python --version
Python 2.7.x

Faire :

$ sudo python -m pip install future

relancer installe dépendances.

Plus de détails ici : [Présentation] akenad

akenad :slight_smile:

1 J'aime

Hallelujah !!! It works fine !

La conclusion c’est que future manquait ?

future oui, à ne pas confondre avec futures.

akenad :slight_smile:

Top merci beaucoup pour ton aide !

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.