Problème d'installation des dépendances Deconz

Tags: #<Tag:0x00007fa7acc572d0>

Bonjour à tous.

Je viens d’effectuer la mise à jour de Jeedom vers le Debian Buster et je rencontre un souci.
J’étais au préalable sur une version Raspbian lite sur un raspberry pi 3B+ ou tout fonctionnait bien.

J’ai donc fait ma mise à jour ce matin vers le buster et rechargé ma sauvegarde jeedom, mais il m’est impossible d’acceder à ma clef conbee II depuis cette manipulation. J’ai réinstallé les dépendances, essayé de me connecter a la clef avec le bouton qui apparait avec l’ip et le port, essayé de faire une découverte automatique, une recherche de chef api mais rien n’y fait. ma clef conbee reste introuvable selon jeedom…

« Echec de la requête HTTP : 127.0.0.1:8484/api/E1BF564787/config cURL error : Failed to connect to 127.0.0.1 port 8484: Connection refused » est le message qui apparait quand je vais voir dans réseau deconz (la ou il y a les nœuds affichés, ou on sélectionne le canal tout ça)…

>  ********************************************************
> *             Installation des dépendances             *
> ********************************************************
> dpkg: error: dpkg frontend lock is locked by another process
> WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
> E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
> E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
> Hit:1 http://deb.debian.org/debian buster InRelease
> Hit:2 http://deb.debian.org/debian-security buster/updates InRelease
> Hit:3 http://deb.debian.org/debian buster-updates InRelease
> Hit:4 http://archive.raspberrypi.org/debian buster InRelease
> Hit:5 https://deb.nodesource.com/node_12.x buster InRelease
> Reading package lists...
> WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
> E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
> E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
> E: Could not get lock /var/lib/dpkg/lock-frontend - open (11: Resource temporarily unavailable)
> E: Unable to acquire the dpkg frontend lock (/var/lib/dpkg/lock-frontend), is another process using it?
> Uninstalling websocket-client-0.57.0:
> Successfully uninstalled websocket-client-0.57.0
> Skipping websocket as it is not installed.
> Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
> Requirement already satisfied: setuptools in /usr/local/lib/python3.7/dist-packages (52.0.0)
> Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
> Requirement already satisfied: wheel in /usr/lib/python3/dist-packages (0.32.3)
> Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
> Requirement already satisfied: serial in /usr/local/lib/python3.7/dist-packages (0.0.97)
> Requirement already satisfied: pyyaml>=3.13 in /usr/local/lib/python3.7/dist-packages (from serial) (5.4.1)
> Requirement already satisfied: iso8601>=0.1.12 in /usr/local/lib/python3.7/dist-packages (from serial) (0.1.13)
> Requirement already satisfied: future>=0.17.1 in /usr/local/lib/python3.7/dist-packages (from serial) (0.18.2)
> Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
> Requirement already satisfied: pyudev in /usr/lib/python3/dist-packages (0.21.0)
> Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
> Requirement already satisfied: requests in /usr/lib/python3/dist-packages (2.21.0)
> Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
> Requirement already satisfied: serial in /usr/local/lib/python3.7/dist-packages (0.0.97)
> Requirement already satisfied: pyyaml>=3.13 in /usr/local/lib/python3.7/dist-packages (from serial) (5.4.1)
> Requirement already satisfied: iso8601>=0.1.12 in /usr/local/lib/python3.7/dist-packages (from serial) (0.1.13)
> Requirement already satisfied: future>=0.17.1 in /usr/local/lib/python3.7/dist-packages (from serial) (0.18.2)
> Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
> Requirement already satisfied: pyudev in /usr/lib/python3/dist-packages (0.21.0)
> Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
> Collecting websocket-client
> Using cached https://files.pythonhosted.org/packages/4c/5f/f61b420143ed1c8dc69f9eaec5ff1ac36109d52c80de49d66e0c36c3dfdf/websocket_client-0.57.0-py2.py3-none-any.whl
> Requirement already satisfied: six in /usr/lib/python3/dist-packages (from websocket-client) (1.12.0)
> Installing collected packages: websocket-client
> Successfully installed websocket-client-0.57.0
> ********************************************************
> *             Installation terminée                    *
> ********************************************************

c’est le log des dépendances.

j’ai aussi des « Erreur sur la fonction cronHourly du plugin : Echec de la requête HTTP : 127.0.0.1:8484/api/E1BF564787/config cURL error : Failed to connect to 127.0.0.1 port 8484: Connection refused » par moment comme si il ne voyait pas la clef conbee qui pourtant remonte bien avec un lsusb en ssh…
« Bus 001 Device 087: ID 1cf1:0030 Dresden Elektronik »

Des idées du problème ? Merci.

Bonsoir,
Quelle image buster as-tu installée ?
Sur le rpi3b, il est recommandé d’insta!mer la version 32bits

Ah j’ai en effet l’image du 64 bits. Il me semblait que le processeur du 3B+ était 64 bits ? Et en plus c’était une image avec le pi3b+ recommandé ! M’enfin. Je repasserais en 32 si c’est le souci… Merci !

Effectivement, le rpi3b peut fonctionner en 64 bits.
Mais, de ce que j’ai pu lire, cette version serait moins stable, dans le cas de Jeedom, que l’image 32 bits.

Ok j’essayerais ça déjà alors :). Merci

Je ne crois pas trop à la piste 32 bits vs 64 bits.

Question bête : ta clé conbee est raccordée sur le Rpi3 qui supporte jeedom ?
Si oui, as-tu relancé l’installation deconz locale ?
Il faut également que tu restaures la base conbee, par Phoscon.
Si tu ne l’as pas sauvegardé spécifiquement avant ta manip, tu devrais la retrouver dans le backup initial, dans /var/www/html/plugins/deconz/data/

Tu peux jeter un oeil à cette doc : [RTEX] installation Odroid-C4 avec Armbian Buster Kernel 5.9 et migration Jeedom V4

Va un paragraphe « spécificités liées au plugin Deconz et au dongle USB ConBee V2 »

Bon courage …

3 J'aimes

En effet c’était bien ça :

as-tu relancé l’installation deconz locale

non…
Après l’avoir fait tout refonctionne… Merci :).

Peut-être mais vu les remontées sur cette.version autant éviter les problèmes à venir.

1 J'aime

Bonjour,

Vous avez une erreur en 1ere ligne.

A priori, il faut redémarrer et tester l’installation des dépendances de nouveau.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.