Problème d'historisation

Tags: #<Tag:0x00007fa7b1ff6530>

Bonjour @mika-nt28 ,

Je viens d’avoir un gros soucis avec le plugin, si on configure l’historique (champ « Purger l’historique si plus vieux que ») à « Jamais », après sauvegarde il revient d’office à « 1 jour » !!!

Idéal pour perdre TOUS ses histos dans mon cas !!! :triumph: :angry: :sob:

Je suis en Jeedom 4.1

Dans la BdD, l’attribut « Jamais » correspond à "historyPurge":"" , visiblement le plugin n’aime pas ça et met d’office la première valeur de sa liste de validation :frowning:

Bonjour,
C’est le core qui gère les config avancées et les historiques, pas les plugins.
Et tu es en 4.1. En tant que bêta testeurs tu devrais savoir les risques d’une bêta non ?

1 J'aime

Autant pour moi :slight_smile: Mes autres plugin ayant tous été upgradés en v4, j’ai bêtement présupposé que celui la aussi :frowning:

Bon, je met de coté mes histo en .csv

Par contre, peux tu me dire quand (et si) tu comptes faire une mise à jour du plugin, même vaguement ??

Merci d’avance

PS: Hormis ce point, le plugin fonctionne nickel en V 1.4.xx :slight_smile:

Tu parles à qui ?
As-tu lu ma réponse précédente ?
Quel rapport entre un upgrade pour v4 et l’historique ?

Décidément je ne suis pas réveillé, au vu de la réponse … je pensais répondre à @mika-nt28 qui est l’auteur du plugin, j’ai zappé l’auteur, sorry.

Quand a ta question

Quel rapport entre un upgrade pour v4 et l’historique ?

Cf ton message :

C’est le core qui gère les config avancées et les historiques, pas les plugins.

Il est compatible V4
Je n’ai pas souvenir que l’on touche a ce parametre a la sauvegarde et je doute que le core puisse le change tout seul

salut @mika-nt28
Merci de ta réponse,

Je te remet ma comm’ d’origine pour remettre les choses au clair après le brouillage de Mips hier au sujet de la V4.

Je viens d’avoir un gros soucis avec le plugin, si on configure l’historique (champ « Purger l’historique si plus vieux que ») à « Jamais », après sauvegarde il revient d’office à « 1 jour »

La version du plugin : " Version 2020-05-12 18:56:18"

Si tu penses avoir besoin d’un accès à la machine, n’hésites pas

J’ai rien embrouillé !
Tu ne comprends pas que l’écran dans lequel on sauve les options d’historique ne dépendent pas des plugins !
C’est dingue ça…

Ton insistance m’a interpellé !!! Alors j’ai poussé mes investigations :slight_smile:

via le menu Analyse/Historiques/Configuration :
image
Tous se passe bien, modif et enregistrement , on a bien ‹ Jamais ›, après contrôle c’est OK en BdD ( « historyPurge »:"" )

Ensuite on va dans l’écran de config de la commande que l’on vient d’enregistrer (ceci est valable pour N’IMPORTE QUEL PLUGIN) et l’on trouve :
image
et si l’on sauvegarde on a en base de données : ( « historyPurge »:"-1 day" )

Donc effectivement les plugins ne sont pas en cause (desolé @mika-nt28) mais plus probablement un problème du core.
Pour rappel je suis sur NUC intel, Jeedom 4.1.14

Donc pour l’instant j’utiliserais Analyse/Historiques/Configuration pour ce paramètre à titre de contournement jusqu’à nouvel ordre.

@mips je te laisse le soin de retransmettre à qui de droit si tu le juges utile

Je ne suis pas beta-testeur moi, je t’invite à remonter ceci via le salon beta-testeur.
Je suis dev et modérateur, et les modérateurs ne sont pas des intermédiaires entre jeedom et le reste du monde :wink: , en tout cas pas pour tous les sujets.

1 J'aime

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.