Problème de connexion au plugin CloudSync

Tags: #<Tag:0x00007f38635a7970>

Bonjour,
J’ai soumis ce post que l’on m’a demandé de déplacer.
Donc, j’ai des problèmes de connexion avec le plugin CliudSync pro…
D’une part, je ne trouve pas la doc (erreur 404 en cliquant sur la documentation), d’autre part je peux sauvegarder sans renouvellement mais pas avec.
Dans ce cas j’ai le message ”Erreur de configuration : Malformed auth code."
Pourriez-vous m’aider à résoudre ces problèmes?
Merci

Bonjour,

Désolé de ne pas t’avoir répondu plus rapidement mais je n’avais pas vu ton message.
La procédure est la suivante pour Google Drive :

1/ cliquer sur l’URL suivante :
https://accounts.google.com/o/oauth2/auth?access_type=offline&client_id=202264815644.apps.googleusercontent.com&redirect_uri=urn:ietf:wg:oauth:2.0:oob&response_type=code&scope=https://www.googleapis.com/auth/drive&state=93c2bae7de5afb19ed549fd7fa4831f4

2/ indiquer son login/password si non connecté sur Google et autoriser l’application rclone pour accéder au stockage Google Drive du compte

3/ copier le code indiqué dans le navigateur dans le champ ‘Access Token’ ET cocher la case ‘Renouvellement’ pour générer un token permanent pour rclone.

Si le token est valide, le message suivant apparaît et la coche ‘Renouvellement’ est décochée :
“Sauvegarde effectuée avec succès”

N’hesite pas à me contacter en MP si tu as le moindre problème.

2 J'aimes

Merci, je vais essayer dès que possible.
A bientôt

Ça serait bien de fixer ça @thanaus :smiley: Sinon j’ai cru comprendre qu’il fallait installer la beta pour fonctionner sur v4, c’est bien ça ?

Bonsoir,
Ça marche ou pas sur V4?
C’est peut-être pour ça que ça ne marche pas chez moi?

J’ai voulu essayer sur une v4 de test et je n’arrivais même pas à créer un équipement (version stable). Avec la bêta du plugin ça semble fonctionner

Alors je vais attendre un peu.
J’avais installé CloudSync et je n’ai pas réussi à l’utiliser.
Du coup, je l’ai laissé comme ça.
Peu de temps après, je me suis rendu compte que mon Jeedom ramait de plus en plus progressivement sur la version de test qui n’a aucun équipement.
Depuis que je l’ai enlevé, ce phénomène n’existe plus.
Je ne sais pas si c’est lié bien sûr mais bon.

@mich0111, @anon72168185

Le plugin est compatible V4 même si il y aura des glitch à l’affichage car il ne respecte pas encore le design imposé par Jeedom.
Par contre, la version stable n’est pas compatible debian10 (buster) contrairement à la version beta.

Je suis très surpris qu’un plugin sans aucun équipement et aucune cron (donc aucune activité) puisse ralentir ta version de test et je ne pense pas que ce soit le retirer qui ait corrigé ce problème. Tu as sans doute fait d’autres actions en parallèle…

Pour info, la documentation est en cours d’écriture… et de nombreux membres utilisent ce plugin sous Google sans aucun problème (dont moi).
Pouvez-vous m’indiquer ce qui pose problème exactement chez vous ?

Bonjour,
Mon problème est que je crois avoir compris qu’il faille sauvegarder le plugin avec l’option “avec renouvellement” et qu’il m’est impossible de le faire.
J’ai le message d’erreur ”Erreur de configuration : Malformed auth code".
C’est probablement mon token mais je ne vois pas bien pourquoi, j’ai utilisé la procédure standard, la même que pour un token d’une autre application externe qui elle fonctionne.
Quant au ralentissement de ma Jeedom de test, je n’ai pas dit que je suis certain que c’est à cause de ça.
Quand je rencontre ce genre problème, je désinstalle progressivement ce que j’ai installé jusqu’à ce que les choses s’améliorent.
Il se trouve que la suppression de ce plugin à faire disparaitre ce ralentissement. Il y avait peut-être des effets de bord avec d’autres plugins, je n’en sais rien.
Quoiqu’il en soit, je vais attendre la parution de la doc pour suivre la procédure pas à pas, je verrais bien à ce moment-là, j’ai probablement merdé quelque part.
A bientôt

Il faut créer un équipement de type Google et faire un copier/coller dans la zone ‘Access Token’ puis cocher ‘Renouvellement’ et cliquer sur ‘Sauvegarder’ dans la configuration de l’équipement.
Tu cliques bien sur l’URL que j’ai indiqué ? Il suffit juste de faire un copier/coller du token.

Voici un exemple que je viens juste de faire :
image

Je viens de suivre ton post à la lettre du moins, je le crois.
Malheureusement, cela ne marche toujours pas. Après avoir paramétré le plugin, lors de la première tentative de sauvegarde , j’ai le message “Unable to write configuration file ‘/var/www/html/plugins/cloudsyncpro/core/config/rclone.conf’”
A la deuxième, le message “Erreur de configuration : Bad Request”.
Je désinstalle le plugin en attendant des jours meilleurs.
Merci et à bientôt

Merci pour ton retour !
Je viens de mettre à jour en version beta une correction pour ne plus avoir ce type de problème.
Peux-tu refaire un test après avoir mis à jour le plugin (2019-10-28 18:42:42) ?

Entendu, je fais ça dès que possible.
Bonne soirée.

Bonjour,
J’ai tenté de faire la mise à jour mais je ne vois pas comment mettre à jour en beta.
Dans le Market il y a la version 2019-09-24 18:04:27, et dans les paramètres de la configuration Jeedom je ne vois pas d’endroit où dire d’aller chercher les beta des plugins. J’ai essayé de vérifier dans le centre de mise à jour, rien.
Peux-tu me dire comment l’installer?
Merci.

Au fait, je te confirme que ce plugin engendre un ralentissemtn de ma config de test et pas qu’un peu.
Je n’avais plus de problème et, sitôt installé sans aucun paramétrage, ça a recommencé.
A+

Il faut accepter sur ton compte associé au market Jeedom d’installer des versions beta (Profil/Activer l’accès aux plugins beta).
Pour ce plugin, tu n’as aucunement besoin d’installer la version beta du core de Jeedom.
Dès que tu as activé la coche, tu pourra installer le plugin en version beta.

Je ne vois vraiment pas comment un plugin sans aucune commande (et donc sans aucune activité) peut autant ralentir ta config de test. Peux-tu me fournir un accès temporaire à cette configuration que je puisse investiguer ?
En tous les cas, tu es le premier qui me fait ce retour

Pas de problème mais pas avant cet après-midi.
Là je l’ai enlevé et ça ne rame plus.
Je n’affirme rien, je ne fais que constater.

Aucun problème et toujours présent pour essayer de comprendre le pourquoi du comment.
Je te demande donc un accès vu que je ne reproduis pas !
Grand merci pour ton aide…

Vers 14h30 ça t’irait?
Est-ce qu’il y a une manip spéciale pour que tu prennes la main?