Probleme avec param inserer si conso> conso precedente

Tags: #<Tag:0x00007f384cba66a8>

Bonjour
J’ai bien coche le paramètre inserer si conso > conso précédente :

image
Pourtant j’ai toujours des remonté erronées qui m’oblige a des corrections fréquentes
image
Je suis en V 4.0.61 Suiviconso du 30-12-2020
Bonne journée

Bonjour @superbricolo
Que penses tu de mon problème ?? J’ai actuellement de + en + de remontées erronées , et je pense que ca vient de mon ecodevice . Mais si je pouvais les bloquer dans suiviconso ce serait formidable.
Merci

C’est bizarre, car moi aussi j’ai un Ecodevice et pour moi c’est d’une stabilité à tout épreuve

Je pense que mon Ecodevice a un probleme , dans les loges j’ai ca en permanence:
image

Cette semaine j’ai la possibilité d’en tester un autre pour voir… en attendant je cherche la possibilité de bloquer ces données
Sur un autre post tu dis qu’il est preferable de parametre variation … sur chaque equipement…mais sur l’equip Teleinfi cette variable n’apparait pas !!!

C’est pas plutôt un souci réseau. As tu essayé de le pinguer en permanent pour voir. (ping 192.168.1.6 -t sur windows)
Et quand tu accèdes dessus via le navigateur ça donne quoi?
Quel version as t’il?

Ca fait plus de 4 ans que je l’ai… sans aucun problème jusque la… il est a jour firmware, et même ardware car j’ai un Linky.
L’accès réseau est parfait, et le ping aussi même permanent (il faudrait etre devant l’écran a l’instant T ou il bloque ) , j’ai essayé un autre câble réseau, même un autre switch… Bref je ne vois plus que l’Ecodevice (ou peut être le Linky) mais ces problème reseau dans les logs ne me plaisent pas.
Je vais en tester un autre dans la semaine , ca sera vite vu.
J’en serai quitte a le remplacer , mais comme a la fin du mois Enedis va valider mon photovoltaique avec revente du surplus, je ne suis pas sur qu’ils ne basculent pas en Tic Standart… et dans ce cas adieu Ecodevice!!! ca risque de devenir compliqué!!

Au vu de tous les tests que tu as fait, je suis d’accord avec toi. Si tu peux tester un autre Ecodevice, c’est l’idéal.
Le photovoltaïque, Moi aussi, j’ai envie de m’y mettre, mais plutôt en autoconsommation.
Dis moi ce que ton test va donner. Je suis curieux de connaître d’où vient le soucis.

Pas de probleme … je te tiendrai informé

En fait je pense avoir trouvé pourquoi le log conso_configuration n’est pas créé. Il faut que la configuration du niveau de log général soit sur « info ». Le mien était sur « warning » et je n’avais rien.

image

Du coup le log c’est bien créé avec un contenu.
image
Si tu as ce log, tu pourras cocher l’option « VARIATION : Insère si Conso > Conso précédente » et elle devrait fonctionner.

Chez moi il etait aussi sur warning… je viens de faire la modif… a suivre je te tiendrais au courant

Bon je reviens apres quelques heures de fonctionnement : Les infos ne sont plus du tout remontées !!!
Voila quelques copies d’ecran des logs :
image
et j’en ai comme ca des kms

image

J’ai enlevé conso > conso précédente et tout est reparti
(ces copie d’ecran provienne de mon rpitest car sur ma prod l’ouverture de la page des logs est infinie… je pense que je vais devoir vider les logs conso_trame a la main ,mais je ne sais pas trop quel fichier toucher !!)

Je viens de verifier par jeexplorer , c’est mes logs cron_execution qui fait presque 2 Gb !!! si je le supprime, est ce qu’il va se recreer ??

Edit: Je crois avoir compris mon probleme de logs , comme la plupart de mes plugin sont en logs par defaut, ils sont tous passés de warning a info … je viens de rectifier le tir en passant seulement suiviconso a info… et j’ai supprimé le fichier log cron_execution… et il s’est bien recrée

Quand tu supprimes un log, il se recrée automatiquement.
Tu peux aussi diminuer le nombre de lignes permises dans les logs. C’est dans la configuration.
C’est vrai que d’avoir remis les logs pas defaut à info, fait apparaître plein de warning de différent plugin et même du core.

Bon j’ai au moins appris comment se gere les logs…
Maintenant je viens de refaire un essai sur un RPI test de valider conso>conso precedente et ca bloque toujours TOUS les enregistrement… dans suiviconso mon graphique journalier s’arrete a l’heure de la manip

Pour moi l’option est bien coché, et cela n’a rien bloqué.

Je reviens vers toi car j’ai refais tes tests sur ma prod et sur RPI test
Sur la prod des que j’ai validé l’option les données se sont arretées de remonter
Sur le test , les donnees remontent bien mais avec un temps entre 2 données parfois importants (5 a 10mn) en fonction de la conso… ce qui est un peut deroutant car l’affichage de mon graph journalier avance par saccade. Avant j’avais une remontée au max toute les minutes meme si elle etait identique a la precedente… Une suggestion comme ca : conso >= conso precdente !!!
Par contre je ne comprend pas du tout pourquoi sur ma prod ca bloque !!!J’ai verifié la config est identique sur les 2 (le test est une sauvegarde de la prod) .
La difference c’est que sur le test, n’ayant pas de cle zwave, les « enfants » ne remontent rien
Et quand j’enleve la modif sur la prod les données repartent bien mais avec une valeur tres legerement inferieure a celle de l’arret :
image
variable validée a 20H04 et arret a 20H42

Bref j’y comprend plus rien !!!
Peut etre que toutes mes erreurs reseau de l’Ecodevice fait que les données sont passablement erronées.

La valeur validé à 20h42 est bien supérieure à celle de 20h04.
Sinon la différence avec moi est que tu es heure base alors que je suis en HP HC. Mais bon , je suis pas convaincu que cela soit le problème.
Il dit quoi ton log cron_execution. J’ai vu qu’il y avait des warning du plugin quand tu actives l’option avec log général en Info. je viens d’ailleurs de faire un correctif.
D’ailleurs quand tu actives, est ce que les valeurs dans conso_configuration évoluent?

Edit: Est ce que ton démon redémarre bien quand tu actives l’option?

C’est quand j’ai désactivé la variable que la valeur de 20h42 est remontée avec une valeur superieure mais c’est normal je pense.
Dans le cron_execution j’ai des données concernant le plugin kassa et mon onduleur (nut) et je ne vois rien concernant suiviconso
dans conso_configuration il n’y a aucune ligne sup depuis 11h31 (1° essai ce matin)
image
Ne tiens pas trop compte des warnings dans les logs de la copie d’ecran 4 ou 5 messages ci dessus car elle a été faite sur le RPItest, sans cléZwave donc tout un tas de service qui n’ont pas demarrées !!!
Oui le demon redemarre bien a l’activation de l’option … je l’ai meme redemarré pour etre sur 45S apres.

L’horaire n’est pas pertinent. Il reste avec l 'heure de création de la ligne et n’évolue jamais.
Je peux te fournir un source avec des logs, mais maintenant le dernier que j’ai, inclu d’autres modifs notamment l’optimisation des commandes pour l’eau, le gaz et le fioul

Oui j’ai vu sur un autre post ,l’optimisation des commandes

tu veux tenter sur ton jeedom de test?