Problème acces externe Appli mobile en 4G

Bonjour à tous,

j’espère que ce sujet n’a pas été traité. Il est fort similaire à d’autre sujets mais mon problème est plus spécifique et plus étrange…

J’ai un RPI3 avec Jeedom connecté en RJ45 sur mon routeur.
L’adresse IP locale est fixe
Mon adresse IP générale est dynamique mais grace à Dynhost de chez OVH je peux accéder depuis l’extérieur à mon jeedom.

Donc aucun problème pour accéder à Jeedom via:

  • adresse ip locale en local
  • adresse ip en externe via un navigateur
  • Dynhost en externe via un navigateur
  • adresse ip locale en local avec l’appli mobile (smartphone connecté sur Wifi local)
  • Dynhost externe avec l’appli mobile (smartphone connecté sur un Wifi quelconque)
  • adresse IP en externe avec l’appli mobile (smartphone connecté sur un Wifi quelconque)

Par contre impossible de me connecter à jeedom depuis l’extérieur lorsque mon GSM est en 4G… :thinking:

Tout semble correctement paramètré et d’ailleurs comme expliqué ci-dessus toutes les connexions vers Jeedom fonctionnent j’ai donc écarté comme source du problème le passage par OVH.
Le problème ne vient pas non plus de l’application mobile car lorsque j’ouvre une page internet sur mon smartphone et que je tape l’adresse ip de Jeedom toujours en externe.
Ca fonctionne lorsque mon smartphone est sur un Wifi mais ca ne fonctionne pas lorsque je suis en 4G.

Il me reste donc comme source du problème soit:
- Un problème de paramètrage dans Jeedom
- Un problème avec mon smartphone (Sur ce point je précise quand même que tout autre application, site web ou fonctions nécessitant l’utilisation d’internet fonctionne sur mon smartphone lorsque je suis en 4G sinon je ne serais pas ici à vous écrire bien évidemment… :slight_smile: )

Si quelqu’un à une idée…
Merci d’avance à la communauté,

Bonne journée à tous,

Bonjour Labellow,

j’ai la même configuration que toi ou presque, et également passer pas mal de temps à trouver une solution pour moi.
Je t’explique ce que j’ai fais.

Tu as une adresse IP chez toi en 192.168.xx.x. rien de nouveau, mais du fait que l’on a une adresse IP variable et c’est pour cela que tu es passé par OVH dans ce cas il fat que tu renseigne ton adresse IP OVH qui t’a été donné (ex 176.108.XXX.XXX:4949).

Tu mets cette adresse IP dans le lien externe et cela doit fonctionner sans problème.

Peut etre un problème DNS.
Vérifie bien la résolution nom/IP en fonction des tes usages

problème également quand j active en mode local l.utilisateur admin

Bah comme ça c’est dfficile de diagnostiquer.
donne l’url en MP qu’on vérifie au moins le basic et qu’on valide que l’accès externe est ok

J’ai fait la mise à jour V3.3.38 et coché la nouvelle case 4G et miracle, maintenant je peux me connecter à distance !! et je revois mes caméras sur imperihome ! une mise à jour utile ! Merci

Hé Romux elle est ou cette case à cocher
J’ai le même problème
Merci de la réponse et excuse le début, j’étais trop excité !!
Roger

configuration > réseaux … en bas de page

J’avais le même pb, résolu !

Salut à tous,

Merci pour vos nombreuses réponses.
Malheureusement la case “ma connexion est en 4g” ne resoud pas le probleme. Je penses d’ailleurs que cette option est plutôt pour ceux qui ont connecté jeedom à internet en 4g et pas forcément pour ceux qui souhaitent y accéder en 4g.

@coolfunk je ne comprends pas bien ta solution… J’ai donné une adresse ip un jour à OVH et il met à jour cette adresse ip. Redirigé grâce au nom de domaine. Donc je dois renseigner mon nom de domaine dans le champ externe et pas une ip qui changerait de toute façon régulièrement. D’ailleurs comme précisé cela fonctionne en fait quand je ne suis pas chez moi mais uniquement quand mon smartphone est sur wifi. Des que je passe mon smartphone sur 4g je n’ai plus rien.

Je précise également avoir fait des test avec un autre smartphone et c’est pareil. Aucun souci particulier sauf lorsque le smartphone est en 4g.

Salut Labellow,

l’IP en 192.168.xx.x. doit être indiqué sur le lien interne dans ton jeedom et sur ton appli jeedom également.
Et tu renseigne l’IP d’OVH (en 176.108.XXX.XXX:4949) sur le lien externe, également sur jeedom et sur l’appli.

Une question à propose de ca, est ce que tu as accès en 4g à jeedom?
Je ne parle pas de l’appli mais via un navigateur internet (chrome ou IE).

@coolfunk
Salut,

c’est effectivement ce qui est fait sauf que dans adresse externe il n’y a pas d’IP mais le DynDNS de OVH qui pour moi est se compose comme suit: http://aaaaaaa.bbbbbbb.ovh:yyyy

ou yyyy est un numéro de port redirigé ensuite vers le port 80 par mon routeur
et aaaaaaaaa.bbbbbbbbb l’adresse de mon Dynhost

Tout ceci fonctionne d’ailleurs en ce moment je suis à l’extérieur et je n’ai aucun souci pour aller sur mon jeedom via cette adresse.
Le problème se pose lorsque l’appareil sur lequel je veux me connecter est sur une connexion 4G.
D’ailleurs si je bypass l’application et que je tape “http://aaaaaaa.bbbbbbb.ovh:yyyy” sur une page internet c’est le même souci à savoir.
Appareil en wifi ou lan --> OK pas de souci
Appareil en 4G --> rien
image

et le problème est le même que je tape:

http://aaaaaaa.bbbbbbb.ovh:yyyy

ou

http://176.108.xxxx.xxxx:yyyy comme dans ton exemple…

Et aussi quelque soit la machine avec laquelle je veux me connecter (smartphone, tablette, PC, …)

:cry:

Donc tu n’arrive pas te connecter à jeedom de l’extérieur en 4G.
Donc il faut en 1er régler cela et ensuite on verra pour l’appli.

Moi j’ai renseigné dans jeedom (je ne parle plus de l’appli), dans mon port exterieur mon adresse de redirection OVH, qui m’a été donné par eux en fait (http://178.185.145.124:4949).
Avec cela je suis capable de me connecter à jeedom en 4g de l’exterieur.

Est ce que tu as “crée” un service DYNDNS sur ta box pour OVH?
Et accepter l’accès à distance avec l’adresse http://178.185.145.124:4949 sur ta box?

Re,

bon en fait j’ai effectivement fait tout cela par contre je viens de faire un test qui réduit le champ des possibles…
Lorsque je me connecte avec le smartphone d’un collègue cela fonctionne en 4G.
Le problème vient donc soit de mon smartphone (ce qui est étrange car le problème est présent également sur celui de ma compagne).
Soit le problème vient de l’opérateur (ORANGE) car ma compagne et moi même sommes tous les deux sur ce réseau.
Les test que j’ai pu effectuer avec le smartphone de mes collègues sont chez des opérateurs différents (PROXIMUS et BASE en l’occurrence).
Je vais donc essayer de trouver quelqu’un qui est également chez ORANGE et voir si le problème est présent.
Je reviendrai donc compléter le post avec la solution je l’espère…

Merci tout de même d’avoir pris un peu de votre temps pour proposer vos solutions.
++