Prise en compte aléatoire des modes (Plugins Mode, Thermostat, Airzone)

Tags: #<Tag:0x00007f3f24079dc8>

Bonjour,

Je ne sais pas trop comment présenter/expliquer mon problème. Mais, j’ai la chance de pouvoir le reproduire assez facilement !

Lorsque j’'utilise par exemple le bouton « Confort Eté » créé dans le PLUGIN Mode, celui-ci doit appliquer (« en masse ») sur chacun des thermostats composant mon installation le Mode « Confort Eté » (voir ci-dessous).

J’ai 5 pièces, donc 5 Thermostats :

  1. Pièce 1 en « Confort Eté » : 25°c
  2. Pièce 2 en « Confort Eté » : 23°c
  3. Pièce 3 en « Confort Eté » : 27°c

Mon problème est que lorsque je regarde le résultat de l’application du Mode « Confort Eté » sur mes 5 Thermostats. Sur les 5 Thermostats seulement 2/5 Thermostats auront le Mode en « Confort Eté » alors que les 3 autres restant seront à « Aucun » !

Si je reclique sur le bouton « Confort Eté » créé dans le PLUGIN Mode pour réappliquer les modes sur tous mes thermostats j’arrive au final à avoir mes 5 Thermostats tous « alignés ».

Ce comportement est pour moi anormal et rends inutile la notion de Modes du PLUGIN Thermostat.

Je suis disposé à partager du Log, mais de quoi ? Je ne sais pas …

Mon installation :

  • Gainable réversible (chauffage/climatisation) avec PAC
  • Le gainable est piloté par des thermostats Airzone (1 par pièce (5 pièces))
  • Le Airzone est requêté par le Cloud Airzone ou par Jeedom au travers une carte-fille Wi-Fi Airzone.

Domotique :

  • PLUGIN Airzone pilotant … mes thermostats Airzone
  • PLUGIN Thermostat
  • PLUGIN Mode

Détails des composants
PLUGIN Mode :
image

image

image

PLUGIN Thermostat :
image

image

image

Merci de m’avoir lu :slight_smile:

j’ai lu attentivement et à priori si je comprends bien tu as 5 equipements thermostat définis et tu changes le mode des 5 via le plugin mode. tes exemples montrent 2 équipements et pas 5.

A priori ça semble ok pour moi, peux-tu passer les plugins thermostat et mode en debug et lancer ta commande mode puis poster les logs ?

Bonjour @neurall,

Merci d’avoir pris le temps de me lire :slight_smile: . Tu as parfaitement compris ma configuration/installation :wink: .

Effectivement dans les exemples je n’ai mis que 2 des 5 équipements/pièces pour ne pas faire un premier post trop long. Les équipements manquants sont identiques au 2 premiers en exemple, seules les consignes changent (pas de valeurs ajoutés selon moi pour la compréhension de ma problématique ?).

Je viens de passer les PLUGIN Thermostat et Mode en DEBUG et voici les logs :

thermostat.txt (22,1 Ko)
mode.txt (5,2 Ko)

ok c’est plus clair.

quand tu rentre dans un mode on voit qu’il y a bien 5 actions de déclenchées.
Après il faudrait matcher les numéro avec les actions réelles pour voir ce qu’elles font exactement :

Entrée dans le mode Eco Été (mode précédent : Confort Été)

Exécution de l'action #**810**# 
Exécution de l'action #**790**# 
Exécution de l'action #**696**# 
Exécution de l'action #**770**#
Exécution de l'action #**831**# 

sur thermostat :
Température intérieure : 26.3 - Température extérieure : 25 - Consigne : 16
Température intérieure : 26.3 - Température extérieure : 25 - Consigne : 17

tu as deux actions sur le même thermostat qui changent la consigne l’une derrière l’autre.

Entrée dans le mode Confort Été (mode précédent : Eco Été)

Exécution de l'action #1278#
Exécution de l'action #1286# 
Exécution de l'action #810#
Exécution de l'action #1266# 
Exécution de l'action #1304#

Température intérieure : 26.3 - Température extérieure : 25 - Consigne : 16
Température intérieure : 26.3 - Température extérieure : 25 - Consigne : 17
Température intérieure : 26 - Température extérieure : 25 - Consigne : 26
Température intérieure : 26 - Température extérieure : 25 - Consigne : 26
Température intérieure : 27 - Température extérieure : 25 - Consigne : 27

idem des changements consécutifs à 1s d’intervalle à chaque commande, c’est comme si tu changeait le même thermostat. normalement tu devrais avoir 5 équipements thermostat. là on voit le log comme s’il y en avait que 1.

Entrée dans le mode Invité Été (mode précédent : Confort Été)

Exécution de l'action #1278#
Exécution de l'action #1286#
Exécution de l'action #1516# 
Exécution de l'action #1266#
Exécution de l'action #1304#

Entrée dans le mode Confort Été (mode précédent : Invité Été)

Exécution de l'action #1278#
Exécution de l'action #1286# 
Exécution de l'action #810#
Exécution de l'action #1266#
Exécution de l'action #1304#

lorsque tu reviens sur confort été on voit bien les mêmes actions déclenchées.

alors j’ai une question, j’ai l’impression que tes actions de mode changent le MEME thermostat 5 fois de suite et pas 5 thermostats différents vu le log.

Bonjour @neurall ,

Merci pour l’analyse des logs :love_letter: !

Je vais vérifier si je n’ai pas des scénarios ou des actions qui sont déclenchés lors d’un changement de consigne sur mes Thermostats. J’ai mémoire d’avoir réaliser des choses en ce sens.

Il y aurait donc une bataille entre ces actions avec pour gagnant … personne laissant le Thermostat en « Aucun ».

Existe-tèil un outil dans Jeedom permettant de lister tout ce qui est lié au PLUGIN Thermostat Chambre 1 par exemple ?

Bonsoir,

En cliquant sur les commandes, paramètres (roue crantée), vous aurez la liste de tout ce qui contient un lien vers votre commande.

Merci @Fabrice !

J’ai pu faire du ménage dans mes scénarios et automatismes. Ma configuration est à présent normalisée :slight_smile: ! Je n’ai plus aucun soucis.

Mon problème était donc bel et bien une bataille d’automatismes et de scénarios.

Merci encore @neurall pour ton aide :wink:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.