[Plugin Tiers][Sujet Principal] Plugin Onkyo

Tags: #<Tag:0x00007f282dca93e0>

Oui cela n’a aucun impact sur l’aspect fonctionnel du plugin :wink:

Je viens de pousser une mise à jour sur le market :

Ajout de la gestion des commandes et informations :

  • LMD (Listening Mode)
  • IFA (Audio Information)
  • IFV (Video Information)
    Fix du message d’erreur au lancement du démon
1 J'aime

Merci @Dough29 tes le meilleur :wink:

Ho tu sais je fais au mieux :sweat_smile:

Salut Dough29

Merci pour on plugin que j’utilise depuis…longtemps du coup je t’ai envoyé un petit MP mais le mieux étant que je te fasse ma demande ici quand même j’était passé a côté du thread officiel du plugin.

J’aurais aimé rajouter les fonctions de la classe « OSD » en fait la fonction instaprevue « IPV » et exit « EXIT »

Si c’est possbiel, c’est top !

merci et a bientôt

Mise à jour publiée sur le Market :

  • ajout des commandes « OSD »

Merci @johan99 pour la suggestion et les test en beta :sunglasses:

1 J'aime

Bonjour, à quoi servent ces fonctions ?

ce sont les touches des menus audio, video, accès rapides ainsi que haut/bas/gauche/droite, enter, home, …

Ca peut permettre de remplacer quelque peu la télécommande pour afficher et naviguer dans les menus.

Et il y a aussi la commande pour afficher l’InstaPreview qui affiche les autres sources en petits encards à l’écran :sunglasses:

1 J'aime

Merci pour l’info :slight_smile:

salut salut!! je viens de comprendre un truc grâce à cette discussion… et du coup, question pour confirmer…
cette fameuse gestion réseau en veille, qui est souvent génératrice de problèmes chez beaucoup en fait…
perso, je profite de jeedom pour économiser les watts au mieux et demande donc d’éteindre la prise électrique qui alimente tv, ampli etc. (18 watts d’économisés chaque heure mine de rien). mais du coup… jeedom/ton plugin perd le principe de connexion/reconnaissance? c’est ça?
car pareil… tout marche bien théoriquement mais dès que je fais mes délires (scénarios, interactions… ), le plugin ne fait plus rien et n’a aucune remontée d’info. (volume hs, état du power hs etc).
mais si j’ai bien compris, c’est parce que l’ampli est totalement coupé électriquement…?
du coup pas top de solution? ou peut-on faire/forcer un « scan » par le plugin?
en tout cas respect à toi pour ce plugin. j’ai vu onkyo dans le marquet, j’ai eu une larmichette de joie :slight_smile:

au fait, d’ailleurs! @ Dough29
différence entre le wifi et l’Ethernet? perso mon ampli est en wifi… si ethernet… il garderait les infos même courant électrique coupé? (ma) solution serait là.

Je confirme. Si on coupe la prise, on économise mais le démon part en vrille et tout est mort en cas de reprise.

Pour ma part, j’ai laissé le nouvel ampli (j’avais un 636, puis un 696) en hybrid standby. Tout le reste est sur une prise pilotée par Jeedom (et l’harmony).

Par contre, même avec l’ampli en veille, le démon est régulièrement KO. Du coup, je suis resté sur mes scripts d’état ou de pilotage.

1 J'aime

Perso en wifi l’état de veille ne fonctionne que quelques heures puis c’est HS alors qu’en filaire aucun soucis.

Je suis donc resté sur filaire.

1 J'aime

Faut gaffe quand même car couper sec certains équipements régulièrement y aiment pas trop.

1 J'aime

merci à toi pour ta réponse/confirmation. bon, par contre, même si en veille ça plante quand même… sniff. mais la soluce vient peut-être de la réponse de @znation qui confirme qu’en wifi c’est moins bon qu’en filaire. en tout cas, qu’appelles tu rester en scripts d’état ou pilotage?

salut @znation . merci pour ta réponse et la confirmation du filaire. par contre, mode veille oblige. ça confirme. ça serait top que le plugin puisse « scanner » (ou je ne sais pas comment appeler ça) une re détection d’un ampli déjà enregistré. (vu que ça déconne aussi en veille apparemment). en tout cas bien vu le conseil de ne pas couper sec tel un bourrin mais c’était déjà prévu. j’ai un broadlink rm pro qui met tout en veille avant de couper la prise électrique :wink: achat du broadlink suite au cafouillage du plugin onkyo d’ailleurs

Hello,
Je viens d’installer le plugin.
Est-il possible d’ajouter les Preset (NPR) qu’on trouve sur l’interface /station.cgi ?

Merci par avance.
Mathieu

Je viens de mettre à jour la version beta : tu as la possibilité de tester ?

Bonjour,

Jeedom : V3:
Box : Smart
OS : Debian 9

Depuis la mise à jour vers la dernière version je rencontre des problèmes sous le plugin Onkyo avec l’ampli TXNR535, il ne fonctionne plus du tout, voici les logs :

DEBUG:Sat Jun 13 2020 22:17:02 GMT+0200 (Central European Summer Time) > <<< Envoi de la commande "PWR00" à id.13
INFO:Sun Jun 14 2020 05:00:14 GMT+0200 (Central European Summer Time) > Service de callback plugin Onkyo : Ok
DEBUG:Sun Jun 14 2020 05:00:43 GMT+0200 (Central European Summer Time) > <<< Envoi de la commande "PWR01" à id.13
INFO:Sun Jun 14 2020 05:00:43 GMT+0200 (Central European Summer Time) > l'id 13 n'est pas connecté
ERROR:Sun Jun 14 2020 05:00:43 GMT+0200 (Central European Summer Time) > ERROR - sending command:Send command, while not connected
DEBUG:Sun Jun 14 2020 05:00:58 GMT+0200 (Central European Summer Time) > <<< Envoi de la commande "PWR00" à id.13
INFO:Sun Jun 14 2020 05:00:58 GMT+0200 (Central European Summer Time) > l'id 13 n'est pas connecté
ERROR:Sun Jun 14 2020 05:00:58 GMT+0200 (Central European Summer Time) > ERROR - sending command:Send command, while not connected
DEBUG:Sun Jun 14 2020 07:20:41 GMT+0200 (Central European Summer Time) > <<< Envoi de la commande "PWR01" à id.13
INFO:Sun Jun 14 2020 07:20:41 GMT+0200 (Central European Summer Time) > l'id 13 n'est pas connecté
ERROR:Sun Jun 14 2020 07:20:41 GMT+0200 (Central European Summer Time) > ERROR - sending command:Send command, while not connected
DEBUG:Sun Jun 14 2020 07:20:45 GMT+0200 (Central European Summer Time) > <<< Envoi de la commande "PWR01" à id.13
INFO:Sun Jun 14 2020 07:20:45 GMT+0200 (Central European Summer Time) > l'id 13 n'est pas connecté
ERROR:Sun Jun 14 2020 07:20:45 GMT+0200 (Central European Summer Time) > ERROR - sending command:Send command, while not connected
events.js:292
throw er; // Unhandled 'error' event
^
Error: read ECONNRESET
at TCP.onStreamRead (internal/stream_base_commons.js:205:27)
Emitted 'error' event on Socket instance at:
at emitErrorNT (internal/streams/destroy.js:92:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:60:3)
at processTicksAndRejections (internal/process/task_queues.js:84:21) {
errno: 'ECONNRESET',
code: 'ECONNRESET',
syscall: 'read'
}

Bonjour,
j’utilise le plugin depuis 6 mois avec mon TX-RN708, au top fonctionne très bien, juste merci.

J’utilise un module Bluetooth raccordé sur Optique n°2, affecté à la source PORT.
J’aimerai pouvoir choisir cette source (PORT) depuis jeedom mais elle est inexistante dans le plugin. serait-il possible de la rajouter ?
Sinon l’autre solution c’est que je démonte mon meuble pour modifier mon raccordement. (pas très envie)…

Merci par avance de votre aide.