Plugin Sonos controller (sonos3) - Stable - Problème TTS

Tags: #<Tag:0x00007f2834facb80>

Bonjour,

Lorsque je teste la fonction “Dire” de mes sonos, j’ai bien la création du fichier mp3 sur mon nas, mais de taille 0 bytes, et il n’y a pas de son sur mes sonos.
La configuration Samba fonctionne, car j’ai appliqué la même configuration que j’utilise sous Jeedom 3.3.32

Logiciel Jeedom V4 - version 4.0.21
Le plugin Sonos Controller - version 2019-10-08 07:55:54
Version PHP : 7.3.9-1~deb10u1

Dans mon log “sonos3_update”, il y a une erreur sur php7.0-mbstring et php7.0-soap, lorsque je lance une installation des dépendances.

Log :

Launch install of sonos dependancy
Hit:1 http://archive.raspberrypi.org/debian buster InRelease
Hit:2 https://deb.nodesource.com/node_12.x buster InRelease
Hit:3 …
Reading package lists…
Reading package lists…
Building dependency tree…
Reading state information…
smbclient is already the newest version (2:4.9.5+dfsg-5+deb10u1+rpi1).
The following package was automatically installed and is no longer required:
rpi.gpio-common
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Reading package lists…
Building dependency tree…
Reading state information…
E: Unable to locate package php7.0-mbstring
E: Couldn’t find any package by glob ‘php7.0-mbstring’
E: Couldn’t find any package by regex ‘php7.0-mbstring’
E: Unable to locate package php7.0-soap
E: Couldn’t find any package by glob ‘php7.0-soap’
E: Couldn’t find any package by regex ‘php7.0-soap’
Reading package lists…
Building dependency tree…
Reading state information…
libsox-fmt-mp3 is already the newest version (14.4.2+git20190427-1).
sox is already the newest version (14.4.2+git20190427-1).
libttspico-utils is already the newest version (1.0+git20130326-3).
The following package was automatically installed and is no longer required:
rpi.gpio-common
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Everything is successfully installed!

Je pense que cela vient de la version de PHP, le plugin cherche PHP7.0, alors que je suis en PHP7.3.

Merci pour votre aide,
Sylvain

Bonjour,
Non ça vient pas de la je pense mais plus picotts. As tu des erreurs dans http.error ?

Bonjour Loic,

Je viens de vider le log “http.error” et relancer la commande “dire” => Message: “Action excétuée avec succès”.
Je n’ai pas d’erreur de créer dans ce log.

J’ai essayé le plugin “PlayTTS” pour l’installation des dépendances, et cela ne fonctionne pas mieux.

Merci pour ton aide,
Sylvain

Pourrais tu passer le log tts en debug et regarder ce qu’il y a dans celui-ci ?

Bonsoir Loic,

Log “playtts” :

[2019-10-13 18:06:49][DEBUG] : Lancement de : /var/www/html/core/class/…/…/core/php/jeePlugin.php plugin_id=playtts function=remove callInstallFunction=1
[2019-10-14 21:02:44][INFO] : Début d’activation du plugin
[2019-10-14 21:02:45][INFO] : Info sur le démon : {“launchable_message”:"",“launchable”:“nok”,“state”:“nok”,“log”:“nok”,“auto”:0}
[2019-10-14 21:02:45][DEBUG] : Lancement de : /var/www/html/core/class/…/…/core/php/jeePlugin.php plugin_id=playtts function=install callInstallFunction=1

Log “playtts_dep” :

Début de l’installation
Installation mplayer
Reading package lists…
Building dependency tree…
Reading state information…
lsb-release is already the newest version (10.2019051400+rpi1).
mpg123 is already the newest version (1.25.10-2).
mplayer is already the newest version (2:1.3.0-8+b3).
software-properties-common is already the newest version (0.96.20.2-2).
The following package was automatically installed and is no longer required:
rpi.gpio-common
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
Installation PicoTTS
Reading package lists…
Building dependency tree…
Reading state information…
libsox-fmt-mp3 is already the newest version (14.4.2+git20190427-1).
sox is already the newest version (14.4.2+git20190427-1).
The following package was automatically installed and is no longer required:
rpi.gpio-common
Use ‘sudo apt autoremove’ to remove it.
0 upgraded, 0 newly installed, 0 to remove and 4 not upgraded.
(Reading database … 70229 files and directories currently installed.)
Preparing to unpack libttspico-data_1.0+git20130326-3_all.deb …
Unpacking libttspico-data (1.0+git20130326-3) over (1.0+git20130326-3) …
Setting up libttspico-data (1.0+git20130326-3) …
(Reading database … 70229 files and directories currently installed.)
Preparing to unpack libttspico0_1.0+git20130326-3_armhf.deb …
Unpacking libttspico0:armhf (1.0+git20130326-3) over (1.0+git20130326-3) …
Setting up libttspico0:armhf (1.0+git20130326-3) …
(Reading database … 70229 files and directories currently installed.)
Preparing to unpack libttspico-utils_1.0+git20130326-3_armhf.deb …
Unpacking libttspico-utils (1.0+git20130326-3) over (1.0+git20130326-3) …
Setting up libttspico-utils (1.0+git20130326-3) …
Processing triggers for man-db (2.8.5-2) …
Ajout de www-data dans le groupe audio
Fin de l’installation

Merci pour votre aide,
Sylvain

Ok ben là va falloir ouvrir une demande de support

Bonjour, je me permets de rejoindre cette discussion car je me retrouve avec le même problème, est ce que vous aviez trouvé une réponse ou non?
Si je doit également ouvrir une demande support il suffit de me l’indiquer.

Cordialement,

Mathieu

Idem … TTS ko …
Est ce que une réponse officielle existe ???

Oui toujours la même… Faut ouvrir une demande de support vous pouvez sinon passer les log tts en débug et regarder après une demande de tts et essayer de changer le moteur tts dans la configuration de jeedom et voir si ça corrige.

Si ça corrige pas c’est qu’il manque des packet au système.

Et pour information rien a voir avec le plugin qui s’appuie juste sur les fonctions tts du core

Ok, J’ai fait tout ça.
En attente de la retour de ma demande de support alors :slight_smile:
Merci

Je viens de répondre a une demande de support la dessus je pense que c’est toi. Fait l’analyse que je t’ai donné et poste ici sinon je regarde dans la semaine sur ton jeedom

Yes c’est bien moi on a le double canal héhé
J’ai suivi les étapes suivantes:

  • J’ai mis à jour mon système (update / upgrade)
  • j’ai mis à jour les dépendances
  • J’ai supprimé les fichiers déjà existant de 0Ko sur mon NAS - c’est ce point que je n’avais pas pensé à faire …

C’est ok avec les 2 moteurs !!!

Merci !