Plugin SMS et clé Huawei E3531

Tags: #<Tag:0x00007f2830dcccb0>

Bonjour,

Je suis possesseur d’une clé 3G E3531i-2 qui des que je l’insert dans le port USB du RPI3 me bloque tout et j’obtiens le message suivant:

Forbidden
You don’t have permission to access /core/ajax/message.ajax.php on this server.
Server unable to read htaccess file, denying access to be safe

Merci pour votre aide

Je pense qu’une muse à plat des droits ferait l’affaire (configuration / os>_ / remise à plat des droits)

Merci mais cela ne change rien, j’ai même essayé en SSH mais pas mieux. Est ce que cela pourrait venir d’une alimentation trop faible? sachant que je tourne sur un ssd avec une alimentation d’origine raspberry.
Merci

Bonjour @Sebastien,

je pense que ce n’est pas lié à la clé.
C’est probablement lié aux droits d’accès sur un répertoire Apache, déterminé par l’existence dans ce répertoire et le contenu d’un fichier .htaccess.

Je te propose de renommer le fichier “.htaccess” par “htaccess” pour essayer dans un premier temps de désactiver l’interdiction.

Dans l’interface Jeedom :
Roue crantée → Configuration → onglet OS/DB → Système → Administration, Lancer

ou bien si JeedomV4 :
Réglages -> Système -> Configuration → onglet OS/DB → Système → Administration, Lancer

Puis taper la commande personnalisée :

sudo mv /var/www/html/core/ajax/.htaccess /var/www/core/ajax/html/htaccess

akenad :slight_smile:

Bonjour et merci

lorsque je tape cette commande, j’obtiens ce message:
mv: cannot stat ‘/var/www/html/core/ajax/.htaccess’: No such file or directory

@Sebastien,

Que renvoie la commande personnalisée ? :
sudo ls -ial /var/www/html/core/ajax

akenad :slight_smile:

Bonjour,
La commande me retourne ceci:

total 5204
71528 drwxrwxr-x 2 www-data www-data 4096 Oct 4 21:16 .
71527 drwxrwxr-x 15 www-data www-data 4096 Aug 15 20:00 …
62109 -rwxrwxr-x 1 www-data www-data 0 Aug 16 13:21 =0.17.7
62110 -rwxrwxr-x 1 www-data www-data 0 Aug 16 13:20 =2.0
62108 -rwxrwxr-x 1 www-data www-data 0 Aug 16 13:20 =3.0.0
62096 -rwxrwxr-x 1 www-data www-data 0 Aug 16 13:20 =40.6.3
509097 -rwxrwxr-x 1 www-data www-data 1402 Oct 4 21:16 cache.ajax.php
509101 -rwxrwxr-x 1 www-data www-data 15228 Oct 4 21:16 cmd.ajax.php
509118 -rwxrwxr-x 1 www-data www-data 3067 Oct 4 21:16 config.ajax.php
509128 -rwxrwxr-x 1 www-data www-data 2039 Oct 4 21:16 cron.ajax.php
509129 -rwxrwxr-x 1 www-data www-data 2918 Oct 4 21:16 dataStore.ajax.php
60484 -rwxrwxr-x 1 www-data www-data 5127684 Sep 7 17:26 deconz.deb
509136 -rwxrwxr-x 1 www-data www-data 12692 Oct 4 21:16 eqLogic.ajax.php
509139 -rwxrwxr-x 1 www-data www-data 1224 Oct 4 21:16 event.ajax.php
509143 -rwxrwxr-x 1 www-data www-data 3674 Oct 4 21:16 interact.ajax.php
509144 -rwxrwxr-x 1 www-data www-data 11801 Oct 4 21:16 jeedom.ajax.php
509148 -rwxrwxr-x 1 www-data www-data 1867 Oct 4 21:16 listener.ajax.php
509150 -rwxrwxr-x 1 www-data www-data 1629 Oct 4 21:16 log.ajax.php
509154 -rwxrwxr-x 1 www-data www-data 1850 Oct 4 21:16 message.ajax.php
509155 -rwxrwxr-x 1 www-data www-data 2226 Oct 4 21:16 migrate.ajax.php
509163 -rwxrwxr-x 1 www-data www-data 1419 Oct 4 21:16 network.ajax.php
509184 -rwxrwxr-x 1 www-data www-data 2223 Oct 4 21:16 note.ajax.php
509201 -rwxrwxr-x 1 www-data www-data 9089 Oct 4 21:16 object.ajax.php
509205 -rwxrwxr-x 1 www-data www-data 9389 Oct 4 21:16 plan.ajax.php
509213 -rwxrwxr-x 1 www-data www-data 7115 Oct 4 21:16 plan3d.ajax.php
509214 -rwxrwxr-x 1 www-data www-data 5375 Oct 4 21:16 plugin.ajax.php
509218 -rwxrwxr-x 1 www-data www-data 4243 Oct 4 21:16 repo.ajax.php
509223 -rwxrwxr-x 1 www-data www-data 2202 Oct 4 21:16 report.ajax.php
509227 -rwxrwxr-x 1 www-data www-data 14439 Oct 4 21:16 scenario.ajax.php
509229 -rwxrwxr-x 1 www-data www-data 5580 Oct 4 21:16 update.ajax.php
509234 -rwxrwxr-x 1 www-data www-data 9701 Oct 4 21:16 user.ajax.php
509238 -rwxrwxr-x 1 www-data www-data 7172 Oct 4 21:16 view.ajax.php

Les droits système dans /core/ajax sont ceux attendus. C’est surprenant.

Tu peux essayer un autre navigateur ?

akenad :slight_smile:

Bonsoir,
Après plusieurs essais non concluants, j’ai connecté la clé 3G sur un hub alimenté et plus de soucis. Cela devait bien venir d’un défaut d’alimentation ou un coup de chance. Merci quand même pour le coup de pouce :wink:

Je n’avais pas encore vu un problème d’accès à un fichier résolu par un changement d’alimentation.

Sinon sur la E3531 : [Présentation] akenad

akenad :slight_smile:

Il y a un début à tout, maintenant faut voir sur la durée mais pour le moment c’est ok.

Tant mieux, et pour info, l’utilisation d’un hub usb pour les clés 3G est recommandé dans la doc :wink:

Merci, je n’avais pas de hub sous la main au moment la et comme c’est recommandé, c’est pas obligatoire :grin: