Plugin Netamo - Mise à jour 2019-10-09 13:47:32

Tags: #<Tag:0x00007fc8ce743580>

Bonjour

Je viens d’effectuer la mise à jour du plugin Netamo Station (Netatmo weather) et voici mon retour d’expérience

Le changelog

09/10/2019
Support PHP 7.3
Adaptation pour jeedom v4
Refonte du moteur de lien avec Netatmo
IMPORTANT : le widget n’est plus spécifique et passe sur les widgets core (plus configurable)

NB1 : Ma version de Jeedom = V4.0.20

NB2 : De manière générale, avant d’effectuer une mise à jour, j’effectue une sauvegarde externalisée de Jeedom. (Fonctionnant avec ESXi, je prends même une image de VM)

L’ancienne version 2019-03-04 08:39:43 posait un petit problème cosmétique (alignement des widgets) avec la version 4.0.x de Jeedom
Netatmo%201
Avant de lancer la maj, j’ai voulu vérifier les paramètres Client ID et Client secret
Je suis passé par Plugins/Météo/Netamo Station/Configuration
Netatmo%202bis

La roue crantée… pas de panique !
On ouvre une autre session et tout va bien
Si l’on veut vérifier la configuration du plugin, on passe par l’autre chemin qui fonctionne bien : Plugins/Gestion des Plugins/Netamo Station
Mais j’imagine que , comme moi, vous aviez conservé ailleurs vos identifiants :slightly_smiling_face:

La mise à jour est rapide
netatmo%203

Trois constats :

  • Les widgets sont alignés

  • Les valeurs sont à zéro : elles ne le resteront pas longtemps

  • Tous les libellés sont au format “Line”
    Le widget est configurable comme l’indique le changelog

Pour info la mise à jour 2019-10-10 10:45:39 modifie la valeur max de C02

Je viens d’intégrer dans mon 1er post la modification du changelog apportée par la mise à jour 2019-10-09 13:47:32 (par rapport à la V2019-10-09 10:43:39)

Je viens également de supprimer ce passage de mon 1er post

J’ai tenté de créer un widget “humidité” en choisissant une icône de parapluie, puis de l’appliquer sur la commande
Mais cela ne fonctionne pas (CTRL F5 effectué)

N’ayant pas utilisé jusqu’à présent la notion d’icône dans la création d’un widget, je n’avais pas réalisé que l’icône dans le cas d’un widget info ne servait que pour distinguer un widget dans la liste de ses widgets :unamused:

La possibilité d’adapter le widget est un vrai plus

L’ancienne version m’amène à une suggestion plus globale pour le futur, permettre l’adjonction d’icônes aux libellés des commandes “info”

Je réalise bien que cette suggestion peut ne pas intéresser grand monde, que cela représente un gros travail et que la team a suffisamment à faire avec la V4 et autres évolutions

Mettons çà dans une boîte à idées…

Je n’ai pas réussi à modifier l’ordre des commandes.

Bonjour,
Normalement c’est possible il faut mettre une icône a la commande info (ça se fait dans la configuration avancé) et ça devrait suffire

j’ai un probleme depuis la mise a jour. Je l’ai faite cet apres midi et depuis 19h05 le CO2 ne bouge plus.
image

En fait ca bloque par moment d’apres les graph et pas forcement sur tous les modules.
sur certains modules ca ne bouge pas pendant 20mn. le relevé se fait toutes les 10 minutes mainteant ? j’ai parfois des relevés à 10 et d’autre à 20 ou plus

@Jeandohm, tu peux modifier l’ordre des commandes, en passant par “Analyse / Résumé domotique”

Tu trouveras l’équipement “netatmoWeather”, et en cliquant dessus tu obtiendras toutes les commandes

netatmo%2010

Tu pourras alors les déplacer à la souris

1 J'aime

Super, je ne connaissais pas.
Merci. :sunglasses:

1 J'aime

Mille fois merci @loic !

Jeedom est d’une grande puissance !

Comme tu l’indiques, il faut aller dans la configuration avancée d’un équipement
Puis cliquer sur “l’engrenage” de la commande

Je n’avais jamais remarqué dans cette fenêtre, l’option d’icône :

netatmo%2012

Ce qui donne (vite fait) :

netatmo%2011

@xavax59, j’ai fait une rapide vérification de mon historique C02

Je trouve par exemple en juillet, des relevés toutes les heures

Aujourd’hui, je constate en alternance des relevés toutes les 10 minutes et 20 mn

10 mn C’est bizarre car normalement c’est 15. Moi aussi j’ai ça

Attention jeedom lisse les historiques donc regarder le graphique ne donne pas forcément l’heure du relevé

et pour l’histoire de la valeur maximale à 1000 ppm pour le CO2 ? J’attends une mise a jour ou je modifie en manuel ? Je suis le seul dans ce cas ? car la pour le cop ca peut expliquer pourquoi il y a des trous dans les graphiques s’il filtre tout ce qui est au dessus de 1000 ppm

Tous le monde est dans ce cas c’est une erreur de configuration de ma part, j’ai fait la correction en stable ce matin malheureusement je peux pas le corriger chez toi en automatique il faut donc que tu fasse le changement a la main

A je vais aussi le redire la pour la date des valeurs c’est maintenant la date réel des relevé c’est pour ca que même si le refresh est toute les 15min la valeur n’est pas a la date de refresh mais a la date reel du relevé par la station

De mémoire, il me semble que la station locale fait des relevés toutes les cinq minutes et les transmet aux serveurs Netatmo toutes les dix minutes.

Couplé au faite que jeedom recuperer les informations toute les 15min les relevé peuvent effectivement avoir l’air pas fixe mais pourtant c’est bien toute les 15min.

Donc ton plugin doit rapatrier trois mesures toutes les quinze minutes ?

Non il prend la dernière disponible