Plugin Alexa-API s'arrête et redémarre toutes les 5 minutes sur V4

Tags: #<Tag:0x00007f282fedec58>

Bonjour,

J’ai effectué ma migration de V3 à V4, et depuis il semblerai que je rencontre un problème avec le plugin Alexa API (le problème est identique en stable ou beta).

Le plugin arrête et redémarre le deamon toutes les 5 minutes (précisément par ex à 21h00, 21h05, 21h10, etc). Je reçoit donc les notifications d’arrêt. Il arrive aussi fréquemment qu’un problème de connexion sur le port 3456 est en échec (peut être que cela correspond au moment ou le plugin cesse de fonctionner)

Extrait log Alexaapi

[2020-06-02 17:38:02][DEBUG] : Réception données sur jeeAlexaapi [ws-volume-change]
[2020-06-02 17:38:02][DEBUG] : Réception données sur jeeAlexaapi [ws-volume-change]
[2020-06-02 17:38:06][DEBUG] : Réception données sur jeeAlexaapi [ws-volume-change]
[2020-06-02 17:38:06][DEBUG] : Réception données sur jeeAlexaapi [ws-volume-change]
[2020-06-02 17:38:16][DEBUG] : Réception données sur jeeAlexaapi [ws-volume-change]
[2020-06-02 17:40:15][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2020-06-02 17:40:16][INFO] :  Arrêt du service alexaapi
[2020-06-02 17:40:19][INFO] :  Lancement du démon alexaapi
[2020-06-02 17:40:19][DEBUG] : Lancement démon alexaapi : nice -n 19 nodejs /var/www/html/plugins/alexaapi/resources/alexaapi.js http://192.172.1.52 amazon.fr alexa.amazon.fr XcBenHmquc2LMZlTrumjZFVfKtGVnFmX 100
[2020-06-02 17:40:19][INFO] :  Démon alexaapi lancé
[2020-06-02 17:44:53][DEBUG] : Réception données sur jeeAlexaapi [ws-volume-change]
[2020-06-02 17:45:16][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2020-06-02 17:45:16][INFO] :  Arrêt du service alexaapi
[2020-06-02 17:45:19][INFO] :  Lancement du démon alexaapi
[2020-06-02 17:45:19][DEBUG] : Lancement démon alexaapi : nice -n 19 nodejs /var/www/html/plugins/alexaapi/resources/alexaapi.js http://192.172.1.52 amazon.fr alexa.amazon.fr XcBenHmquc2LMZlTrumjZFVfKtGVnFmX 100
[2020-06-02 17:45:20][INFO] :  Démon alexaapi lancé

Rien à signaler dans les autres logs (Alexaapi_dep ou Alexaapi-node)

Je ne sais plus trop quoi faire, j’ai réinstallé la version stable ou beta, refait un scan, mais rien n’y change, pourtant ce plugin fonctionnait bien quand j’étais en V3.

Dernière version jeedom V4 à jour
RPI 2B

Merci pour votre aide

Bonjour @juliengr,

Une piste, voir dans la configuration réseau de Jeedom.
L’ ip interne n’est pas standard, ce serait plutôt 192.168. et non pas 192.172.

akenad :slight_smile:

Bonjour akenad,

L’ip 192.172.1.52 est bien celle de mon jeedom, en vérifiant la configuration, onglet réseaux, l’ip interne est bien la même qui est renseignée, ou as tu vu 192.178 ?

Merci, cordialement

RFC 1918 :
adresses privés (aka interne, aka locale)
10/8
172.16/12
192.168/16

Dans la configuration réseau jeedom, quelle est l’IP indiquée dans gestion avancée/interface ?

akenad :slight_smile:

Je n’ai malheureusement pas trop saisi, mais je suis preneur de l’info pour savoir comment vérifier et éventuellement corriger, tout mon réseau est en 192.172.1.X et cela n’a jamais posé de problèmes sur mes équipements, ni même pour jeedom lorsque j’étais en V3

Dans la config réseau, l’ip indiquée dans gestion avancée est la suivante gérée par mon routeur :
Gestion avancée

Interface IP Mac
lo 127.0.0.1
eth0 192.172.1.52 b8:27:eb:8b:53:0e

Désactiver la gestion du réseau par JeedomMasque IP local (utile que pour les installations type docker, sous la forme 192.168.1.)
127.0.0.1;192.168.
.;10...;192.172..
Ma connexion internet est en 4g (pas coché)
MTU spécifique (expert) : 1300

une autre piste, le cookie d’identification amazon.

akenad :slight_smile:

Je l’ai réinitialisé, c’est pareil :frowning:

Le deamon s’arrête toutes les 5 min, (précisément par ex à 21h00, 21h05, 21h10, etc) puis redémarre. Le problème c’est que si une phrase est demandée pile poil à 21h00 par exemple, j’ai un échec de connexion (puisqu’il est en cours de redémarrage).

Vu, c’est effectivement étrange.
En plus, on voit pas ce qui fait tomber le Daemon

Tu as quoi comme devices ? tu peux me faire une copie d’écran ?

Voici la capture, je vais réessayer de tout supprimer et réinstaller mais je vais devoir revoir mes scénarios tant pis.

Capture

J’ai donc tout réinstallé, pour le moment ca l’air de bien fonctionner. Je refais le point ce soir avant de clôturer si le problème est résolu.

Malheureusement, le problème persiste. La réinstallation complète du plugin n’y aura rien changé :frowning:

Tu sais ce qui s’est passé entre la réinstallation et le début du probleme ?

Tu as essayé de ne gardé qu’un device pour voir lequel pouvait déclencher le souci ?

T’es le seul à avoir cela, on va trouver d’où ça vient mais faut faire pas élimination.

Je n’ai rien fait entre la réinstallation et le debut du problème. Je l’ai refait ce soir, et ca a en effet tenu une 10ene de minutes avant de recommencer toutes les 5 minutes.

Je viens de désactiver tous les devices, et je vais voir le comportement en fonction, je te tiens au courant :slight_smile:

Donc même avec tout de désactivé le deamon redemarre toutes les 5min :

[2020-06-03 20:00:30][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2020-06-03 20:00:31][INFO] :  Arrêt du service alexaapi
[2020-06-03 20:00:36][INFO] :  Lancement du démon alexaapi
[2020-06-03 20:00:36][DEBUG] : Lancement démon alexaapi

Même dans device ?

Excuses moi je n’ai pas compris ta question, ou se situe cette partie ? J’ai désactivé tous les elements présents sous mes amazon echos, ne voyant pas de changements je les ai réactivés.

Merci pour ton aide :slight_smile:

Comme tu avais tout réinstallé, je te proposais de supprimer un a un tes devices pour voir celui qui présent, provoquait ces soucis

Ok je vais les supprimer et regarder

Donc même en ayant supprimé manuellement tous les devices, le problème reste identique, le deamon s’arrete et redémarre chaque 5min précises.

2020-06-03 22:05:12][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2020-06-03 22:05:12][INFO] :  Arrêt du service alexaapi
[2020-06-03 22:05:15][INFO] :  Lancement du démon alexaapi
[2020-06-03 22:05:15][DEBUG] : Lancement démon alexaapi : nice -n 19 nodejs /var/www/html/plugins/alexaapi/resources/alexaapi.js http://192.172.1.52 amazon.fr alexa.amazon.fr P8PrV0Mwh8l32y5nbw4sYg4cNcvnbDHi 100
[2020-06-03 22:05:16][INFO] :  Démon alexaapi lancé
[2020-06-03 22:06:11][DEBUG] : Résultat du checkAuth  OK (1)
[2020-06-03 22:10:13][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2020-06-03 22:10:13][INFO] :  Arrêt du service alexaapi
[2020-06-03 22:10:16][INFO] :  Lancement du démon alexaapi
[2020-06-03 22:10:16][DEBUG] : Lancement démon alexaapi : nice -n 19 nodejs /var/www/html/plugins/alexaapi/resources/alexaapi.js http://192.172.1.52 amazon.fr alexa.amazon.fr P8PrV0Mwh8l32y5nbw4sYg4cNcvnbDHi 100
[2020-06-03 22:10:16][INFO] :  Démon alexaapi lancé
[2020-06-03 22:12:12][DEBUG] : Résultat du checkAuth  OK (1)
[2020-06-03 22:15:14][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2020-06-03 22:15:15][INFO] :  Arrêt du service alexaapi
[2020-06-03 22:15:18][INFO] :  Lancement du démon alexaapi
[2020-06-03 22:15:18][DEBUG] : Lancement démon alexaapi : nice -n 19 nodejs /var/www/html/plugins/alexaapi/resources/alexaapi.js http://192.172.1.52 amazon.fr alexa.amazon.fr P8PrV0Mwh8l32y5nbw4sYg4cNcvnbDHi 100
[2020-06-03 22:15:18][INFO] :  Démon alexaapi lancé

Hello ,

Depuis un petit moment ,
Je constate également que 2 ou 3 fois par semaine le demon est KO.
Je dois régénérer le cookie amazon pour retrouver l’usage du plugin .

image
tu peux essayer ça !

1 J'aime