Perte Evenement Sonoff RFBRidge. Ne se résoud qu'en redémarrant le démon

Tags: #<Tag:0x00007fa7b031cbf8>

Bonjour,
Je suis sous Pi4, sous buster, avec un jeedom4.0.61, et un ewejee en version stable à jour ( en version 2.0.2 du coup ).

J’ai des détecteurs de mouvement associés au RFBridge qui fonctionnent très bien la plupart du temps.
De temps en temps , je constate que les détections ne déclenchent plus les scenarios.
J’ai fait deux vérifications :

  • les évènements de détection sont bien visibles dans ewelink
  • les événements de détection sont bien visibles dans les logs jeedom.

Voici des logs.
Hier, ils ont été déclenchés le matin, puis vers 18h30.
Le matin le scenario a bien été déclenché. A 18h30, j’ai des logs, mais le scenario ne se déclenche pas.
J’ai redémarré le démon et ça fonctionne de nouveau après 19h00.
Ce matin , cela fonctionne toujours

Les logs de 18;30 au moment où ça ne déclenche pas de scenario.

[2021-01-28 18:27:36][DEBUG] : [attribute_update]Device ID = 1000cdc1e7 Nom = Sonoff Allee
[2021-01-28 18:27:36][DEBUG] : [event][old_value][1000cdc1e7] 2021-01-28 18:27:28
[2021-01-28 18:27:36][DEBUG] : [MDNS][Update] {"params":{"configure":true,"rfTrig1":"2021-01-28T17:27:37.000Z","ssid":"TPLinkBDF4C6","bssid":"b0:4e:26:bd:f4:c6"}}
[2021-01-28 18:27:36][DEBUG] : [attribute_update]Device ID = 1000cdc1e7 Nom = Sonoff Allee
[2021-01-28 18:27:37][DEBUG] : [MDNS][Update] {"params":{"configure":true,"rfTrig1":"2021-01-28T17:27:37.000Z","ssid":"TPLinkBDF4C6","bssid":"b0:4e:26:bd:f4:c6"}}
[2021-01-28 18:27:37][DEBUG] : [attribute_update]Device ID = 1000cdc1e7 Nom = Sonoff Allee
[2021-01-28 18:27:37][DEBUG] : [event][old_value][1000cdc1e7] 2021-01-28 18:27:36
[2021-01-28 18:27:37][DEBUG] : [MDNS][Update] {"params":{"configure":true,"rfTrig1":"2021-01-28T17:27:37.000Z","ssid":"TPLinkBDF4C6","bssid":"b0:4e:26:bd:f4:c6"}}
[2021-01-28 18:27:37][DEBUG] : [attribute_update]Device ID = 1000cdc1e7 Nom = Sonoff Allee
[2021-01-28 18:27:37][DEBUG] : [MDNS][Update] {"params":{"configure":true,"rfTrig1":"2021-01-28T17:27:37.000Z","ssid":"TPLinkBDF4C6","bssid":"b0:4e:26:bd:f4:c6"}}
[2021-01-28 18:27:37][DEBUG] : [attribute_update]Device ID = 1000cdc1e7 Nom = Sonoff Allee





Les logs de ce matin ou tout fonctionne :

[2021-01-29 09:19:13][DEBUG] : [MDNS][Update] {"params":{"configure":true,"rfTrig1":"2021-01-29T08:19:12.000Z","ssid":"TPLinkBDF4C6","bssid":"b0:4e:26:bd:f4:c6"}}
[2021-01-29 09:19:13][DEBUG] : [attribute_update]Device ID = 1000cdc1e7 Nom = Sonoff Allee
[2021-01-29 09:19:13][DEBUG] : [event][old_value][1000cdc1e7] 2021-01-29 09:19:12
[2021-01-29 09:19:13][DEBUG] : [MDNS][Update] {"params":{"configure":true,"rfTrig1":"2021-01-29T08:19:12.000Z","ssid":"TPLinkBDF4C6","bssid":"b0:4e:26:bd:f4:c6"}}
[2021-01-29 09:19:13][DEBUG] : [attribute_update]Device ID = 1000cdc1e7 Nom = Sonoff Allee
[2021-01-29 09:19:13][DEBUG] : [MDNS][Update] {"params":{"configure":true,"rfTrig1":"2021-01-29T08:19:12.000Z","ssid":"TPLinkBDF4C6","bssid":"b0:4e:26:bd:f4:c6"}}
[2021-01-29 09:19:13][DEBUG] : [attribute_update]Device ID = 1000cdc1e7 Nom = Sonoff Allee

Les logs du scenario ( ou on voit que la détection d’hier matin a fonctionné, ainsi que celle peu après 19h00 une fois le démon redémarré, mais pas de trace de celle de 18:30 ).

[2021-01-28 05:59:01][SCENARIO] Start : Scenario execute automatiquement sur evenement venant de : [Aucun][Sonoff Allee][Bouton1 Info ch1].
[2021-01-28 05:59:01][SCENARIO] Exécution du sous-élément de type [condition] : if
[2021-01-28 05:59:01][SCENARIO] Evaluation de la condition : [ 0=0] = Vrai
[2021-01-28 05:59:01][SCENARIO] Exécution du sous-élément de type [action] : then
[2021-01-28 05:59:01][SCENARIO] Affectation de la variable DeclencheurSonoff => Electrificateur = Electrificateur
[2021-01-28 05:59:01][SCENARIO] Lancement du scénario : Mouvements Sonoff options : []
[2021-01-28 05:59:02][SCENARIO] Exécution de la commande [Technique][Telegram][toto] avec comme option(s) : {"background":"0","title":"","message":"Electrificateur :
1:2021-01-28T04:59:01.000Z
2:2021-01-26T18:03:16.000Z"}
[2021-01-28 05:59:02][SCENARIO] Fin correcte du scénario

[2021-01-28 19:17:42][SCENARIO] Start : Scenario execute automatiquement sur evenement venant de : [Aucun][Sonoff Allee][Bouton1 Info ch1].
[2021-01-28 19:17:42][SCENARIO] Exécution du sous-élément de type [condition] : if
[2021-01-28 19:17:42][SCENARIO] Evaluation de la condition : [ 0=0] = Vrai
[2021-01-28 19:17:42][SCENARIO] Exécution du sous-élément de type [action] : then
[2021-01-28 19:17:42][SCENARIO] Affectation de la variable DeclencheurSonoff => Electrificateur = Electrificateur
[2021-01-28 19:17:42][SCENARIO] Lancement du scénario : Mouvements Sonoff options : []
[2021-01-28 19:17:42][SCENARIO] Exécution de la commande [Technique][Telegram][toto] avec comme option(s) : {"background":"0","title":"","message":"Electrificateur :
1:2021-01-28T18:17:42.000Z
2:2021-01-26T18:03:16.000Z"}
[2021-01-28 19:17:43][SCENARIO] Fin correcte du scénario

J’ai pris l’habitude de tester à intervalle régulier que ça fonctionne toujours mais je suis embêté les fois où ça arrête de fonctionner la nuit.
J’ai même soucis que je sois en mode cloud seul ou cloud plus lan.
Je n’ai pas de logs indiquant une perte de connexion cloud.

C’est clairement pas une méga urgence mais je suis preneur de billes sur ce que peux faire pour résoudre le problème.
En espérant avoir donné toutes les infos nécessaires.

ConfigRFBridge ConfigScenario

Bonjour,

Merci à l’avenir d’utiliser les balises </> pour insérer vos logs pour une meilleurs lisibilité pour tout le monde.

ou envoyer un message privé à @sheldon-bot démarrer tutoriel avancé pour apprendre à utiliser les menus :wink:

Je n’y manquerai pas.
Merci d’avoir corrigé pour moi.

Hello,

Il me faudrait le log ewejee_node stp

Bonjour.
Les voici.
Comme ils ne sont pas horodatés, je ne sais pas dire si ils ont rollé, ou si ils couvrent toujours la période problématique.
Je suis passé sur la dernière version du core jeedom hier (4.1.18).
Tous mes plugins sont à jour dans la dernière version stable.

ewejee_node.txt (71,3 Ko)
Merci d’avance.

C’est ce que je pensais, il est planté ça a été corrigé dans la dernière bêta d’hier.

Merci beaucoup.
Je passe en bêta.
Et encore merci pour ce plugin et la réactivité.

1 J'aime

Bon.
Au vu du gros disclaimer de l’équipe jeedom sur tout installation de plugin en beta, et n’ayant qu’un seul jeedom ( celui de production ),je vais rester en version stable. :slight_smile:

Ok en attendant, tu peux relancer le démon cloud toutes les heures pour être sûr qu’il tourne correctement