Perte de connexion internet = plus de jeedom en local

Bonjour,

J’ai eu une perte de connexion de SFR pendant 3j, donc box et wifi opérationnel mais pas de connexion internet.

Grace à ça je me suis rendu compte d’une très grosse faille du système, Jeedom n’exécuté plus mes scénario (notamment celui de la lampe XIAOMI Gatexway de ma fille), rien dans les logs sur 3J….Pourtant accessible et pilotable manuellement via l’adresse 192.168…. déclenchement du scénario par un programme horaire (perte de l’heure jeedom sans connexion internet ?)

Idem sur les modules ShellyPlug-S plus de pilotage même en manuel, en revanche les Shelly 1PM RAS…

Pourquoi, et quelle solution apporter ?

Probablement parce qu’elle utilise un système de clound?

xiaomi c pas le truc chinois qui passe par un serveur en chine pour allumer la lampe à 1m de toi ?

:thinking:

7 J'aimes

Hello,
J’avais noté que jeedom utilise des polices cloud (celle de google), et que donc, sans internet, impossible d’afficher l’interface web local de jeedom car les polices n’étaient pas accessibles (sauf si elles sont en cache) (Je trouve ca dommage d’ailleurs).
Mais je n’avais pas noté de problème de fonctionnement autonome sans internet (sauf bien sur, sur les plugins utilisant un cloud).
Pour Xiaomi, je peux me tromper, mais je crois que le plugin utilise un hack (le mode developpeur) de la gateway pour l’attaquer sur une API local il me semble… Etrange donc que ca ne marche plus.
Peut-etre un engorgement des scenarios / plugin suite a des timeouts en serie sur des plugins cloud?
Sujet a creuser…

Autre piste : ta box fonctionne encore sans internet? (je parle du wifi et du dhcp)

What ?? Tu peux développer là, parce que à ma connaissance (et je suis un peu sur l’ui depuis la 4.0) ce n’est absolument pas le cas, toutes les fonts sont en local.

Le css de roboto utilisé sur 99% du core (à part bloc code et logs, mais même principe) : https://github.com/jeedom/core/blob/alpha/3rdparty/roboto/roboto.css

La même pour le code : https://github.com/jeedom/core/blob/alpha/3rdparty/camingocode/camingocode.css

Je suis peu être passé à coté de quelque chose car loin d’être infaillible, mais tout a été fait pour que le Core tourne sans soucis sans internet et n’aille rien chercher sur le net.

Hello @kiboost,
Je faisais référence à ca : https://forum.jeedom.com/viewtopic.php?t=47322
De mémoire, c’était les lib Highchart qui utilisaient des fonts/css google.
MAis je viens de voir que ca date un peu maintenant, et si tu me dis que ca n’est plus le cas, ca me va bien :smiley:

Faudra que je revérifie sur des libs externe pour être sur car en effet ça ne doit pas … si tu voit qql chose remonte le.

Je viens de revérifier avec un petit F12, et il semblerait que ca ne soit plus le cas…
Désolé, j’étais plus à jour :slight_smile:

Y’a plus grand chose en commun avec une v3 dans le core :rofl:

3 J'aimes

Et ca se voit! la fluidité et le temps de chargement sont largement meilleurs effectivement (je suis sur jeedom depuis 2015 de mémoire, donc sur la v2…)
Mais désolé pour l’anachronisme de ma remarque sur les url google du coup. :smiley:

1 J'aime

Oui ma box avait bien le wifi qui fonctionné. C’est grace à ca que je pouvais piloter mon jeedom via l’adresse ip 192.168.1.1

Euh… rassures-moi, 192.168.1.1, c’est bien l’adresse de ton jeedom, et pas de l’interface d’admin de la box?

Si pardons je suis un boulet. C’est un autre chiffre mon jeedom :slight_smile: mais le principe reste le même. C’est bien pour cela que je ne comprends pas.

D’après vos retours je comprends le xiaomi, qui passe forcément par sa passerelle en Chine et donc un besoin de connection (ce qui est complément con et du coup très très embêtant).

Mais pour les scénarios qui ne ce sont pas déclencher je ne comprends pas.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.