Pb install plugin dépendance Zwave

Tags: #<Tag:0x00007f2834dd6c20> #<Tag:0x00007f2834dd6ae0>

Je n’ai jamais modifié la configuration du port, c’est toujours resté sur auto.

zwave

Alors, il va falloir être départagé par d’autres, on a une différence d’opinion.
Ce n’est pas bien grave.
Si ça marche comme ça pour toi comme ça tant mieux, moi ça n’a jamais marché en auto.
D’ailleurs ce n’est vrai par que pour le z-wave, tous mes ports sont en durs aucun en auto.

Ça ne tranche pas le débat mais, en lisant la doc, je suis tombé sur ça :

Screenshot_20200124_233040

T’as du le chercher loin celui-là car il me semble bien qu’il est/était conseillé de laisser le port sur Auto (si j’ai du temps à perdre je chercherais…)

Perso j’ai toujours laissé le port sur Auto sur toutes mes installs et aucun problème. De plus ça n’a aucun lien avec l’installation des dépendances.

bref…

Salut,

C’est quoi comme machine physique ? debian à jour sudo apt-get update && apt-get upgrade ?

Problème avec Louie je peux me tromper mais ça sent le conflit sur une version de python.

Tu utilises d’autres logiciels que Jeedom sur ta machine ? L’environnement de bureau debian est installé ?

2 solutions:

  • tenter de réinstaller les paquets qui posent problème dans cette idée:
apt update
apt upgrade
pip install --upgrade setuptools
python -m pip install --upgrade pip
python3 -m pip install --upgrade pip

Je ne dis pas que ça va corriger, c’est plutôt une piste pour investiguer.

  • sinon réinstallation de debian et de jeedom et restauration.

A voir si d’autres jeedomiens avisés ont une meilleure solution :wink:

Édit: je viens de voir que @cadavor avait déjà donné cette piste. C’est à creuser sinon le plus simple sera de réinstaller

La page santé jeedom est toute au vert?

Hello,
Pour ma part j’ai toujours mis sur auto car justement quand je spécifie le port je n’ai que des soucis :sweat_smile:

Puisqu’il semble que j’'avance es trucs sans source, juste pour embêter le monde.

Est-ce que lire la doc du plugin z-wave c’est aller chercher loin?
D’ailleurs, dans cette même doc, il est marqué que le mode auto ne fonctionne “qu’avec” les clés. Cela me semble déjà limitatif.
Je me suis arrêté très vite dans la recherche.
Dernier point, ces insinuations me gonflent sérieusement, au lieu de passer son temps à dénigrer, il serait souhaitable d’être constructif.

https://forum.jeedom.com/viewtopic.php?f=67&t=45558&p=779139&hilit=port+z+wave&sid=4f70de74c6a612563a3747d285e59a0e#p779139




Bonjour,

Sans rentrer dans le débat auto ou non, le fait de passer le port sur une valeur “en dur” n’a permis de corriger (selon tes sources) que des problèmes de démarrage du démon et non de compilation des dépendances.
Cela est cohérent avec le fait que lorsqu’on change le port il n’est nul part indiqué qu’il faille recompiler les dépendances.

D’où les incompréhensions persistantes observées sur ce sujet bien que d’autres personnes t’aient faite la même remarque.

2 J'aimes

Tu noies le poisson ici.

Il est juste question de :

puis :

Ta réponse :

Si tu restes toujours sur cette position alors merci de me donner tes sources.

Bonjour,

Ecoute, c’est le week-end, il ne fait pas beau mais ce n’est pas grave.

Je propose une solution, si tu estimes qu’elle n’est pas bonne, je respecte ton avis.

Est-ce que ça règle le problème des dépendances ou du daemon ? Je ne saurais être catégorique mais manifestement ça règle un problème.

Je me suis contenté d’appliquer une règle que d’autres appliquent également.

J’ai extrait une partie de la doc du plugin où il est noté d’une part que le mode auto ne fonctionne “qu’avec” les clés USB et d’autre part que s’il y avait un problème, il fallait vérifier que le port USB était le bon.

A preuve les posts que j’ai mis en exergue.

Maintenant, je te le répète si ça marche autrement pour toi, tant mieux.

Bonne journée

Bonjour @gls50,

l’analyse et les recommandations de @Salvialf sont excellentes.
Ton problème d’installation des dépendances du plugin Zwave est lié à un problème de consistance de python et ses modules dans ton installation.
La description de ton matériel et de ton système mériterait d’être un peu plus précis que “DIY” et “machine physique debian 9”.

La version du système s’obtient
dans Jeedom : Analyse -> Santé
Version OS : …

Quelques exemples de matériels et de systèmes ici : [Présentation] akenad

akenad :slight_smile:

1 J'aime

Bonjour, voici les info complémentaires. Pc Atom X5 z8350 , 4Go ram SSD 64 Go.

image

Je vais modifier ma présentation.

Merci

D’après le support se serai la version de PIP qui n’est pas bonne , le python est bon:

sup: Ok vous etes donc en DIY pouvez vous verifier que la version de python par defaut et bien la 2 et si c’est pas le cas bien la mettre sur 2 (tout comme la version pip)

root@Jeedom2:/home/gls50# pip --version
pip 20.0.2 from /usr/local/lib/python3.5/dist-packages/pip (python 3.5)

Est ce que quelqu’un connait la procédure pour changer la version ?

Merci

Oui donc ça correspond bien à ce qu’on te dit… ouf :sweat_smile:

Tu peux essayer ça (sans conviction):

sudo easy_install pip==1.5.6

Tu peux creuser plus loin mais tu auras plus vite fait de faire une réinstall totale selon moi…

root@Jeedom2:/home/gls50# easy_install pip==1.5.6
WARNING: The easy_install command is deprecated and will be removed in a future version.
Searching for pip==1.5.6
Reading https://pypi.org/simple/pip/
Downloading https://files.pythonhosted.org/packages/3f/08/7347ca4021e7fe0f1ab8f9 3cbc7d2a7a7350012300ad0e0227d55625e2b8/pip-1.5.6-py2.py3-none-any.whl#sha256=fbc 1351ffedf09ca7560428758845a88d648b9730b63ce9e5df53a7c89f039a4
Best match: pip 1.5.6
Processing pip-1.5.6-py2.py3-none-any.whl
Installing pip-1.5.6-py2.py3-none-any.whl to /usr/local/lib/python3.5/dist-packa ges
Adding pip 1.5.6 to easy-install.pth file
Installing pip3.4 script to /usr/local/bin
Installing pip3 script to /usr/local/bin
Installing pip script to /usr/local/bin

Installed /usr/local/lib/python3.5/dist-packages/pip-1.5.6-py3.5.egg
Processing dependencies for pip==1.5.6
Finished processing dependencies for pip==1.5.6
root@Jeedom2:/home/gls50# pip --version
pip 1.5.6 from /usr/local/lib/python3.5/dist-packages/pip-1.5.6-py3.5.egg (pytho n 3.5)

Même erreur dans l’install des dépendances. Ca sent la reinstall. Y a t’il une procédure par rapport au mdp bdd avant formatage, J’ai vu que certain on des pb de restauration de sauvegarde.

ton python est aussi routé sur python3 par défaut probablement, tape: python --version qui doit retourner Python 2.7.13
(python3 --version pour python3)

regarde si tu as un alias pour “python”: alias
si oui tu peux taper: unalias python

Pour pip pareil: pip --version doit retourner python 2.7
(pip3 --version) pour python3

pour installer pip pour python2: sudo apt install python-pip

root@Jeedom2:/home/gls50# pip --version
pip 1.5.6 from /usr/local/lib/python3.5/dist-packages/pip-1.5.6-py3.5.egg (python 3.5)
root@Jeedom2:/home/gls50# apt install python-pip
Lecture des listes de paquets… Fait
Construction de l’arbre des dépendances
Lecture des informations d’état… Fait
python-pip is already the newest version (9.0.1-2+deb9u1).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
root@Jeedom2:/home/gls50# pip --version
pip 1.5.6 from /usr/local/lib/python3.5/dist-packages/pip-1.5.6-py3.5.egg (python 3.5)
root@Jeedom2:/home/gls50# python --version
Python 2.7.13
root@Jeedom2:/home/gls50# python3 --version
Python 3.5.3
root@Jeedom2:/home/gls50#

Le pb ,je pense, c’est que pip --version me retourne une reponse avec python3 et non 2.
Comment faire ?

Après réinstallation complète ça fonctionne.
Merci à tous ce qui m’ont aidé

J’avais le même message d’erreur, donc si quelqu’un retombe la dessus, une solution simple (qui a fonctionné chez moi en tout cas) :

Réinstaller/repointer python2 as default :
pip2 install --upgrade --force pip
ou, plus explicite :
python2 -m pip install --upgrade --force pip

->

Collecting pip
  Using cached pip-20.0.2-py2.py3-none-any.whl (1.4 MB)
Installing collected packages: pip
  Attempting uninstall: pip
    Found existing installation: pip 20.0.2
    Uninstalling pip-20.0.2:
      Successfully uninstalled pip-20.0.2
Successfully installed pip-20.0.2
-----
Check : 
# pip --version
pip 20.0.2 from /usr/local/lib/python2.7/dist-packages/pip (python 2.7)
# pip3 --version
pip 20.0.2 from /usr/local/lib/python3.5/dist-packages/pip (python 3.5)

Et pip3 et bien toujours là :smiley: ouf !..

Note: une telle erreur dans les dépendances :

Requirement already satisfied: urwid in /usr/local/lib/python3.5/dist-packages (2.1.0)
Collecting louie
  Using cached Louie-2.0.tar.gz (13 kB)
    ERROR: Command errored out with exit status 1:

Qui peut donc se reproduire en ligne de commande en tentant :
pip install louie
-> même message d’erreur, donc aucun lien avec les ports, etc…

Merci, pour toutes ces infos qui m’ont permis de corriger le même problème. C’est pourtant une install complète toute fraîche avec seulement jeedom dans une vm.
Pour moi la commande de idalys a fonctionné et a corrigé le problème.

Par contre juste une précision, il faut exécuter la commande en root ou avec sudo.

sudo pip2 install --upgrade --force pip