Passage V4

Bonjour, Comment passer aisément à la version 4?
Le module de mise à jour me dit que la 3.3.49 est la dernière?

(VM sur QNAP en Debian)

Si le sujet est ailleurs et que je ne l’ai pas trouvé, je suis vraiment désolé :slight_smile: je vous jure que j’ai cherché et tout ce que j’ai supposé après avoir un peu lu c’est qu’il faut faire un backup, effacer et installer.
Le soucis c’est que j’ai récupéré ma version ce jour avec wget https://raw.githubusercontent.com/jeedom/core/master/install/install.sh
et je ne comprend pas pourquoi je ne me retrouve pas avec la dernière version.

Merci!derniere version jeedom

Tout est là Core "Release Candidate V4"

Bonjour

En complément, voici comment j’ai fait: Ma migration V4

Si tu utilises des widgets particuliers, il faudrait mieux tester avant sur une vm.

Attendez, le V4 n’est pas considérée stable? Je l’ai découvert en voyant le plugin enphase https://market.jeedom.com/index.php?v=d&p=market_display&id=3992 qui n’est pas compatible avec ma version.
Je vous avoue que j’essaie d’en faire le moins possible, étant mauvais en informatique et pas versé à l’idée de versions alpha, beta… .
Je suis un peu perplexe sur le fait qu’un plugin ne soit pas compatible avec la dernière version stable que me propose le centre de mise à jour! ça voudrait dire que le nouveau plugin développé n’est accessible que sur des versions release candidate?

Sinon je laisse tomber l’idée du plugin si version 4 est non stable. Mais je n’ai pas de widgets spécifiques, j’utilise juste homebridge quasi exclusivement.

Merci,

Ok, j’ai compris : wikipedia est mon ami : :slightly_smiling_face:

Bon, j’essaie

L’article cité en référence date de octobre 2019. Depuis, il y a eu du progrès et la dernière version est en stable.
Depuis 10j que j’ai installé la v4, je n’ai eu absolument aucun problème de fonctionnement .

Tout les plugins sont sensé être compatible v3 (et v4), c’est une exigence que l’équipe a donné à tous les devs tiers, donc j’imagine que c’est pareil pour les plugins officiels :wink:

Bonjour,

Le plugin est compatible V4 en plus de la version 2.3 minium, c’est indiqué dans la partie informations du plugin.

Bonjour @seb009,

Comment passer de V3 à V4-stable : [RTEX] Debian 10 - Buster - netinst - amd64 - Jeedom V4

akenad :slight_smile:

Peut on installer la V4 sur un nouvel rpi 4 (buster) puis injecter sa sauvegrde V3 rpi2 (jessee) afin de récupérer sa conf (scénarios, plugin, capteur etc) ?

Hello
Oui, pas de souci. par contre après avoir injecter ta sauvegarde tu te retrouveras en V3.
Si tu veut passer en V4, il te suffiras de refaire la mise à jour.

alors il faut mieux installer une V3 sur une distrib buster pour restaurer une save v3 ou peut importe ?

Non, aucune incidence. Tu peux installer la V4.
Je tourne en V4 depuis plusieurs mois, et aucun souci.
Vivement la V4.1 :grinning:

non mais je voulais dire pour repartir à 0 et restaurer une save v3 (mais le but est bien de passer en 4 mais sur un nouveau rpi)

Oui, tu installe la V4 en partant de 0, il n’y a pas de problème.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.