[ Nissan Leaf connect ] Demande de testeur

Tags: #<Tag:0x00007f38536906a8>

Salut,

Je viens de mettre a jour, mais je ne peux pas tester moi meme… merci de me dire si cela fonctionne.

1 J'aime

Bonjour,

Je viens de mettre à jour le plugin.

Cela marche, merci c’est super.

Nicolas

Merci pour les infos, cool !
Tu t’y connais un peu en dev/git ? tu veux reprendre le plugin ? ( au moins m’aider ? )

Ben heu… En dev, j’y capte pas grand chose… Et je rend ma Nissan dans 3 mois.
Mais testeur tant que tu veux :wink:

Bonjour,
Je fais un ptit retour après plusieurs jours avec la maj du plugin.
J’ai plusieurs fois par jour ce message d’erreur : “Erreur sur la fonction cron15 du plugin : Request for ‘BatteryStatusCheckRequest.php’ failed. Response received: {“status”:503}”
Le dernier en date c’était il y a 10 minutes quand j’ai voulu faire un refresh manuel.

Je veux bien faire testeur, mais par contre je n’y connait rien en dev…

Bonjour,
Je serai testeur avec plaisir.
Merci pour le Plugin

Salut,
je peux aider pour tester/dev si besoin !

Salut,
(Je suis en train d’utiliser Google Traduction)

Je ne peux pas installer les dépendances:

une solution quelconque?

********************************************************
*             Installation des dépendances             *
********************************************************
Obj:1 http://security.debian.org/debian-security buster/updates InRelease
Obj:2 https://deb.nodesource.com/node_10.x buster InRelease
Des:3 http://ftp.es.debian.org/debian buster InRelease [121 kB]
Des:4 http://ftp.es.debian.org/debian buster-updates InRelease [51,9 kB]
Descargados 173 kB en 15s (11,7 kB/s)
Leyendo lista de paquetes...
Leyendo lista de paquetes...
Creando árbol de dependencias...
Leyendo la información de estado...
E: No se ha podido localizar el paquete php5-mcrypt
********************************************************
*             Installation terminée                    *
********************************************************

Je peux déjà configurer le plugin mais maintenant j’ai cette erreur.
Ma Nissan LEAF date de 2019.

Request for 'UserLoginRequest.php' failed. Response received: {"status":"-2010","message":"INVALID PARAMS","resultKey":""}

Je rencontre le même problème, maintenant que je viens de passer en V4.
Dans la page Santé de Jeedom, il est indiqué que les dépendances sont NOK. Lorsque je veux relancer l’installation de celles-ci, ça indique que ça charge à 50%, puis repasse en NOK.

Peut-être un début de piste avec ça :
image
Il semblerait que le package php5-mcrypt ait depuis été remplacé par une version 7, voire 7.1…

Je ne suis pas trop calé en dev, mais ceci ne voudrait pas dire qu’il faudrait que le plugin cherche à disposer de la version actuelle plutôt que de chercher la vieille version qui n’existe plus ?

Je m’auto-réponds, peut-être que ça pourra servir à certains.
En forçant l’install de php7.0-mcrypt en ligne de commande :

sudo apt-get install php7.0-mcrypt

L’install s’est déroulée correctement, puis après un reboot du Raspberry j’ai pu installer les dépendances sans problème et le plugin n’apparaît plus en défaut dans l’onglet Santé.

Alors, le plugin fonctionne-t-il pour vous?

Oui, le message d’erreur n’était pas exactement le même que le vôtre, mais avec la version 7 de phpX-mcrypt, l’application a pu installer les dépendances sans souci et fonctionne parfaitement.

Je pense que le développeur du plugin a spécifié qu’en l’absence de pxpX-mcrypt, il faut obligatoirement aller installer la version 5, qui ne semble plus être disponible au téléchargement puisque trop ancienne.

comment avez-vous obtenu php7.0-mcrypt?

root@jeedom:~# sudo apt-get install php7.0-mcrypt
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
E: No se ha podido localizar el paquete php7.0-mcrypt
E: No se pudo encontrar ningún paquete usando «*» con «php7.0-mcrypt»
E: No se pudo encontrar ningún paquete con la expresión regular «php7.0-mcrypt»

Ce paquet doit être pour Stretch.
Es-tu sous Buster ?

root@jeedom:/etc# lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 10 (buster)
Release:        10
Codename:       buster

Il semblerait qu’il n’y ait pas de paquet mcrypt pour php7.3.
Il y a des procédures d’installation sur la toile mais il vaudrait mieux attendre l’avis du développeur sur ce sujet.

Je pense que le développeur a abandonné le plugin

1 J'aime

J’ai finalement découvert ce qui se passait.
La bibliothèque php utilisée n’est pas compatible à partir de Leaf 2019.
Vous devez utiliser https://gitlab.com/tobiaswkjeldsen/dartnissanconnect

Malheureusement, je ne sais pas comment fonctionne le langage DART.
Je ne peux que faire fonctionner l’exemple fourni.
Des experts DART dans la salle?