Mise à jour notifications Home sur Iphone non fonctionnelles

Bonjour,

Après avoir pas mal cherché aussi bien sur internet globalement que sur la communauté, je viens poser ma question ne parvenant pas à trouver de réponse.

Voici ma config :
Jeedom installé sur une VM buster sur un NUC I7 sous proxmox qui tourne parfaitement bien depuis 3 ans maintenant. Jeedom est en dernière version et tous les plugins sont à jour.
Concentrateur : Apple TV 4K à jour elle aussi
Périphériques : 2 Iphone 11 (à jour toujours :stuck_out_tongue:)

mon souci :

J’ai des notification sous apple home que je reçois sur les téléphone, par contre, il arrive de manière régulière que je ne reçoive pas ces notification (principalement des notifs « sécurité »).
Si j’actualise régulièrement l’application HOME sur l’un des téléphone, pas de souci pour les recevoir, par contre, si ça fait un moment, je ne les reçois pas du tout.

J’ai cherché sur l’apple TV s’il y avait une sorte de mise en veille prolongée mais je n’ai rien trouvé et je ne trouve rien en rapport avec ce souci.

Est-ce que quelqu’un a déjà rencontré ce problème et si oui, comment le solutionner ?

Merci d’avance, bonne journée.

Bonjour,

Je retire ton tag homebridge car aucun rapport avec le plugin.

C’est un problème Apple, je t’invite à contacter le support Apple qui te dira probablement deux choses : achete plus de concentrateurs et branche ton appletv en filaire ou vérifie ton wifi.

Bonjour,
L’apple TV est déjà branchée en filaire.

Merci à d’autres qui auraient éventuellement déjà eu le souci de bien vouloir m’aider.
Bonne journée.

Je pense pas que quelqu’un pourra t’aider là dessus à part le support Apple… ça ressemble plus à un bug …

Bonjour,

Tu peux préciser les versions OS de ton Apple TV 4K et de tes 2 iPhone 11 ?
Ton problème de non réponse dans l’App Maison est uniquement en 4G ou aussi en Wifi ?
Peux-tu débrancher électriquement ton Apple TV 4K et le rebrancher ?

akenad :slight_smile:

Bonjour,

Les iphone sont en IOS 15.1 et l’apple TV en TVOS 15.1 aussi.
Il ne s’agit pas d’une non réponse mais d’une non poussée de notification (donc selon moi d’update du concentrateur) et ça se produit aussi bien en wifi qu’en 4G.
J’ai déjà débranché et rebranché l’apple TV sans meilleur résultat :frowning:

peux tu décrire exactement ce que tu entends par « actualiser l’application HOME sur le iPhone » et « non poussée de notification » ?
Si tu as aussi le problème en wifi, ce n’est alors pas le seul fait du concentrateur.
Pour mon problème de App Maison non réponse, c’était uniquement en 4G (donc pas en wifi)
je n’avais qu’un seul concentrateur sur le réseau (un Homepod, pas d’Apple TV).
le problème est apparu après avoir fais une mise à jour iPhone et Homepod.
j’ai alors ajouté un Homepod mini au réseau, le Homepod s’est synchronisé avec le Homepod mini.
c’est redevenu nominal. J’ai retiré le Homepod mini et cela fonctionne toujours.

akenad :slight_smile:

En fait, (c’est pas évident à expliquer à l’écrit), l’application sur le téléphone est programmée pour m’envoyer une notification sur activation ou désactivation de l’alarme.
L’info est bien géré par jeedom étant donné que côté Jeedom les infos sont mises à jour.

Par contre, si je n’utilise pas régulièrement l’application home sur les iphone, la notification n’est pas poussée et la variable non mise à jour dans l’app du téléphone.

Que je sois en wifi ou en 4G le souci est le même.
J’espère que c’est plus compréhensible. Bonne journée et merci d’essayer de m’aider

l’équipement alarme est gérée par quel plugin dans Jeedom ?
cet équipement est-il envoyé par ailleurs dans le plugin Homebridge ?
peux-tu fournir les copies d’écran de :

  • ta programmation sur ton téléphone d’envoi de la notification
  • la variable non mise à jour
  • la notification lorsque tu forces l’actualisation

akenad :slight_smile:

Non c’est la notif intégrée à l’app « maison », d’où je le dirigeais vers Apple.

Il faut donc comprendre alors que son alarme est homekit, directement accédé par l’App Maison ?

akenad :slight_smile:

Non pas native, il l’a poussé dans homebridge et les valeurs sont correctes. C’est un problème de cache iCloud je pense, Apple lui fera refaire complètement son domicile à mon avis.

Pour ma part je suis toujours en iOS 14.8.1 sur mon iPhone.
Depuis iOS 15 il semblerait qu’il y ait un bug sur les notifications.
Les Apps ne déclencheraient pas d’alerte si elles ne sont pas ouvertes.
Ce qui est semble-t-il le problème que tu décris.
il en est question par exemple ici :

akenad :slight_smile:

1 « J'aime »

Merci pour ton retour @akenad. J’avais déjà le souci avant la mise à jour en IOS15 malheureusement :frowning:

Comme je le disais, pour ma part je suis en iOS 14.8.1 sur mon iphone et les notifications de l’App Maison fonctionnent même si l’App Maison n’est pas ouverte.
Les notifications se définissent sur chaque accessoire (qui le supporte) dans l’App Maison.
Exemple :
un détecteur d’ouverture Aqara dans le plugin xiaomihome, remonté dans le plugin homebridge (type générique, Ouvrant : Info / Porte)
App Maison > Réglages de Domicile > Détecteurs > Autoriser les notifications de >
détecteur d’ouverture > Notifications sur cet iPhone > activer

En cas de partage familial, si souhaité, la notification est à activer dans chaque App Maison de chaque iPhone.

En iOS 15 je t’invites à regarder ce qui est configurable dans :
Réglages > Concentration
et
Réglages > Notifications

Une autre hypothèse est que tu aies une autre app avec notifications qui soit buggé et qui neutralise les notifications de l’App Maison.

akenad :slight_smile:

Je reste sur mon idée de problème de cache iCloud puisque tout se débloque quand il lance l’app maison… or C’est le rôle du concentrateur de gérer l’état passivement quand rien n’est ouvert via le cache.

En effet, l’App Maison et le concentrateur homekit utilisent iCloud.

akenad :slight_smile: