Mise a jour deconz .81

Tags: #<Tag:0x00007f3861affd48>

Page : index.php?v=d&m=deconz&p=deconz&id=deconz
Jeedom_version : 4.0.61
Uname : Linux JeedomV4 4.9.0-13-amd64 #1 SMP Debian 4.9.228-1 (2020-07-05) x86_64 GNU/Linux


Message :
BOnjour,

La version .81 de deconz est sortie récemment. Je vois que ma config tape le repo ici : https://images.jeedom.com/resources/deconz/arm64/ et que la version dispo est toujours 0.77.
POuvez vous la mettre à jours ? Autre question, pourquoi le arm64 n’est pas relié au dépôt deconz comme les autres ?

Cordialement,

.

Juste le temps que Jeedom SAS prenne en compte le message que je leur ai envoyé.
(Attention à la confusion entre amd64 et arm64)

akenad :slight_smile:

2 J'aimes

C fé !

akenad :slight_smile:

2 J'aimes

Je dois raté quelque chose… Je stop le deamon, je lance l’installation des dépendances puis l’installation locale. Je suis toujours en .77

et le log de mise à jour te dit quoi ?

J’ai ça dans les logs.deconz_update.txt (3,9 Ko) deconz_install.txt (2,8 Ko)

Sans toucher aux dépendances , arrête le démon Deconz , mets le niveau des logs Deconz en debug et relance l’installation locale.
J’oubliais pour que le niveau de logs soit pris en compte il me semble qu’il faut désactiver puis réactiver le plug in (plussur mais j’ai un doute subitement)

EDIT : es sur une VM ?

Oui je suis sur une VM mais jusque là ça toujours marché, j’ai le plugin depuis le début. Je suis déjà en log débug

Ce qui est bizarre c’est que je ne suis pas sur que la cible de dépôt pour les paquets soit bien interprété par le serveur deconz . Tout se déroule OK mais en fait rien n’est checké au niveau version.

peux tu lancer la commande suivante en ssh


apt list --all-versions deconz

ça me donne ça :
deconz/now 2.05.77-ubuntu-xenial-beta amd64 [installé, local]

Donc effectivement le serveur ne reconnait aucune nouvelle version pour ta cible.

donc installation forcée :
arrête le démon Deconz et en ssh :
wget http://deconz.dresden-elektronik.de/ubuntu/stable/deconz-2.05.81-qt5.deb
sudo dpkg -i deconz-2.05.81-qt5.deb

sudo apt-get update
sudo apt-get upgrade

Ok mais donc la redirection qui a été faite sur et par jeedom est pas bonne ?

Si mais visiblement c’est ta VM qui ne doit pas donner la bonne architecture ou la bonne version vers le serveur deconz au moment du check de version. Il est clair que apt va chercher sur un dépôt distant qui n’est pas celui de Jeedom en l’occurence celui ci :
Hit:5 http://phoscon.de/apt/deconz stretch InRelease
donc aucune chance qu’il trouve la version main la plus up to date

DOnc il faudra que je fasse ça a chaque maj ? En tout cas merci pour ton aide.

ca me donne : deconz/now 2.05.81-ubuntu-xenial-stable amd64 [installé, local]
WTF !!!

Non je ne pense pas. Il faudra faire un tour dans la liste des .list de cibles de dépôts pour les mises à jour mais je dois avouer que je ne suis pas très fan car pas assez calé sur le comportement des VM sous Debian. Et ces VM c’est vraiment une mauvaise idée pour de la domotique. Je me suis déjà exprimé plusieurs fois sur ce sujet sur ce forum et sur le pourquoi.

tu as bien fait le dpkg ?
que donne de nouveau

apt list --all-versions deconz

ca me donne :

deconz/now 2.05.81-ubuntu-xenial-stable amd64 [installé, local]

WTF…

Bon bien ya pu ka redémarrer deconz (le démon) voire relancer la machine pour que le service qui lance les process deconz prennent bien ceux qui viennent d’être installés

j’ai relancer le deamon c’est bon ! Merci beaucoup !
Je garde ta procédure dans un coin mais vraiment spé que ça ai toujours fonctionné et pas sur celle ci…

J’ai du nouveau matos a intégré maintenant.