Message d'erreur : Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.2.0". You are running 7.0.33-0+deb9u8

Bonjour,
Je viens de faire une mise à jour de 4 plugins dont je ne me rappel plus exactement des plugins, entre autre le bluetooth, etc
Suite a cette mis a jour j’ai ce message d’erreur :

Composer detected issues in your platform: Your Composer dependencies require a PHP version ">= 7.2.0". You are running 7.0.33-0+deb9u8.

Je n’ai plus accès a l’interface de Jeedom, mais par contre avec PuTTY j’ai acces.
J’étais en Jeedom 4.0.15
Pouvez-vous m’aider ?
Je précise que je ne suis pas à l’aise avec les lignes commandes.
Merci d’avance.

Je rectifie version 4.1.15

Hello,

PHP c’est pas uniquement en lien avec la version de Jeedom mais aussi avec ton OS.
7.0.33-0+deb9u8 => Debian 9, et ça commence à être « vieux »…
Fin de support depuis 1 an
https://www.php.net/eol.php

Donc c’est Debian qu’il faut mettre à jour

Merci pour cette information, mais comment faut il faire, comme je l’ai dis je suis une quiche en ligne de commande.

Quelques pistes :

  • Commencer par récupérer le dernier backup (dans /var/www/html/backup/) avec winscp par exemple (c’est comme ssh)

Ensuite au choix :

  • Repartir de zéro en installant la dernière version de debian (c’est plus propre mais un peu plus long) et restaurer le backup
  • ou Tenter une mise à jour en ligne de commande dans l’ordre
  1. sudo apt-get -y update
  2. sudo apt-get -y upgrade
  3. sudo apt-get -y dist-upgrade
  4. sudo apt-get -y auto-clean
  5. sudo apt-get -y autoremove
1 J'aime

Dès la première commande : sudo apt-get -y update j’ai un message d’erreur : Err:4 https://repo.mosquitto.org/debian stretch InRelease
Les signatures suivantes ne sont pas valables : EXPKEYSIG 61611AE430993623 Mos quitto Apt Repository repo@mosquitto.org

Un repository mosquito, c’est pas classique et c’est le résultat soit d’une mauvaise manip/experience, soit de l’installation d’un plugin => mqtt https://github.com/lunarok/jeedom_MQTT/blob/master/resources/install.sh
Il doit y avoir une référence à effacer dans un des fichiers de /etc/apt/ ou /etc/apt/sources.list.d/
Par exemple /etc/apt/sources.list

On a déjà dépassé le stade de la bête ligne de commande, et c’est pas de bon augure pour la suite.J’aurai tendance à dire qu’il faut rester sur du classique et repartir d’une installation propre

Bonjour,

Tu devrais plutôt revenir à une version jeedom 4.0.
La 4.1 est en bêta.

Bon ba je vais partir sur une installe complète que me conseillez vous comme procédure pour faire une installe
Merci encore.

Techniquement SSD ou Carte SD c’est pas très différent donc en adaptant :