Le plugin RFXCom ne fonctionne plus depuis quelques heures

Tags: #<Tag:0x00007f3853dbdb10>

Bonjour,

Depuis quelques heures le plugin RFXCom est planté avec le message :

[2020-08-18 17:09:04][INFO] : Start rfxcomd
[2020-08-18 17:09:04][INFO] : Log level : debug
[2020-08-18 17:09:04][INFO] : Socket port : 55000
[2020-08-18 17:09:04][INFO] : Socket host : 127.0.0.1
[2020-08-18 17:09:04][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2020-08-18 17:09:04][INFO] : Device : /dev/ttyUSB1
[2020-08-18 17:09:04][INFO] : Apikey : j4jg6a6LIGv1vSm4DKlKyMutC6IgiAG5
[2020-08-18 17:09:04][INFO] : Callback : http://127.0.0.1:81/plugins/rfxcom/core/php/jeeRfxcom.php
[2020-08-18 17:09:04][INFO] : Cycle : 0.3
[2020-08-18 17:09:04][INFO] : Serial rate : 38400
[2020-08-18 17:09:04][INFO] : Serial timeout : 9
[2020-08-18 17:09:04][INFO] : Protocol : 12,13,18,20,21,22,23
[2020-08-18 17:09:04][INFO] : Find device : /dev/ttyUSB1
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x01 : Interface Response Message
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x10 : Lighting1 (X10, ARC, ELRO, Waveman, EMW200, IMPULS,RisingSun, Philips, Energenie, GDR2, HQ, Oase)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x11 : Lighting2 (AC, HomeEasy EU, ANSLUT, Kambrook)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x13 : Lighting4 (PT2262)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x14 : Lighting5 ( LightwaveRF, Siemens, EMW100, BBSB, MDREMOTE,RSL2, OTIO, Livolo, RGB, Aoke relay, Eurodomest, RGB432W, Legrand,Avantek, IT, Kangtai)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x15 : Lighting6 (Blyss (AE), Cuveo)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x16 : Chime (Byron SX, Byron MP001, SelectPlus, Envivo, Alfawise)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x17 : Fan (Siemens SF01, Itho, LucciAir, SEAV,Westinghouse,Casafan,FT1211R,Novy)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x19 : Blinds1 (RollerTrol,Hasta,A-OK,Raex, Media Mount, DC)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x1C : Edisio
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x1D : Honeywell ActivLink
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x1E : FunkBus
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x1F : Hunter Fan
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x20 : Security1 (X10, KD101, Visonic, Meiantech, SA30, SA33, RM174RF)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x21 : Security2 (KeeLoq)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x28 : Camera1 (Ninja/Robocam)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x30 : Remote control and IR (ATI, Medion, PC Remote)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x40 : Thermostat1 (Digimax)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x42 : Thermostat3 (Mertik-Maxitrol G6R-H4 type)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x4E : BBQ Temperature sensors (BBQ1)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x4F : Temperature and rain sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x50 : Temperature sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x51 : Humidity sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x52 : Temperature and humidity sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x53 : Barometric sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x54 : Temperature, humidity and barometric sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x55 : Rain sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x56 : Wind sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x57 : UV sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x58 : Date/time sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x59 : Current sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x5A : Current sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x5B : Current + ENERGY sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x5C : Power sensors
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x5D : Weighting scale
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x60 : CARTELECTRONIC
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x70 : RFXsensor
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x71 : RFXMeter
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x72 : FS20 (FS20, FHT 8V, FHT80)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x76 : Weather stations (WEATHER1-WEATHER2)
[2020-08-18 17:09:04][DEBUG] : Load decoder packet type 0x77 : SOLAR1
[2020-08-18 17:09:04][DEBUG] : Writing PID 28585 to /tmp/jeedom/rfxcom/deamon.pid
[2020-08-18 17:09:04][DEBUG] : Init request module v2.21.0
[2020-08-18 17:09:04][DEBUG] : Starting new HTTP connection (1): 127.0.0.1:81
[2020-08-18 17:09:04][DEBUG] : null
[2020-08-18 17:09:04][DEBUG] : http://127.0.0.1:81 « GET /plugins/rfxcom/core/php/jeeRfxcom.php?apikey=j4jg6a6LIGv1vSm4DKlKyMutC6IgiAG5 HTTP/1.1 » 200 0
[2020-08-18 17:09:04][ERROR] : Fatal error : module ‹ serial › has no attribute ‹ VERSION ›
[2020-08-18 17:09:04][DEBUG] : Traceback (most recent call last):
File « /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py », line 394, in
globals.JEEDOM_SERIAL = jeedom_serial(device=_device,rate=_serial_rate,timeout=_serial_timeout)
File « /var/www/html/plugins/rfxcom/resources/rfxcomd/jeedom/jeedom.py », line 231, in init
logging.debug(‹ Init serial module v%s › % (str(serial.VERSION),))
AttributeError: module ‹ serial › has no attribute ‹ VERSION ›
[2020-08-18 17:09:04][DEBUG] : Shutdown
[2020-08-18 17:09:04][DEBUG] : Removing PID file /tmp/jeedom/rfxcom/deamon.pid
[2020-08-18 17:09:04][DEBUG] : Exit 0
[2020-08-18 17:09:33][ERROR] : Impossible de lancer le démon RFXcom, vérifiez le log rfxcmd

Je suis en Jeedom stable 4.0.61.
Le plugin RFXCom est en version beta du 2020-07-30 16:31:24
Le RFXCom est en firmware 1043 (la dernière).

Merci de votre aide. On est en été donc ça va mais en hivers ce protocole pilote la partie chauffage électrique.

Cordialement

Bonjour @krissam44 ,

As tu fait un reboot pour voir si cela refonctionne ?

1 J'aime

A qui dois-je donc m’adresser si la communauté ne peux pas m’aider.
Comment contacter la hotline Jeedom ?

Bonjour
Tu es en bêta… Donc pas de hotline (il n’y en a pas de toute façon) ni de support. La tu as un soucis de dépendance essayes de les relancer si tu veux rester en bêta.

Je viens de repasser en stable et ça refonctionne.
Ce que je ne comprends pas, c’est pourquoi depuis le 30 juillet, date de l’installation de la dernière beta cela a fonctionné et tout d’un coup dans l’après-midi cela plante.

En tout coup cas merci, Loic, de la réponse et merci à l’équipe Jeedom pour le boulot réalisé.

PS : la dernière version (beta) de deconz fonctionne beaucoup mieux.

Car le démon avez pas du redémarrer donc toujours l’ancien code. Et oui les bêtas sont pas toute les même la j’ai tout réécris de 0

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.