Kroomba dépendance erreur

Tags: #<Tag:0x00007f3f38232e58>

Bonjour a tous,
Après plusieurs recherches et essai qui n’ont pas fonctionné, je vous fait part de mon problème en esperant que vous pourriez me venir en aide.

Après avoir chaque tentative de téléchargement des dépendance du plugin Kroomba le statut reste en NOK.

je vous mets les logs de l’instal.

Pour info mon robot apsi et un irobot roomba i7


********************************************************
*             Installation des dépendances             *
********************************************************
Version de Python 3 installée :
Python 3.9.2
Hit:1 http://ftp.fr.debian.org/debian bullseye InRelease
Hit:2 http://ftp.fr.debian.org/debian bullseye-updates InRelease
Hit:3 http://security.debian.org/debian-security bullseye-security InRelease
Hit:4 http://phoscon.de/apt/deconz bullseye InRelease
Reading package lists...


WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...

Building dependency tree...
Reading state information...
python3-pip is already the newest version (20.3.4-4+deb11u1).
The following packages were automatically installed and are no longer required:
  ethtool libmspack0 libxmlsec1 libxmlsec1-openssl zerofree
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
Reading package lists...
Building dependency tree...
Reading state information...
python3-setuptools is already the newest version (52.0.0-4).
The following packages were automatically installed and are no longer required:
  ethtool libmspack0 libxmlsec1 libxmlsec1-openssl zerofree
Use 'sudo apt autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
WARNING: No metadata found in /usr/local/lib/python3.9/dist-packages
Found existing installation: six 1.16.0
WARNING: No metadata found in /usr/local/lib/python3.9/dist-packages
WARNING: No metadata found in /usr/local/lib/python3.9/dist-packages
WARNING: No metadata found in /usr/local/lib/python3.9/dist-packages
WARNING: No metadata found in /usr/local/lib/python3.9/dist-packages
WARNING: No metadata found in /usr/local/lib/python3.9/dist-packages
ERROR: Cannot uninstall six 1.16.0, RECORD file not found. You might be able to recover from this via: 'pip install --force-reinstall --no-deps six==1.16.0'.
Found existing installation: paho-mqtt 1.6.1
Uninstalling paho-mqtt-1.6.1:
  Successfully uninstalled paho-mqtt-1.6.1
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
Requirement already satisfied: setuptools in /usr/local/lib/python3.9/dist-packages (62.6.0)
WARNING: Error parsing requirements for six: [Errno 2] No such file or directory: '/usr/local/lib/python3.9/dist-packages/six-1.16.0.dist-info/METADATA'
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
Requirement already satisfied: six in /usr/local/lib/python3.9/dist-packages (1.16.0)
ERROR: Could not install packages due to an OSError: [Errno 2] No such file or directory: '/usr/local/lib/python3.9/dist-packages/six-1.16.0.dist-info/METADATA'
Collecting paho-mqtt
  Using cached paho_mqtt-1.6.1-py3-none-any.whl
WARNING: Error parsing requirements for six: [Errno 2] No such file or directory: '/usr/local/lib/python3.9/dist-packages/six-1.16.0.dist-info/METADATA'
Installing collected packages: paho-mqtt
Successfully installed paho-mqtt-1.6.1
WARNING: Running pip as the 'root' user can result in broken permissions and conflicting behaviour with the system package manager. It is recommended to use a virtual environment instead: https://pip.pypa.io/warnings/venv
sudo: git: command not found
mv: cannot stat 'Roomba980-Python/roomba': No such file or directory
chown: cannot access 'roomba': No such file or directory
chmod: cannot access 'roomba': No such file or directory
********************************************************
*             Installation terminée                    *
********************************************************

Salut

Tu es sur bulleyes, par sur que ce plugin soit compatible, python 2 vs 3. As-tu testé avec buster?

Antoine

Non, Je me lance seulement sur jeedom.
Selon toi il serait mieux de refaire une install complet avec buster?

Bonjour,

Le plugin est sur python3 par contre personnellement je n’ai jamais testé avec python 3.9 (sous buster c’est 3.7) mais en principe il n’y a pas de grande différence.

Je pense que le problème est plus sur votre machine, il y a des paquets « cassés »:

du coup p-e essayer ce qui est proposé (mais je le ferais avec pip3 pour être plus sur:

sudo pip3 install --force-reinstall --no-deps six==1.16.0'

et ensuite relancer les dépendances

Ca ne fonctionne pas.

      sudo pip3 install --force-reinstall --no-deps six==1.16.0
collecting six==1.16.0
   Using cached six-1.16.0-py2.py3-none-any.wh1 (11kb)
installing collected packages : six
  attempting uninstall: six
     warning: no metadata found in /usr/local/lib/python3.9/dist-packages
     found axisting installation six 1.16.0
     warning: no metadata found in /usr/local/lib/python3.9/dist-packages
     warning: no metadata found in /usr/local/lib/python3.9/dist-packages
     warning: no metadata found in /usr/local/lib/python3.9/dist-packages
     warning: no metadata found in /usr/local/lib/python3.9/dist-packages
     warning: no metadata found in /usr/local/lib/python3.9/dist-packages
ERROR: Cannot uninstall six 1.16.0, RECORDS fil not found. you might be albe to recover from this via : 'pip install --force-reinstall --no-deps six==1.16.0' .

Avez-vous fait quelque chose de particulier/manuellement sur votre système?

Essayez du supprimer le dossier six dans /usr/local/lib/python3.9/dist-packages et ensuite réinstallez:

sudo pip install --upgrade --force-reinstall six

Non mise a part install deconz en manuel pour mettre une conbee2. je vais essayé si cela ne fonctionne pas je vais downgrade sur buster et refaire mon install

Le meme message d’erreur

Je ne sais pas comment réparer alors, le mieux serait de réinstaller proprement effectivement si possible pour vous.

1 J'aime

Merci pour votre aide en tous cas

Après être repassé sur debian buster, le plugin fonctionne parfaitement bien. Effectivement ca ne doit pas être compatible avec debian 11

Ça on ne sait pas. Votre environnement python avait un problème donc on ne peut pas affirmé que ça ne fonctionne pas sous debian 11.
Je suis quasi sur qu’en reinstallant debian 11 ça fonctionnera aussi.
D’autant plus que là ce n’est pas le code du plug-in mais l’installation des dépendances qui posait problème.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.