Jeedom ne communique plus avec le roborock S50V2

Bonjour,

Depuis quelques semaines, Jeedom ne peut plus envoyer de commandes à mon aspirateur Roborock S50V2.

Pourtant, cela a toujours fonctionné à travers les mois et les mises à jour respectives de Jeedom, de l’application ou de l’aspirateur.

Jeedom, l’application Xiaomi Home (4.23.1) et l’aspirateur (3.3.9_001886) sont à jour. L’aspirateur est sur un serveur France.

J’ai une Gateway avec des capteurs sur un serveur Chine. Tous les firmwares sont à jour de côté là aussi.

L’IP n’a pas changé (elle est fixe). Je n’ai pas touché au token.

Sur les commandes du Roborock, quand celui-ci est en train d’aspirer le statut sur Jeedom renvoie toujours « en charge » donc le lien ne semble plus se faire. Ce qui est étrange, c’est que Jeedom renvoie une valeur récente dans dernière activité :

Type : wifi
Modèle : vacuum2
Gateway : 192.168.1.191
Dernière Activité : 2019-11-16 09:40:10

Le token a-t-il pu changer sur une mise à jour?
Fallait-il rester sur une version antérieure?

J’imagine que vous avez besoin de plus d’informations pour m’aider, à disposition…

Merci pour votre aide

Bonsoir,

J’ai le même soucis avec mon Roborock aussi.

image

Il est impossible à piloter mais par contre il communique avec Jeedom.

Une aide serai le bienvenue.

Je vous remercie d’avance.

Le log quand j’essaye de « Démarrer » une aspiration…

[2019-11-18 23:12:13][DEBUG] : execute : action wifi start
[2019-11-18 23:12:13][DEBUG] : Client connected to [127.0.0.1:42592]
[2019-11-18 23:12:13][DEBUG] : Message read from socket: {« apikey »:« Wn6VyLsvVbGmMgueIHG0jcIC7yN1XGGZ »,« type »:« wifi »,« cmd »:« send »,« model »:« vacuum2 »,« dest »:« 192.168.1.191 »,« token »:« 46614778397039464977476273435464 »,« devtype »:« 05c1 »,« serial »:« 820c »,« method »:« app_start »,« param »:""}
[2019-11-18 23:12:13][DEBUG] : Client disconnected from [127.0.0.1:42592]
[2019-11-18 23:12:13][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2019-11-18 23:12:13][DEBUG] : Received command from jeedom : send
[2019-11-18 23:12:13][DEBUG] : Executing action on : vacuum2
[2019-11-18 23:12:13][DEBUG] : {« id »:49117,« method »:« app_start »}
[2019-11-18 23:12:14][DEBUG] : tuple index out of range
[2019-11-18 23:12:14][DEBUG] : {« id »:64574,« method »:« app_start »}
[2019-11-18 23:12:15][DEBUG] : tuple index out of range
[2019-11-18 23:12:15][DEBUG] : {« id »:62929,« method »:« app_start »}

même soucis j’ai bien récupérer le token et l’ip pourtant impossible de recuperer les infos et le robot ne bouge pas sur les commande envoyé

Le Token a changé dans une mise à jour du firmware de l’aspirateur.

Avec la méthode n°4 de Lunarok pour récupérer le Token ça va vite (vieux téléphone android avec APK de Mi Home modifiée qui affiche le Token en clair).

Tout refonctionne.

3 « J'aime »

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.