Jeedom HS, un sauveur?

Bonjour à toutes et à tous,

j’avais des problèmes avec Jeedom v4.1.25 sur une smart qui tout à coup me lançait des erreurs « JavaScript ».
Cela étant très soudain, j’ai fait une restauration avec une image remontant à 48 heures.

Jeedom a tourné un petit moment puis m’a éjecté erreur 401 (de mémoire).
Je peux accéder à la page de login de Jeedom mais plus moyen de se connecter ni avec mes identifiants ni avec admin/admin.

Je me suis connecté en SSH suivant la documentation pour modifier son mot de passe et en fait il n’y a plus aucun utilisateur d’enregistré.

image_2022-06-21_161755340

Je suis vraiment désespéré, étant totalement paralysé je contrôle Jeedom grâce à la voix et celui-ci gère tout mon environnement. C’est un peu comme perdre ses mains.

Je vous en prie si vous avez une idée, dites-moi.
Je vous remercie par avance.

tu as le droit d’ouvrir des tickets chez jeedom pour ce genre de souci. vu que c’est une box produite par leur soin, je te conseille de suivre leurs instructions.

sinon tu sembles pouvoir accéder à ssh, donc à linux. cela permettra de faire un diagnostique.

Merci, j’ai demandé à l’installateur qui s’est connecté à distance mais apparemment il n’y a pas moyen…

es-tu certain de bien utiliser le bon utilitaire. celui là c’est pour de la 3.X, là on est sur de la 4.1 ou 4.2, normalement tu devrais pouvoir trouver ton utilisateur avec cette procédure :

php /var/www/html/core/php/jeecli.php user list

Une fois que vous avez reperé le nom de l’utilisateur dont vous voulez changer le mot de passe faite :

php /var/www/html/core/php/jeecli.php user password [username] [password]

Bonjour, je n’ai pas compris tous les utilisateurs étaient effacés… pour être honnête j’ai essayé par dépit toutes les procédures. Rien n’y a fait.

J’ai suivi la procédure de réinstallation complète de la notice pour les smart Jeedom (avec l’image sur une clé USB).
J’ai remis une de mes sauvegardes. J’ai accès la box, le Z-Wave ne fonctionne pas pour l’instant mais je m’en soucierais plus tard.
J’ai pensé qu’une nouvelle installation était le moment parfait pour passer de la 4.1.25 à la version 4.2…

Mal m’en a pris car la mise à jour a commencé (c’est comme si elle continuait) mais en réalité elle est à 15 % depuis une demi-heure et rien ne se passe. J’ai un peu peur que tout repète.

image_2022-06-22_144608861

Jeedom-42b

Je me demande ce que je dois faire.
Qu’en pensez-vous ?
Merci.

Bonjour

D’après votre dernier log, meme si c’est long, il n’y a pas l’air d’avoir d’erreurs sur la mise à jour

Le log continue t il de défilé ?
Un refresh sur la page de mise a jour, vous restez toujours à 15% , ou la valeur évolue ?

Bonjour, je n’aurais pas osé… j’ai rafraîchi ma page la barre du haut a disparu (celle qui m’a affiché 15 %) et la mise à jour ne s’est pas faite.

Sur le log Informations que vous nous avez screen juste avant, qu’en est il ?

Il est vide, juste marqué « aucune mise à jour en cours ».

Alors vous pouvez retenter de passer la mise à jour

Ne cocher pas Mettre a jour les plugins, laissez juste Mettre à jour le Core

Surveillez les logs Informations quand la mise à jour via démarrer

(de toute maniere vous avez un backup de votre installation au cas ou)

OK, je vous fais confiance et je reteste. Je marquerai ici ce qu’il en est tout à l’heure.
Merci beaucoup.

Comme quoi l’informatique est l’inverse de la folie, répétez plusieurs fois les mêmes actions et vous obtiendrez des résultats différents.

Bref, la mise à jour est passée du coup par la suite j’ai pu faire celle des plug-ins aussi. Je vous remercie grandement pour cela.

S’il vous plaît j’ai besoin d’aide pour une dernière chose et c’est une chose vitale : suite à l’installation de Jeedom et à la restauration de ma sauvegarde il a fallu réinstaller les les dépendances de certains plug-ins. Je n’arrive pas à réinstaller ceux de Snips. J’ai un besoin vital de celui-ci car je n’utilise ma domotique qu’en vocal.

Lorsque je lance l’installation des dépendances il va jusqu’à 30 % puis s’arrête.
Pouvez-vous m’aider s’il vous plaît ?

1 J'aime

Parfait si la mise à jour est passée :wink:

Pour le reste, ne mélangeons pas les sujets.

Je vous écris en MP pour voir comment régler cela

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.