Installation dépendances impossible

Tags: #<Tag:0x00007f282bfb10a8>

bonjour,

Depuis la dernière MAJ, je n’arrive plus à installer les dépendances malgré une réinstallation complète du plugin (Bêta et stable) .

à priori pb avec npm
je n’arrive pas à joindre le log !!! :
merci d’avance pour votre aide.

Installation de Homebridge beta…
npm WARN registry Unexpected warning for https://registry.npmjs.org/:

un peu court pour t’aider…
les nouveaux arrivants ont du mal à joindre des fichiers, copie le contenu et n’oublie pas de choisir le mode “texte préformaté” image

Bonjour @jeanpoil,

Ce que souhaite @nebz, le développeur du plugin, est évoqué plus en détails ici : [Présentation] akenad

akenad :slight_smile:

bonjour @nebz
merci pour les conseils, voici le log des dépendances :

Installation dépendances sur Jeedom 4.0.38 sur Debian GNU/Linux 10 (buster)/arm64/aarch64/64bits aka 'freeboxDelta' avec nodeJS v12.15.0 et jsonrpc:enable et homebridge (beta) 2020-02-06 12:08:48
--0%
--10%
Lancement de l'installation/mise à jour des dépendances homebridge
--20%
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 https://deb.nodesource.com/node_12.x buster InRelease
Hit:3 http://deb.debian.org/debian buster InRelease
Hit:4 http://deb.debian.org/debian buster-updates InRelease
Hit:5 http://deb.debian.org/debian buster-backports InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
--30%
Version actuelle : v12.15.0
Ok, version suffisante
--50%
--60%
Installation de Homebridge beta...
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning ENODATA: Cache input stream was empty
npm WARN registry Using stale data from https://registry.npmjs.org/ due to a request error during revalidation.
npm ERR! code EINTEGRITY
npm ERR! errno EINTEGRITY
npm ERR! Invalid response body while trying to fetch https://registry.npmjs.org/http-signature: Integrity verification failed for sha512-GwcDVdyQNHSaTapaA5mAzEcLH8l+smpd//gC6/X+rpITs7pgTgO77Lym08HHGXU4ElLrn55YMHZs/5XdHnUo8w== (/root/.npm/_cacache/content-v2/sha512/1b/07/0355dc9034749a4daa5a039980cc470b1fc97eb26a5dfff802ebf5feae9213b3ba604e03bbecbca6d3c1c71975381252eb9f9e5830766cff95dd1e7528f3)
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-02-11T20_01_13_821Z-debug.log
--70%
--80%
--90%
--95%
--100%
Installation des dépendances Homebridge terminée, vérifiez qu'il n'y a pas d'erreur

Ok tu as un problème dans ton système, peux tu lancer “réparer et réinstaller” dans la configuration du plugin, attendre 10 min et renvoyer le log homebridge_dep ?

Installation dépendances sur Jeedom 4.0.38 sur Debian GNU/Linux 10 (buster)/arm64/aarch64/64bits aka 'freeboxDelta' avec nodeJS  et jsonrpc:enable et homebridge (beta) 2020-02-06 12:08:48
--0%
--10%
Lancement de l'installation/mise à jour des dépendances homebridge
--20%
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease
Hit:3 https://deb.nodesource.com/node_12.x buster InRelease
Hit:4 http://deb.debian.org/debian buster-updates InRelease
Hit:5 http://deb.debian.org/debian buster-backports InRelease
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
apt-utils is already the newest version (1.8.2).
avahi-daemon is already the newest version (0.7-4+b1).
avahi-discover is already the newest version (0.7-4).
avahi-utils is already the newest version (0.7-4+b1).
libavahi-compat-libdnssd-dev is already the newest version (0.7-4+b1).
build-essential is already the newest version (12.6).
dialog is already the newest version (1.3-20190211-1).
lsb-release is already the newest version (10.2019051400).
libnss-mdns is already the newest version (0.14.1-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
--30%
Version actuelle :
--40%
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
Package 'nodejs' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
--45%
Utilisation du dépot officiel
## Installing the NodeSource Node.js 12.x repo...
## Populating apt-get cache...
+ apt-get update
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Hit:4 https://deb.nodesource.com/node_12.x buster InRelease
Hit:5 http://deb.debian.org/debian buster-backports InRelease
Reading package lists...
## Confirming "buster" is supported...
+ curl -sLf -o /dev/null 'https://deb.nodesource.com/node_12.x/dists/buster/Release'
## Adding the NodeSource signing key to your keyring...
+ curl -s https://deb.nodesource.com/gpgkey/nodesource.gpg.key | apt-key add -
Warning: apt-key output should not be parsed (stdout is not a terminal)
OK
## Creating apt sources list file for the NodeSource Node.js 12.x repo...
+ echo 'deb https://deb.nodesource.com/node_12.x buster main' > /etc/apt/sources.list.d/nodesource.list
+ echo 'deb-src https://deb.nodesource.com/node_12.x buster main' >> /etc/apt/sources.list.d/nodesource.list
## Running `apt-get update` for you...
+ apt-get update
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Hit:4 https://deb.nodesource.com/node_12.x buster InRelease
Hit:5 http://deb.debian.org/debian buster-backports InRelease
Reading package lists...
## Run `sudo apt-get install -y nodejs` to install Node.js 12.x and npm
## You may also need development tools to build native addons:
sudo apt-get install gcc g++ make
## To install the Yarn package manager, run:
curl -sL https://dl.yarnpkg.com/debian/pubkey.gpg | sudo apt-key add -
echo "deb https://dl.yarnpkg.com/debian/ stable main" | sudo tee /etc/apt/sources.list.d/yarn.list
sudo apt-get update && sudo apt-get install yarn
Reading package lists...
Building dependency tree...
Reading state information...
The following NEW packages will be installed:
nodejs
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0 B/16.8 MB of archives.
After this operation, 88.4 MB of additional disk space will be used.
Selecting previously unselected package nodejs.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 68933 files and directories currently installed.)
Preparing to unpack .../nodejs_12.15.0-1nodesource1_arm64.deb ...
Detected old npm client, removing...
Unpacking nodejs (12.15.0-1nodesource1) ...
Setting up nodejs (12.15.0-1nodesource1) ...
Processing triggers for man-db (2.8.5-2) ...
Version actuelle : v12.15.0
--50%
--60%
Installation de Homebridge beta...
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm WARN registry Unexpected warning for https://registry.npmjs.org/: Miscellaneous Warning ENODATA: Cache input stream was empty
npm WARN registry Using stale data from https://registry.npmjs.org/ due to a request error during revalidation.
npm ERR! code EINTEGRITY
npm ERR! errno EINTEGRITY
npm ERR! Invalid response body while trying to fetch https://registry.npmjs.org/http-signature: Integrity verification failed for sha512-GwcDVdyQNHSaTapaA5mAzEcLH8l+smpd//gC6/X+rpITs7pgTgO77Lym08HHGXU4ElLrn55YMHZs/5XdHnUo8w== (/root/.npm/_cacache/content-v2/sha512/1b/07/0355dc9034749a4daa5a039980cc470b1fc97eb26a5dfff802ebf5feae9213b3ba604e03bbecbca6d3c1c71975381252eb9f9e5830766cff95dd1e7528f3)
npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-02-11T21_20_52_050Z-debug.log
--70%
--80%
--90%
--95%
--100%
Installation des dépendances Homebridge terminée, vérifiez qu'il n'y a pas d'erreur

Pouvez vous fournir le log indiqué à la fin ?

je n’arrive pas accéder au log… pouvez vous m’indiquer la marche à suivre svp ?

jeanpoil@Jeedom:~$  /root/.npm/_logs/2020-02-11T21_20_52_050Z-debug.log
-bash: /root/.npm/_logs/2020-02-11T21_20_52_050Z-debug.log: Permission denied

Tapez plutôt ceci en ligne de commande :

sudo npm cache clean --force

Puis relancez vos dépendances et envoyez moi à nouveau homebridge_dep

Merci @nebz ça fonctionne :ok_hand:
voici le log si besoin :

Installation dépendances sur Jeedom 4.0.38 sur Debian GNU/Linux 10 (buster)/arm64/aarch64/64bits aka 'freeboxDelta' avec nodeJS v12.15.0 et jsonrpc:enable et homebridge (beta) 2020-02-06 12:08:48
--0%
--10%
Lancement de l'installation/mise à jour des dépendances homebridge
--20%
Get:1 http://security.debian.org buster/updates InRelease [65.4 kB]
Hit:2 http://deb.debian.org/debian buster InRelease
Get:3 http://deb.debian.org/debian buster-updates InRelease [49.3 kB]
Get:4 http://deb.debian.org/debian buster-backports InRelease [46.7 kB]
Hit:5 https://deb.nodesource.com/node_12.x buster InRelease
Get:6 http://deb.debian.org/debian buster-backports/main Sources.diff/Index [27.8 kB]
Get:7 http://deb.debian.org/debian buster-backports/main Sources 2020-02-12-1412.45.pdiff [543 B]
Get:7 http://deb.debian.org/debian buster-backports/main Sources 2020-02-12-1412.45.pdiff [543 B]
Fetched 190 kB in 1s (130 kB/s)
Reading package lists...
Reading package lists...
Building dependency tree...
Reading state information...
apt-utils is already the newest version (1.8.2).
avahi-daemon is already the newest version (0.7-4+b1).
avahi-discover is already the newest version (0.7-4).
avahi-utils is already the newest version (0.7-4+b1).
libavahi-compat-libdnssd-dev is already the newest version (0.7-4+b1).
build-essential is already the newest version (12.6).
dialog is already the newest version (1.3-20190211-1).
lsb-release is already the newest version (10.2019051400).
libnss-mdns is already the newest version (0.14.1-1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
--30%
Version actuelle : v12.15.0
Ok, version suffisante
--50%
--60%
Installation de Homebridge beta...
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142
npm notice created a lockfile as package-lock.json. You should commit this file.
added 234 packages from 181 contributors and audited 1484 packages in 46.557s
15 packages are looking for funding
run `npm fund` for details
found 0 vulnerabilities
--70%
--80%
--90%
--95%
--100%
Installation des dépendances Homebridge terminée, vérifiez qu'il n'y a pas d'erreur

Parfait ! Bon amusement à toi !

1 J'aime

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.