Impossible de se connecter de l'exterieur à Jeedom via Synology

Bonjour,
Tout d’abord j’espère que ce topic à sa place dans cette section car je n’ai pas trouvé une catégorie concernant la configuration.

Alors mon problème étant que je n’arrive pas a configurer Jeedom pour y accéder depuis l’extérieur.
A savoir :

  • Mon jeedom est installer sur une VM d’un NAS Synology.
  • il n’est pas accessible en wifi mais via cable ethernet du nas lui même brancher sur le wifi.
  • j’arrive très bien a accéder a Jeedom en ip local.
  • j’ai désactivé antivirus et parefeu pour tester.

J’ai fouillé sur le net et suivi plusieurs tuto plusieurs fois mais rien n’évolue je tombe sur une page d’erreur :

Capture d’écran (50)

Sur ma Livebox

  • L’ip du de mon NAS et de Jeedom sont fixe.

Voici mes règles NAT/PAT pour le NAS
Capture d’écran (51)

Création du dns

Pour le dns je passe pas My NO-IP, tout simple.
MON-DNS redirige vers MON-IP-PUBLIC.

Configuration NAS

Sur le NAS je vais dans le portail des applications, puis Proxy inversé pour déclarer la redirection de la source de la DNS préalablement créée pour la rediriger vers l’ip local de Jeedom.

Capture d’écran (53)

Certificat SSL

Aussi coté sécurité je vais créer un certificat via Let’s enscript et spécifier pour quels services il est utilisé.

Capture d’écran (54)

Voilà ! et malgré ça impossible de se connecter, même en rentrant l’ip public de mon modem.
Alors je suis pas un expert et j’ai surement du rater qlq chose, si un détail vous interpelle je serai ravi !

je ne peux pas répondre pour le cas spécifique du synology en https.
Mais cela fonctionne t’il sur le port 80 (en http) ?

non plus, alors je viens de trouver une methode en fouillant sur le forum.
Alors je n’explique pas comment ça fonctionne, mais ça fonctionne … (!)

Du coup j’ai vérifié sur le NAS Synology dans le panneau « Web Station », en mettant le serveur principal HTTP sur Nginx (il était sur Apache pour moi)
Ensuite j’ai modifié sur ma Livebox les règles NAT pour que le port externe HTTPS soit 5004 vers 443
Puis enfin encore sur Synology j’ai rajouter une règle de proxy inversé, exactement la même que j’avais mais avec le port source 5004.
Et en rentrant https://MON-DNS:5004 je suis bien redirigé.
A mon avis ce n’est pas parfait et surement que quelqu’un de plus compétant saura l’expliquer.

Articles m’ayant inspiré :

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.