Fonctionnement surprenant Telegram

Bonjour
J’ai eu ce matin une drole de suprise :thinking:
J’ai parametré telegram pour m’envoyer un message de rappel auquel je peux répondre 3 mots prédéfinis: Oui/ Non/Rappel 2h
N’ayant pas vu le message avant le timeout, l’action par défaut s’est réalisée. Les 3 mots prédéfinis restant néamoins accessibles, j’ai après le timeout appuyé sur « rappel 2h »
La réponse du bot a été : C’est fait (Maison Pilotage VMC 2h)
=> Jeedom m’a donc lancé une action qui se lance via un bouton nommé « 2h » alors que j’ai n’ai absolument pas parametré cela!!

Y a -t-il un moyen d’éviter cela et de n’autoriser Telegram à n’accepter que les réponses prédéfinies?

Merci d’avance

Bonjour,

Je pense que si tu ne joins pas ton scénario et un peu de logs personne ne pourrais essayer de t’aider.

Bison

Tu es sûr que tu n’as pas plutôt paramétré Jeedom en faisant un scénario qui utilise telegram.

Et vu ce que tu dis je pense qu’effectivement le souci vient de ton scénario et pas de telegram !

Mais comme dit précédemment, on ne peut pas t’aider car on n’a aucune donnée pour le faire

Moi je parie plutot sur les interactions automatiques qui sont activées :wink:
config jeedom, onglet interactions.

Jeedom a reçu un message, il a tenté de trouver la commande correspondant le mieux à la demande.
S’il y a eu timeout c’est impossible que ca soit le scénario.

regarde le log interact.

1 J'aime

Bonjour, sinon dans l’action par défaut (« Aucune réponse ») y’a aussi la possibilité de mettre l’option empty=1 pour qu’il retire les choix de réponses si on rate le message.

Hello @Mips
Bien vu, effectivement en enlevant « interaction automatique » tout rentre dans l’ordre,
Merci beaucoup

@Kevin_Patault
Ta propositon m’intérese néanmoins, à quel endroit dois-je mettre « empty=1 »

Dans la partie option de la commande Telegram

1 J'aime