Explications logs http errors

Bonjour à tous,

J’ai actuellement un JEEDOM version 4.1.24 installé sur un raspberry pi 3b qui tourne sur Raspbian Buster version 10.

J’ai régulièrement ce genre de log dans la partie http Errors :

[Mon Sep 13 01:51:57.786909 2021] [access_compat:error] [pid 11661] [client 45.146.164.110:33244] AH01797: client denied by server configuration: /var/www/html/vendor/phpunit [Mon Sep 13 01:51:58.720383 2021] [access_compat:error] [pid 8358] [client 45.146.164.110:41726] AH01797: client denied by server configuration: /var/www/html/vendor/phpunit [Mon Sep 13 10:19:34.918157 2021] [access_compat:error] [pid 10732] [client 45.146.164.110:34100] AH01797: client denied by server configuration: /var/www/html/vendor/phpunit [Mon Sep 13 10:19:35.468280 2021] [access_compat:error] [pid 10722] [client 45.146.164.110:41754] AH01797: client denied by server configuration: /var/www/html/vendor/phpunit [Mon Sep 13 19:40:16.098991 2021] [access_compat:error] [pid 24440] [client 45.146.164.110:34798] AH01797: client denied by server configuration: /var/www/html/vendor/phpunit

J’ai lu sur le forum qu’il fallait configurer fail2ban pour éviter ce genre de choses, mais à priori j’ai loupé quelque chose :slight_smile:

Quelqu’un aurait-t’il des infos ?

A+

Bonjour,

C’est effectivement un robot ou autre qui scanne probablement.
Fail2ban ne va pas permettre d’éviter cela, le seul moyen s’est de ne pas brancher la box sur internet :wink:, par contre fail2ban va bannir et donc bloquer les ip qui ont effectuée des tentatives.

Merci pour ta réponse.

Je n’ai pas le choix de connecter le Pi vers l’extérieur, j’ai besoin de me servir de Jeedom en dehors de la maison. Peux-être qu’un VPN peut aider ?

Justement, Fail2ban n’a pas bloqué cette adresse alors qu’elle a fait plusieurs tentatives, peux-être un soucis de configuration.

A+

Oui évidement :wink:

Qu’avez-vous comme config ?

Re,

Fail2ban est configuré comme ceci (dans le fichier jail.local) :

[sshd]

enable = true
bantime = 1440m
findtime = 1m
maxretry = 2


[apache]

enabled  = true
bantime = 1440m
port     = http,https
filter   = apache-auth
logpath  = /var/log/apache2/*error.log
maxretry = 3
findtime = 600


[apache-noscript]

bantime = 1440m
enabled  = true
port     = http,https
filter   = apache-noscript
logpath  = /var/log/apache2/*error.log
maxretry = 3
findtime = 600

[apache-overflows]

enabled  = true
bantime = 1440m
port     = http,https
filter   = apache-overflows
logpath  = /var/log/apache2/*error.log
maxretry = 2
findtime = 600

[apache-badbots]

enabled  = true
bantime = 1440m
port     = http,https
filter   = apache-badbots
logpath  = /var/log/apache2/*error.log
maxretry = 2
findtime = 600

merci :slight_smile:

Du coup pas de règle pour le log http.errors, il n’y a que les règles par défaut d’apache.

Les erreurs http sous jeedom sont redirigé dans le log http.errors mais ce fichier n’est pas surveillé par fail2ban pour l’instant.
Il faut créer une nouvelle règle pour cela.

Dac.

Je suis novice dans la programmation du raspberry en général et je m’aide de tutos pour essayer de m’en sortir :grin:

Comment fait-on pour créer la règle http.errors ?

Je suis sur téléphone là donc un peu compliqué de donner des informations détaillées.
Je note pour plus tard dès que je trouve un peu de temps.
Mais il existe des tutos pour ce type d’action sur internet (p-e pas pour jeedom mais transposable).

ça marche,

merci pour le coup demain.

A bientôt

J’ai trouvé ça, au cas ou :

A+

1 J'aime

Re,

Bon, j’ai suivi le tutoriel mais à j’ai toujours les mêmes erreurs dans les logs.

Peut-être un soucis de config ?

A+