EWeJee et état

Tags: #<Tag:0x00007fcb945e54b8>

Bonjour
J’espère ne pas une discussion doublon (mais j’ai fait des recherches)
J’ai un module SONOFF basic 2 et le plugin EweJee. J’ai bien tout configuré car je le vois bien et les actions fonctionnent. Sauf qu’en mode lan, je n’ai pas le retour d’état qui s’actualise. Pourtant dans le log « Ewejee_lan », on voit bien l’info qui passe

{ status: 'ok', state: 'off' } 
{"action":"update","userAgent":"lan","deviceid":"1000d9b3b7","params":{"switches":[{"switch":"off","outlet":0}]}}
{ status: 'ok', state: 'on' }
{"action":"update","userAgent":"lan","deviceid":"1000d9b3b7","params":{"switches":[{"switch":"on","outlet":0}]}}
{ status: 'ok', state: 'off' }
{"action":"update","userAgent":"lan","deviceid":"1000d9b3b7","params":{"switches":[{"switch":"off","outlet":0}]}}

je suis en Jeedom 4.1.19 et le plugin en 2.0.2.

Merci pour vos lumières

j’ai modifier ton post avec ce principe essai de l’utiliser.

@fotimoli je crois que c’est pour toi ça

Hello,

C’est corrigé sur la bêta actuelle, je vais bientôt là basculer sur la stable si tout ce passe bien.

1 J'aime

Bonjour
J’ai fait la dernière mise à jour 2.1.0 mais ce n’est pas mieux pour le retour d’état :upside_down_face:

Cordialement

Donc la il y a un autre souci, il y a une une refonte complète sur le LAN le moteur est complètement différent.

Tu veux quoi comme info ?
Voici un bout de log et l’état ne remonte pas

[2021-02-25 11:21:02][DEBUG] : - ON en on
[2021-02-25 11:21:02][DEBUG] : [send_lan][1000d9b3b7] Sending ... {"switch":"on"}
[2021-02-25 11:21:02][DEBUG] : [send_lan]['.1000d9b3b7.'] {     "sequence": "1614248462123",     "deviceid": "1000d9b3b7",     "selfApikey": "5b9b6e47-0276-4cad-a9fe-f8987ed61e07",     "iv": "MTIzNDU2Nzg5MTIzNDU2Nw==",     "encrypt": true,     "data": "yi9k/NAsyNH8zF534MueQg==" }
[2021-02-25 11:21:02][DEBUG] : [send_lan][1000d9b3b7] {"seq":41,"sequence":"1614248462123","error":0}

@olive : c’est bon le format ? :grin: edit olive : YES

Tu peux voir dans le moteur de tâches si tu as un cron nommé « deamon » pour eWeJee ?

image
Visiblement Oui

Je ne vois pas sur la capture, il est lancé ou arrêté ?

Oups désolé
Il est « en cours »

Donc c’est qu’il y a un soucis sur le réseau quand un appareil changé d’état il envoie plusieurs packets mDns et ceux ci n’arrivent pas jusqu’à ton jeedom.

Peux tu d’écrire ta configuration réseau ?

J’oserais dire rien d’original
Un réseaux en 192.168.x.x, le sonoff et la jeedom sur le même réseau
Le sonoff en wifi 2.4. les actions fonctionnent mais pas le retour d’état donc ils communiquent entre eux
Le deamon est en « lan seulement » mais mon application sur le téléphone voit les changements d’état
Autre chose ?

Le multicast est bien autorisé ?

Tu ne donne pas beaucoup d’info sur ton réseau, notamment le routeur.