ESPeasy (espeasy)

Tags: #<Tag:0x00007f385c3beb38>

bonjour
je viens d’installer le plugin espeasy les dépendances ne s’installent pas .
Voila le log

Accueil
Analyse
Outils
Plugins
Réglages

18:56:30
Maison

ESPeasy (espeasy) - stable
Etat
Statut
Actif
Action
Version
2020-02-17 01:22:25
Version minimum Jeedom
3.3.24
License
AGPL
Logs et surveillance
Niveau log
Aucun Defaut Debug Info Warning Error
Logs
Heartbeat (min)
Redémarrer démon
Dépendances
Nom Statut Installation Dernière installation
Local NOK
2020-07-15 18:54:48
Démon
Nom Statut Configuration (Re)Démarrer Arrêter Gestion automatique Dernier lancement
Local NOK NOK Dépendances non installées
Inconnue
Configuration
IP Controleur à saisir dans ESPeasy (onglet config) :
192.168.0.3
Port Controleur à saisir dans ESPeasy (onglet config) :
8121
Publish template à saisir dans ESPeasy (onglet tools, puis bouton advanced) :
device=%sysname%&taskid=%id%&cmd=%valname%&value=%value%

Fonctionnalités
interact Non
cron Non
cron5 Non
cron10 Non
cron15 Non
cron30 Non
cronHourly
Non
cronDaily Non
deadcmd Non
health Non

Log du plugin

Début de l'installation
--2020-07-15 16:54:48--  https://raw.githubusercontent.com/lunarok/jeedom_nodejs/master/nodejs.sh
Resolving raw.githubusercontent.com (raw.githubusercontent.com)... 151.101.120.133
Connecting to raw.githubusercontent.com (raw.githubusercontent.com)|151.101.120.133|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1491 (1.5K) [text/plain]
Saving to: 'dependencies.sh'
0K .                                                     100% 7.53M=0s
2020-07-15 16:54:48 (7.53 MB/s) - 'dependencies.sh' saved [1491/1491]
dependencies.sh: 3: [: espeasy: unexpected operator
Version actuelle : 10
Hit:1 http://deb.debian.org/debian buster InRelease
Hit:2 http://deb.debian.org/debian buster-updates InRelease
Hit:3 http://deb.debian.org/debian buster-backports InRelease
Hit:4 http://security.debian.org buster/updates InRelease
Ign:5 http://ppa.launchpad.net/certbot/certbot/ubuntu focal InRelease
Err:6 http://ppa.launchpad.net/certbot/certbot/ubuntu focal Release
404  Not Found [IP: 2001:67c:1560:8008::15 80]
Reading package lists...
E: The repository 'http://ppa.launchpad.net/certbot/certbot/ubuntu focal Release' does not have a Release file.
Reading package lists...
Building dependency tree...
Reading state information...
lsb-release is already the newest version (10.2019051400).
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
KO, version obsolète à upgrader
Suppression du Nodejs existant et installation du paquet recommandé
Reading package lists...
Building dependency tree...
Reading state information...
Package 'npm' is not installed, so not removed
The following packages will be REMOVED:
libc-ares2* libnode64* nodejs* nodejs-doc*
0 upgraded, 0 newly installed, 4 to remove and 1 not upgraded.
After this operation, 30.5 MB disk space will be freed.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 71011 files and directories currently installed.)
Removing nodejs (10.21.0~dfsg-1~deb10u1) ...
Removing libnode64:arm64 (10.21.0~dfsg-1~deb10u1) ...
Removing libc-ares2:arm64 (1.14.0-1) ...
Removing nodejs-doc (10.21.0~dfsg-1~deb10u1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10) ...
dependencies.sh: 37: [: aarch64: unexpected operator
Utilisation du dépot officiel
## Installing the NodeSource Node.js 12.x repo...
## Populating apt-get cache...
+ apt-get update
Hit:1 http://security.debian.org buster/updates InRelease
Hit:2 http://deb.debian.org/debian buster InRelease
Hit:3 http://deb.debian.org/debian buster-updates InRelease
Hit:4 http://deb.debian.org/debian buster-backports InRelease
Ign:5 http://ppa.launchpad.net/certbot/certbot/ubuntu focal InRelease
Err:6 http://ppa.launchpad.net/certbot/certbot/ubuntu focal Release
404  Not Found [IP: 2001:67c:1560:8008::15 80]
Reading package lists...
E: The repository 'http://ppa.launchpad.net/certbot/certbot/ubuntu focal Release' does not have a Release file.
Error executing command, exiting
Reading package lists...
Building dependency tree...
Reading state information...
The following additional packages will be installed:
libc-ares2 libnode64 nodejs-doc
Suggested packages:
npm
The following NEW packages will be installed:
libc-ares2 libnode64 nodejs nodejs-doc
debconf: unable to initialize frontend: Dialog
debconf: (Dialog frontend will not work on a dumb terminal, an emacs shell buffer, or without a controlling terminal.)
debconf: falling back to frontend: Readline
debconf: unable to initialize frontend: Readline
debconf: (This frontend requires a controlling tty.)
debconf: falling back to frontend: Teletype
dpkg-preconfigure: unable to re-open stdin:
0 upgraded, 4 newly installed, 0 to remove and 1 not upgraded.
Need to get 0 B/6409 kB of archives.
After this operation, 30.5 MB of additional disk space will be used.
Selecting previously unselected package libc-ares2:arm64.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%
(Reading database ... 25%
(Reading database ... 30%
(Reading database ... 35%
(Reading database ... 40%
(Reading database ... 45%
(Reading database ... 50%
(Reading database ... 55%
(Reading database ... 60%
(Reading database ... 65%
(Reading database ... 70%
(Reading database ... 75%
(Reading database ... 80%
(Reading database ... 85%
(Reading database ... 90%
(Reading database ... 95%
(Reading database ... 100%
(Reading database ... 70872 files and directories currently installed.)
Preparing to unpack .../libc-ares2_1.14.0-1_arm64.deb ...
Unpacking libc-ares2:arm64 (1.14.0-1) ...
Selecting previously unselected package libnode64:arm64.
Preparing to unpack .../libnode64_10.21.0~dfsg-1~deb10u1_arm64.deb ...
Unpacking libnode64:arm64 (10.21.0~dfsg-1~deb10u1) ...
Selecting previously unselected package nodejs-doc.
Preparing to unpack .../nodejs-doc_10.21.0~dfsg-1~deb10u1_all.deb ...
Unpacking nodejs-doc (10.21.0~dfsg-1~deb10u1) ...
Selecting previously unselected package nodejs.
Preparing to unpack .../nodejs_10.21.0~dfsg-1~deb10u1_arm64.deb ...
Unpacking nodejs (10.21.0~dfsg-1~deb10u1) ...
Setting up libc-ares2:arm64 (1.14.0-1) ...
Setting up libnode64:arm64 (10.21.0~dfsg-1~deb10u1) ...
Setting up nodejs-doc (10.21.0~dfsg-1~deb10u1) ...
Setting up nodejs (10.21.0~dfsg-1~deb10u1) ...
update-alternatives: using /usr/bin/nodejs to provide /usr/bin/js (js) in auto mode
Processing triggers for libc-bin (2.28-10) ...
Processing triggers for man-db (2.8.5-2) ...
Version actuelle : v10.21.0
dependencies.sh: 59: dependencies.sh: npm: not found
chown: cannot access 'node_modules': No such file or directory
Fin de l'installation

bon j’ai trouvé

curl -L https://npmjs.org/install.sh | sudo sh

ont peux cloturer le sujet

Clic sur solution :wink:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.