Espace disque à 2%

Bonjour j’ai installé il y a 2 semaines « pour test » Jeedom sur un Raspberry 4 avec 2GB de mémoire et une carte SD de 32GB. J’ai 9 plugins et 7 scenarios simples. J’ai mis en route les backups quotidien sur mon NAS par SAMBA. Mais depuis quelques jours j’ai chaque matin seulement 2% de disque libre, je me demande ce qui a pu remplir quasiment 32GB aussi vite … le dernier plugin installé est CAMERA pour une EZVIZ C3W , j’ai l’impression que le problème d’espace disque existe depuis ce moment. Si je supprime la dernière sauvegarde quotidienne je remontes à 5% de disque donc il y a autre chose… quelqu’un a t il une idée ? je ne suis pas un pro en Linux mais merci d’avance :slight_smile:

Il me semble avoir lu sur le Forum que cela pouvait venir du plugin caméra

Essai du -s /var/* | sort -rn

j’obtiens celà en me connectant depuis mon macbook:
Linux raspberrypi 4.19.118-v7l+ #1311 SMP Mon Apr 27 14:26:42 BST 2020 armv7l

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Wed Aug 12 00:17:11 2020
pi@raspberrypi:~ $ du -s /var/* | sort -rn
du: impossible de lire le répertoire ‹ /var/cache/private ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/cache/ldconfig ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/cache/lightdm ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/cache/apt/archives/partial ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/private ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/php/sessions ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/samba/private/msg.sock ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/bluetooth ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/mysql/jeedom ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/mysql/mysql ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/mysql/performance_schema ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/lightdm ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/udisks2 ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/polkit-1 ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/lib/apt/lists/partial ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/log/private ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/log/lightdm ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/spool/cron/crontabs ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/spool/cron/atspool ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/spool/cron/atjobs ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/spool/exim4 ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/spool/rsyslog ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/tmp/systemd-private-9df9088e04c8406d8670e070533b02f3-ModemManager.service-mTmU7T ›: Permission non accordée
du: impossible de lire le répertoire ‹ /var/tmp/systemd-private-9df9088e04c8406d8670e070533b02f3-ntp.service-Gj5oae ›: Permission non accordée
1209236 /var/www
1139756 /var/cache
304732 /var/lib
102400 /var/swap
32160 /var/log
5756 /var/mail
5268 /var/backups
40 /var/spool
16 /var/tmp
4 /var/opt
4 /var/local
0 /var/run
0 /var/lock

Tu as passé la commande en root ?

Bonjour,
et la partition a bien été étendue sur toute la carte? fait-elle réellement les 32gb?

Le raspberry vient du ‹ kit › vendu par amazon avec Raspberry 4 2GB, boitier, carte SD 32GB, alimentation etc et j’ai suivi ce qui est indiqué dans ‹ jeedomiser.fr › pour l’installation. je ne me souviens pas avoir passé une commande spécifique pour définir la partition

avec ton du rajoute -h que ca soit lisible.

et df pour voir la taille des disks

df -h

en root:
pi@raspberrypi:~ $ sudo su
root@raspberrypi:/home/pi# du -s /var/* | sort -rn -h
sort: les options « -hn » sont incompatibles
root@raspberrypi:/home/pi# df -h
Sys. de fichiers Taille Utilisé Dispo Uti% Monté sur
/dev/root 27G 24G 1,5G 95% /
devtmpfs 815M 0 815M 0% /dev
tmpfs 944M 0 944M 0% /dev/shm
tmpfs 944M 25M 920M 3% /run
tmpfs 5,0M 8,0K 5,0M 1% /run/lock
tmpfs 944M 0 944M 0% /sys/fs/cgroup
tmpfs 256M 1,2M 255M 1% /tmp/jeedom
/dev/mmcblk0p6 253M 52M 202M 21% /boot
tmpfs 189M 0 189M 0% /run/user/1000

ça parait correcte au niveau taille 27Go total ± le swap on est pas loin des 32
Tu n’a pas mis des sauvegardes trop fréquentes dans ton plugin-camera ?
ou activé le mode capture de tes cameras ?

sur tes camera a tu cliqué sur le petit icone dossier pour voir ce qu’il y a dans l’historique ?

Tu peut aussi avec jeexplorer ou en ssh visualiser le contenu du repertoire data/records du plugin …

Capture d’écran du 2020-08-12 19-57-57

Oui je vais re-vérifier le plugin de la camera et son setting, voire le stopper quelques temps pour validre que le problème vient de là. J’avais mis en route le monitoring jeedom (très efficace !) et j’ai un message régulier sur l’utilisation disque. D’ailleurs cette nuit jeedom s’est arrêté, je viens de le relancer (par l’alim car je n’avais plus accès à rien…) . Dans l’historique de la caméra j’ai tout effacé je suis seulement à 9% dispo sur le disque. je n’ai pas de capture, seulement un flux rtsp. Ce qui me gêne c’est ce que je vois ici : /dev/root 27G 24G 1,5G 95% / … j’ai 95% d’utilisé à ce niveau sur 27G ? mais par quoi ? je crains que dans mes premiers pas avec Jeedom j’ai fait des boulettes et j’ai des gros fichiers stockés quelque part :slight_smile: sinon j’ai pu après quelques tâtonnements faire un ‹ design › et c’est vraiment top les possibilités sont infinies; je veux aussi installer des lampes et un détecteur de fumée, mais il faut d’abord régler ce pb de disque !!

Afficher les répertoires les plus volumineux

sudo du -xks * |sort -n

Commence par la racine puis descend dans les plus gros

après recherches j’ai trouvé que c’était les backups faits sur le NAS chaque nuit qui restaient depuis l’origine dans le repertoire ‹ mnt ›, donc rien à voir avec la caméra… je me suis aussi fait aider à distance via teamviewer par quelqu’un qui connait bien LINUX et du coup il a corrigé le problème, maintenant j’ai 70% de disque libre…
merci à tous pour votre aide ! j’ai bien noté les différentes commandes Linux et apprécié la rapidité de vos réponses. je peux à présent continuer avec des lampes Xiaomi et un détecteur de fumée Fibaro.

Bon super :+1:
Il ne te reste plus qu’a solutionner le fil
en cliquant sur solution du post qui ta le plus aider la repondre a ta question.

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.