Erreur sur eibd::BusMonitor() : connect failed mais démon fonctionnel

Tags: #<Tag:0x00007f28375da2a8> #<Tag:0x00007f28375da168>

Bonjour,
J’ai un petit souci avec le plugin KNX. Il fonctionne parfaitement depuis 1 an. Ayant des modifs à faire, sur le jeedom, je crée des commandes KNX. Au moment ou je termine, je vois apparaitre le message dans le titre. Ayant déjà eu le problème, je vérifie mes flags init et transmit. Tout parait normal. Je désactive les 2 équipements que j’ai modifié, je tente de relancer le démon, le statut reste à NOK. J’ai regardé le log Eibd, on voit les commandes défiler normalement et aucun message d’erreur.
En résumé, à part le NOK dans le statut du démon, tout fonctionne normalement.
Merci
Benoit

Bonjour,

Il y a une mise a jours sur le market, sur lequel j’ai ajouté des log pour lorsque le demon passe a NOK a cause d’un flag transmit ou Init.

Peux tu faire la mise a jours et verifier les log
Si le demon tourne et avec un NOK c’est tres probablement une flag transmission avec un objet non valide

Bonjour,
Merci, je regarde ça fin de semaine.
Benoit

Bonjour,
J’ai un peu tardé pour répondre.
En fait, hier, le démon s’est bloqué, et ne répondait plus. (en le passant en eibd et sans redémarrage automatique j’ai temporairement réglé le problème). Là je suis en train de vérifier tous les objets pour vérifier les flags. Mais j’ai un doute, le flag transmit devrait être actif sur toute commande action pour qu’elle soit fonctionnelle hors j’ai des commandes actions qui fonctionnent alors qu’aucun flag n’est actif. Est ce normal?
Merci
Benoit

Surtout pas.
Le flag « Transmission » ne doit etre actif uniquement lorsque l’on veux transmetre la valeur de sont retour d’etat.
Hors ce cas de figure est a utilisé uniquemen lorsque l’on veux faire un passerelle.

OK donc quand jeedom modife un objet, la valeur est transmise d’office.
Merci

Pas sur d’avoir bien compris la question
Une commande ACTION, n’a pas besoin de flag pour etre transmis sur le bus, car c’est considerer comme une action manuel.
On vas avoir besoin d’un flag dans le cas ou l’on veut transmettre une information sur le bus automatiquement, par exemple, chez moi je n’ai pas de station meteo mais j’ai besoin de la temperature exterieur pour mes thermostat.
J’ai donc cree un gad, liee a mes thermostat avec jeedom qui transmet la temperature exterieur provenant d’un autre plugin

OK,
Pour une info, il suffit donc du falg write a minima?
Merci
Benoit

Non pour une action standard aucun flag
Pour une info il faut effectivement à minima le flag write pour que la valeur du bus soit enregistrée sur jeedom

OK, je crois que j’ai compris, merci

Pour pas te tromper, part de template

Bonjour,
J’ai désactivé tous les flags sauf « write » sur les infos, et mon démon est toujours NOK. Dans les logs, j’ai bien le bus monitor et les infos remontent et redescendent mais rien d’autre. J’ai pour l’instant désactivé le redémarrage automatique du démon. Je n’ai rien vu d’autre.
Merci
Benoit

Peux-tu me donner un accès sur ton jeedom