Erreur Javascript après installation V4

Bonjour,

après avoir installer la V4, j’ai une icone attention et voilà ce que j’ai:
Java

Que puis-je faire s’il vous plait?

Bonsoir.

Redemarrer par exemple et vider le cache du navigateur et tester une authentification ensuite.

.dial je dirais plutôt widget tiers non supporté.

A tester objet par objet voir sur lequel ça fait l’erreur puis de quel équipement ça viens.

J’ai vidé le cache du navigateur, vidé dans jeedom et relancé, les erreurs reviennent.
J’ai supprimé le plugin widget il me semble comme demandé à la fin de l’installation de la V4

Pour « voir »

Si vous masquez vos objets sur le Dashboard, par exemple 50% de l’ensemble (à la louche).
Vous allez finir par trouver l’objet qui contient le Widget (merci @kiboost) qui pose le problème.

Il faut aller dans le menu Objets et sur vos objets, vous décochez la case visible.

Une copie d’écran de votre Dashboard pour voir ce qui pourrait poser le problème ?
- en sachant que le passage sur du 100% Widget Core est, et de loin, la meilleur idée.

J’ai donc retiré la visibilité de chaque objets de toute mes pièces.

Je les ai remis un par un et j’ai identifié lesquels.

Pour chaque pièces où il n’y a pas l’erreur qui apparait, je n’ai pas de thermostat (plugin thermostat de jeedom) dans mon dashboard. Donc je pense que c’est lui qui pose problème.

C’est vrai que la présentation de ce dernier est bizarre.

Voilà une capture pour exemple :
Capture

Il faut que je fasse du coup?

Je n’ai jamais changer les widgets, pourquoi ce n’est pas bien? et que dois-je faire du coup pour améliorer?

Bonjour, ton problème ressemble fortement a ce topic :

Bonsoir,

Créez un nouveau thermostat et basez vous sur les informations par défaut de celui-ci pour les reporter sur vos thermostats à problème.

Après par défaut, ce n’est pas forcement ce qui va vous convenir, on en parle après si vous avez besoin d’aide.

Effectivement, du coup maintenant que ce sont sûrement les thermostats, ça doit être le même problème que sur ce topic.

Par contre Loic de la team jeedom dit « Il faut repasser sur le widget core faut pas garder l’ancien du thermostat »
Mais franchement je ne sais pas du tout ou aller et quoi changer, même avec son deuxième message plus loin…

Vous pouvez m’aiguiller svp?

Faites ce que j’ai indiqué au dessus et on en reparle après.
Cela pour vous assurer que vous n’avez plus cette erreur.

j’ai fait un nouveau thermostat test pour ma salle à manger, il y a une différence oui, mais je dois regarder ou maintenant svp pour reproduire la même chose?
Ca risque d’être long en tout cas j’ai 9 thermostats…

Capture2

Long non, car maintenant vous pouvez copier tout ce qui est sur l’un, sur les 9 autres en même temps.
La réponse est dans la réponse de loic du post cité.

Il faut éditer le bon thermostat, cliquer sur le bouton [Configuration avancé] (à ne pas confondre avec l’onglet avancé).
Là, vous cliquez sur la 1ere roue crantée, allez dans l’onglet Affichage de cette commande.
Sur la ligne du Widget, vous avez un bouton Appliquer A. Vous sélectionnez alors la même commande pour l’appliquer sur les 9 autres thermostats.
Vous sauvegardez.
Et vous répétez cela sur toutes les roues crantées de la liste.

Idéalement, il ne faut le faire QUE sur la ou les commandes qui présentes le défaut, mais si vous ne pigez pas, autant le faire sur toutes les lignes.

Sur le topic envoyé plus tôt, Loic donne la solution :

Supprime ton widget perso/thermostat et passe sur un widget core pour la commande thermostat

ll semblerai que se soit le widget de la commande [Thermostat].
image
image
image

Merci à vous deux.

En effet ce n’était pas long ta méthode @Fabrice, et j’ai indiqué du coup que à la commande thermostat.

Je n’ai plus l’erreur aussi.

Voilà ce que ça donne :
Capture2

Je ne suis pas à l’aise avec tout ça, je m’y suis mis et voulu prendre jeedom pour plusieurs raisons, mais j’avoue que dès que je veux faire quelque chose je rame énormément et je mets beaucoup de temps pour chaque chose.

J’ai encore pas mal de question à poser sur des choses qui ne fonctionne pas ou que je n’arrive pas à faire mais bon. J’aurais peut-être dû prendre autre chose, mais il y a beaucoup d’aide ici donc c’est cool.