Erreur exécution de la commande / Erreur de connexion au cloud Tuya / setData() must be of the type array

Tags: #<Tag:0x00007f3863709de0>

Bonjour,
Depuis peu j’ai un problème de notification avec le plugin smartlife qui vient me remplir la notification de jeedom.
Le problème semble être lié aux commandes de la multiprise Konyks qui fonctionne (réponse à mes interactions) pourtant bien 95% du temps.
J’ai cherché sur le forum et vu un post similaire mais qui avait été résolu par son auteur en s’assurant que tous les devices étaient sur le cloud. J’ai checké de mon coté et j’ai bien les mêmes équipements coté cloud & coté plugin.
Une idée d’où cela pourrait venir ?
Merci à vous !

Erreur exécution de la commande [Salon][TV Salon][Allumer] : Erreur de connexion au cloud Tuya : Argument 1 passed to Sabinus\TuyaCloudApi\Device\Device::setData() must be of the type array, null given, called in /var/www/html/plugins/SmartLife/vendor/sabinus52/tuyacloudapi/src/Device/Device.php on line 145

Lo,

Une présentation un peu plus claire de ton installation sur laquelle tourne ton jeedom, une capture de ta page santé des logs en debug du plugin. Un peu plus d’informations qui faciliteraient la communauté à ciblé au mieux ton problème seraient un plus pour que la communauté puisse t’aider au mieux.
Si tu consultes le lien ci-dessous regarde les points 10 à 15,

Au plaisir, bonne journée

1 J'aime

Salut !

Merci Toms pour ton message.
Voici ci joint, je l’espère quelques éléments qui pourraient aiguiller les « helpers » !
Le problème que je rencontre, comme notifié plus haut, n’est que l’encombrement visuel des messages d’alertes jeedom (voir image ci dessous) : les équipements marchent (à 95% mais c’est pas bloquant).

Ma config :
Jeedom 3.3.53 VM Nasyno

Ci dessous mon log :
SmartLife.txt (799,7 Ko)

Voici maintenant une copie d’écran des erreurs dans mes messages jeedom :
notifjeedomsmartlife

Au tour de l’image de la plage de configuration du plugin… pour la capture page santé : je sèche je n’ai que l’option configuration et découverte pour ce plugin ?
configimage

Merci par avance !

Bonjour,

Je pense que le problème vient du Cloud Tuya. Depuis quelques temps, la requête de retour renvoie des données incomplètes comme l’état de la prise par exemple.
Du coup l’état reste inchangé ou à null.
J’ai remarqué que le problème survient le plus souvent quand on fait trop d’interrogation au Cloud Tuya. Pour ma part, je fais en sorte de limiter ses interrogations et je n’ai jamais d’erreur.

Une correction sera apportée pour éviter les messages d’erreur mais uniquement pour la version 4 de Jeedom. A partir de septembre 2020, le plugin ne sera plus supporté pour la version 3 de Jeedom.

Bonjour,
Merci pour ta réponse, je comprends.
Je vais faire le move vers la v4 :slight_smile:
Bonne soirée