Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Empty reply from server

Tags: #<Tag:0x00007f242f75a350>

Bonjour,

depuis aujourd’hui, j’ai ce message qui apparait quand je veux faire les mises à jour : Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Empty reply from server
Au départ, sachant qu’il y avait la maintenance aujourd’hui, je pensais que le problème venait de là. Mais ce soir, cela ne fonctionne toujours pas et je n’ai plus accès au market sur mon Jeedom. Aucun problème d’accès sur le market par internet. J’ai bien accès à mon Jeedom en externe (DN4 fonctionnel).
Est ce que quelqu’un aurait une solution a me proposer.
C’est une nouvelle install sur Debian 10 que j’ai fait la semaine dernière pour pouvoir envisager un passage en V4 (je suis toujours en V3.3.54). Tout fonctionnait parfaitement jusqu’à aujourd’hui, je n’ai pas fait d’install de plugin, de modification particulaire depuis la restauration de mon backup.

Merci

J’ai la meme chose egalement depuis ce jour:

[2020-12-08 17:24:08][ALERT] : [START UPDATE]
[2020-12-08 17:24:08][ALERT] : Début de la mise à jour de : kkasa
[2020-12-08 17:24:08][ALERT] : Action de pré-update...
[2020-12-08 17:24:08][ALERT] : OK
[2020-12-08 17:24:08][ALERT] : Téléchargement du plugin...
[2020-12-08 17:24:18][ALERT] : Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Operation timed out after 10001 milliseconds with 0 bytes received
[2020-12-08 17:24:18][ALERT] : [END UPDATE ERROR]

Jeedom V4.061

Je viens d’essayé de restaurer une sauvegarde de ce week-end, au cas ou, mais même problème d’accès au market et aux mises à jours avec.
Retour à la case départ…

Bonjour.
Pour info, le pb a disparu pendant quelques minutes (j’ai reussi une mise à jour d’un plugin), et là, j’ai à nouveau le pb.
Patience… patience…

Il ne devait pas y avoir une maintenance chez jeedom le 8 décembre ?

bonjour j’ai le problème encore ce matin,
le log de update

[3] => Array
(
[file] => /var/www/html/install/update.php
[line] => 65
[function] => checkAllUpdate
[class] => update
[type] => ::
[args] => Array
(
[0] =>
[1] =>
)
)
)
[END UPDATE ERROR]
PHP Fatal error:  Uncaught Exception: Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Empty reply from server in /var/www/html/core/repo/market.repo.php:812
Stack trace:
#0 /var/www/html/core/repo/market.repo.php(416): repo_market::byLogicalIdAndType(Array)
#1 /var/www/html/core/repo/market.repo.php(163): repo_market::getInfo(Array, Array)
#2 /var/www/html/core/class/update.class.php(82): repo_market::checkUpdate(Array)
#3 /var/www/html/install/update.php(65): update::checkAllUpdate('', false)
#4 {main}
thrown in /var/www/html/core/repo/market.repo.php on line 812

Merci pour l’aide

Salut :wink:

Je viens de modifier les tag du post pour que cela colle plus au souci.

Il y a bien un souci.

@Loic peux-tu jeter un oeil, cela semble le faire avec toute version de Jeedom

Merci

Erreur sur la verification des mies à jour : Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Empty reply from server

Bonjour
Pour ça il faut désactiver la vérification ssl. C’est du au changement de certificat ( l’équipe jeedom cherche une solution plus propre)

Merci de ton retour, mais on fait cela comment ?

@prfalken un apt update, upgrade à mis à jour les root ca chez moi et plus l’erreur. (oui ca faisait longtemps que je ne l’avais pas fait :grin:)

edit: ou alors qlqch a changé coté serveur

Oui les certificats ssl ont été renouvelé côté serveur c’est pour ca

1 J'aime

Je viens de tester sur mon alpha, et c’est OK !

Bon pas si facile que cela, sur ma prod j’ai tjrs le souci.
Pour tant j’ai fait apt-get update && upgrade.

J’ai cela lors de l’update

PHP Fatal error:  Uncaught Exception: Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Empty reply from server in /var/www/html/core/repo/market.repo.php:817
Stack trace:
#0 /var/www/html/core/repo/market.repo.php(421): repo_market::byLogicalIdAndType(Array)
#1 /var/www/html/core/repo/market.repo.php(163): repo_market::getInfo(Array, Array)
#2 /var/www/html/core/class/update.class.php(82): repo_market::checkUpdate(Array)
#3 /var/www/html/install/update.php(65): update::checkAllUpdate('', false)
#4 {main}
thrown in /var/www/html/core/repo/market.repo.php on line 817

@Loic, je suis perdu en fait: tu voulais dire que vous avez généré une deuxième fois des certifs pour régler le soucis ou pas en fait? j’ai p-e mal compris ta réponse?

Ou tu voulais dire que le problème est là parce que ce sont des nouveaux certifs?

parce que je pensais le problème réglé partout mais en fait finalement il ne semble pas
Désolé pour la confusion que j’ai introduite

Hello
Pour Info, j’ai le problème sur mes Jeedom V4.1.16
Si je coche « Pas de validation SSL » dans la config, il y a une erreur avec le bouton « Tester »
Si pas coché, le test est OK.

Dans les 2 cas on arrive à Empty reply … dans l’écran des mises à jour.

Idem, j’ai mis a jour comme suggéré par Mips, j’ai tenté Pas de validation SSL mais pas mieux.

On va laisser le temps à l’équipe de chercher le souci et le résoudre :wink:

hier apres 17h c etait mort , sauf les mises a jours.

Erreur sur la connexion au market : Exception Object ( [message:protected] => Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Could not resolve host: market.jeedom.com [string:Exception:private] => [code:protected] => 9999 [file:protected] => /var/www/html/core/repo/market.repo.php [line:protected] => 582 [trace:Exception:private] => Array ( [0] => Array ( [file] => /var/www/html/core/class/jeedom.class.php [line] => 1054 [function] => test [class] => repo_market [type] => :: [args] => Array ( ) ) [1] => Array ( [file] => /var/www/html/core/php/jeeCron.php [line] => 62 [function] => cron [class] => jeedom [type] => :: [args] => Array ( ) ) ) [previous:Exception:private] => )

aujourd hui :>
market non accessible
suppression ssl
market dispo et demande d installation d un plugin, apres 30s avoir cliker sur telecharger => message d erreur, server indisponnible.
verification mise a jour jeedom
mise a jour du 4.0 a la 4.1.16
comme par magie, apres la mise a jour du jeedom le plugin que je voulait telecharger est apparu dans les mises a jours
je regarde dans mes plugin => vide , pas de plugin.

[2020-12-09 09:24:24][DEBUG] : jsonrpcClient Object (     [errorCode:jsonrpcClient:private] => 9999     [errorMessage:jsonrpcClient:private] =>      [error:jsonrpcClient:private] => Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Empty reply from server     [result:jsonrpcClient:private] =>      [rawResult:jsonrpcClient:private] =>      [apikey:jsonrpcClient:private] =>      [options:jsonrpcClient:private] => Array         (             [username] => popol@hotmail.com             [password] => popolc2ffbf6eff3297bb1dc187f22cfa2 .

redemarrage
plugin tj pas dispo dans jeedom
telechargement via market
ok, le plugin me demande apres le telechargement si je veux l activé . il est maintenant installé et fonctionnelle .
je ne sais pas quand je dois remettre le ssl et si c est bien necessaire de le mettre pour la suite .

Hello
Je pense que Loic travaille dessus. On va attendre son retour.

Oui je fais que ca depuis ce matin ya bien un soucis mais la ca me depasser completement…

J’ai aussi le même depuis ce jour: ×Erreur curl sur : https://market.jeedom.com/core/api/api.php. Détail :Empty reply from server