Edition de la consigne via Google Assistant si Consigne < Température actuel

Tags: #<Tag:0x00007f3854735c88> #<Tag:0x00007f38547359b8> #<Tag:0x00007f3854735738>

Bonjour

j’ai remarqué que Google considère le Thermostat comme OFF si ce dernier est en mode Confort (par ex) mais que la température de la pièce étant supérieur a la consigne , du coup en effet le statut du thermostat (la commande Actif) est a 0

Hors , ca devrait pas être la cas, On devrait avoir le thermostat marqué comme Actif même si ca chauffe pas non ? , si jamais je veux passer par le Google pour monter la consigne pour que le chauffage démarre , et bien je peux pas car Google me dit que c’est etteint,

mais si je monte la consigne a 24° sur Jeedom, le statut du thermostat passe à ACTIF, du coup le thermostat sur GOOGLE est marqué comme allumé aussi.

une idée comment faire ?

Cordialement

Bonjour, j’ai exactement le même problème :

Si le thermostat est en statut « arrêté » sous jeedom parce que la température de la pièce est supérieure à la consigne, il apparait comme « éteins » et « Désac. » sur google home et il devient alors impossible à contrôler (changement de mode ne fonctionne pas et impossible de changer la consigne), cependant si le statut du thermostat change, il devient visible et opérable sous Google Home.

edit : par contre faire le sujet dans la section « communication » ou au pire « confort » avec les tags plugin-gsh et thermostat aurait probablement était plus efficace, je doute qu’on ait une réponse ici c’est pas la bonne section :frowning:

Bonjour

Heureux d’avoir été lu et de voir que tu partages le même soucis

j’ai procédé à la modification de section/tag , merci pour ton aide :+1:

Bonjour,

Pour la forme, évitons les mots en majuscules ainsi que de préfixer le titre avec des infos gérées par les tags déjà.

Sinon essayez d’adapter les types génériques des commandes ?

Bonjour

Dsl pour le titre, je vois que vous l’avez corrigé, merci

ReBonjour

Sinon concernant les types génériques des commandes, j’ai pas tous saisie, mais voilà ce que j’ai fais

  • j’ai 3 thermostats dans la maison, je parle de 3 thermostats créés dans le plugin officiel Jeedom Thermostat. Ça me permet de diviser les zones de chauffages de ma maison.

Je suis donc allé dans le plugin Google Smarthome, le plugin officiel de Jeedom, j’ai sélectionné mes 3 thermostats. Toutes les commandes sont automatiquement mappé, j’ai juste du associer les Mode, vu que j’ai pas. De Clim j’ai associé le mode Chauffe à mon mode CONFORT des thermostat, le mode Eco au ECO des thermostats et le Off a OFF des thermostats. J’ai laissé à aucun le mode froid

Sinon j’ai touché à rien d’autre

Bonjour,
La gestion des thermostats est vraiment complexe chez Google. Pour tester j’ai fait une modification qui sera dans la beta de demain a voir si ca corrige mais surtout si ca ne casse pas quelque chose d’autre.

Super merci beaucoup pour la réactivité

Comment je peux tester la bêta ?

Cordialement

En cochant la case Activer l’accès aux plugins beta depuis ton profil utilisateur sur market.jeedom.com d’une part et après depuis ton jeedom appeler le plugin et prendre la version beta

merci ! je vais le faire

Merci pour ton retour, je ferais une update demain de la situation alors

Toujours pareil !

flute !

peut être que le soucis a été mal expliqué,

Je crois que Actuellement le plugin GSH envoit à Google le Statut Actif du Thermostat. Hors ce dernier = 1 uniquement lorsque le Thermostat donne l’ordre de chauffe. Donc si on a activé en mode confort le Thermostat (T° 18°) mais qu’il fait 19° dans la pièce deja, le statut Actif du plugin = Thermostat sera à = 0

Il faudrait envoyer un statut à Google du genre Statut_différent_de_Off , ainsi même si le thermostat est pas techniquement en ordre de chauffe, dès qu’il est pas sur l’ordre OFF, on aurait un 1 envoyé

Si le soucis avait bien été compris, toutes mes excuses pour la paraphrase !

C’est bien ce que j’ai changé hier dans le code.

Vous etes bien sur la beta ?

20200930_102000 20200930_101923 20200930_101857 20200930_101846 20200930_101834

Voilà
Je suis en bien sur la bêta, installé ce matin
Mon thermostat est allumé en mode confort (mais en statut Arrêté car la Température de la pièce > température consigne
On constate sur le thermostat du Google (j’ai relancé la synchro évidemment avant) que le thermostat est à OFF que ce soit en mode ou en consigne

Cdt

Ok je vois c’est donc le mode qui fait tout :
image

Ya ca comme mode, je peux pas mettre heat/cool car je sais pas le mode actuel. Donc reste On et off qui normalement colle avec standby

Exactement pareil, je suis bien en beta également

La beta de demain mettra le status en on au lieu de off a voir si ca va pour le besoin

Bonjour,

Toujours le même problème, à la différence que maintenant cela apparait en mode « autre » (voir capture)

Screenshot_20201001-013826