Doordird - Clé API non valide

Tags: #<Tag:0x00007f28365ecaa8>

Bonjour tout le monde, bonjour @lunarok

J’essaye de configurer mon doorbird d2101v.
Je suis sur Jeedom v4.0.54, installé sur Debian 10

Mes identifiants Doorbird sont bons, aucun souci de ce coté.
Mon doorbird est en IP fixe (192.168.86.90)
L’appli doorbird sur iPhone et Android fonctionne sans souci.
L’installation du plugin ne présente aucun souci particulier.

La config réseau de Jeedom est OK.

Par contre, quand j’enregistre mon doorbird :

  • je n’ai pas le build, firmware, model qui apparaissent
    Capture d’écran 2020-05-23 à 10.48.45

  • dans les logs, j’ai ceci :


[2020-05-23 10:43:34][DEBUG] : Appel : info.cgi, Retour : 
[2020-05-23 10:43:35][DEBUG] : Appel : notification.cgi?reset=1, Retour : 
[2020-05-23 10:43:37][DEBUG] : Appel : notification.cgi?url=http://192.168.86.8:80/plugins/doorbird/core/api/jeeDoorbird.php?apikey=SxxxxxxxxxxxxxZw45r0%26id=260%26sensor=doorbell&subscribe=1&event=doorbell, Retour : 
[2020-05-23 10:43:39][DEBUG] : Appel : notification.cgi?url=http://192.168.86.8:80/plugins/doorbird/core/api/jeeDoorbird.php?apikey=SKxxxxxxxxxxxxxxxxZw45r0%26id=260%26sensor=dooropen&subscribe=1&event=dooropen, Retour : 
[2020-05-23 10:43:41][DEBUG] : Appel : notification.cgi?url=http://192.168.86.8:80/plugins/doorbird/core/api/jeeDoorbird.php?apikey=SKxxxxxxxxxxxZw45r0%26id=260%26sensor=motion&subscribe=1&event=motionsensor, Retour : 

Quand j’essaye une des URL proposée par les logs, j’ai ce message :
Clef API non valide, vous n’êtes pas autorisé à effectuer cette action (doorbird)
Capture d’écran 2020-05-23 à 10.51.24

Je n’ai aucune URL qui s’ajoute automatiquement dans l’application doorbird (ce qui est normal, vu le souci d’api).

  • J’ai réinstallé le plugin
  • J’ai recréé l’équipement
  • J’ai essayé avec differents comptes existants sur l’app du doorbird, y compris l’admin
  • J’ai essayé de réinitialiser la clé API dans Jeedom
    Capture d’écran 2020-05-23 à 10.54.02

J’ai clairement un souci d’API.
Qu’est ce que je fais de mal ?

Merci

Merci de ne pas tagger les développeurs au premier post sans aucune raison.
Là en plus il y a deux soucis, pas de retour du doorbird (surement user/password) et la clef qui n’est pas acceptée.

Bonjour, j’ai un doorbird 101S et j’ai deux login / pwd:
1 pour l’équipement
1 pour l’admin (dans l’appli mobile)

Je n’avais pas utilisé le bon dans le plugin au début et j’avais les mêmes symptômes.

Peux-tu vérifier ?
Merci

1 J'aime

C’était effectivement pas très clair quel login utiliser, mais j’ai bien mis celui de « Appareil » et non celui des admins (que j’ai également essayé).
D’ailleurs, si ca peut en aider d’autres :
Screenshot_20200523-154436_DoorBird - copie

Bon, sinon, du coup, ca ne fonctionne pas.
Tant pis, je vais faire autrement. Merci pour le coup de main.

C’est pas ‹ ca fonctionne pas › mais tu n’arrives pas à le configuré. Le plugin fonctionne très bien.
Lucky t’as posé des questions c’est dommage de rembarrer et pas fournir plus d’infos

T’es un peu à cran, non ? :flushed: Restons cool ^^

1/ Je n’ai pas rembarré Lucky, je l’ai même remercié de son coup de main. J’ai certes reprécisé que j’avais essayé plusieurs mots de passe, mais de là à le rembarrer…
Par ailleurs, sa réponse doit résoudre le souci chez d’autres, parce que c’est effectivement un truc qui peut faire foirer l’installation d’un portier, cette confusion entre mot de passe de l’appareil et mot de passe de l’admin

2/ Oui, ça ne fonctionne pas CHEZ MOI.
Je ne crois pas avoir remis en cause le plugin,sinon, ca ne marcherait pas chez d’autres et ca n’a pas l’air d’être le cas

Je soupçonne un souci soit sur le réseau soit sur les clés API.
Je n’ai pas trop de temps de creuser pour l’instant et j’ai une solution de contournement via une tablette inusée pour l’instant, donc oui, je vais faire autrement et je chercherai plus tard ce qu’il se passe.

Merci à tous de votre aide rapide.

Update
Regénération de la clé API
Reboot de la machine
Reboot du routeur ET du switch du garage

Et ca fonctionne :slight_smile:
Comme quoi…

Merci à tous, bisous :slight_smile:

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.