DNS Jeedom 404

Problème 404 ou erreur de communication quand j’essaie d’aller sur mon jeedom depuis l’extérieur avec mon téléphone, sur le navigateur.
Je n’ai pas l’application mobile.
Si je me connecte depuis mon vpn (qui est chez moi) ca fonctionne bien.

Je ne comprends pas comment ca se fait. Je croyais que jeedom était indépendant de cloud. Comment un problème de votre côté peut m’empêcher de me connecter ?

Comme repeté plusieurs fois : ce n’est pas un probleme de DNS… mais un probleme de web app qui bloque l’utilisateur du a la rotation des clefs api chez certain utilisateur… Une correction a été publié ce matin suite à la mise à jour il faudra attendre 10/15min pour que les utilisateurs banni ne le soit plus et la webapp devrait vous demander de vous authentifier.

Pour rappel je suis benevole jeedom et je ne représente aucunement la societé jeedom (je n’en fait pas partie)

Bonjour,
C’est bon pour moi ça fonctionne à nouveau.

Bonjour,

ça fonctionne de nouveau pour moi également.

Je rencontre de nouveau l’erreur 404 après avoir utiliser l’app mobile :frowning:

mais sinon, non il n’y a JAMAIS de problème DNS, non ô grand jamais.

Il n’y a pas de probleme coté serveur comme je l’ai expliqué mais de toute facon ce debat est stérile quand ya des soucis on le dit on a aucune raison de vous le cacher mais bon.

Enfin tout ca me fatigue donc quoique tu dise je suis 100% d’accord avec toi pas de soucis.

1 J'aime

Bonjour à tous,

Je me greffe sur le sujet.
Utilisant depuis qq mois maintenant les systèmes DNS en test (en alpha), je n’avais pas fait attention que la solution stable actuelle (dns1,dns2…) ne fonctionnait plus chez moi (erreur 404).
Je viens de voir que je suis passé du dns3 au dns1. Peut-être un lien avec mon passage de mon statut en dev :slight_smile: ou pas !?
Du coup je dois le remettre en place avec l’arrêt du système en test.
De ce que je vois dans les logs, il s’agirait d’un souci de certificat :

Tue Jul  7 09:23:50 2020 WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Tue Jul  7 09:23:50 2020 TCP/UDP: Preserving recently used remote address: [AF_INET]xxx.xxx.xxx.xxx:xxxx
Tue Jul  7 09:23:50 2020 UDP link local: (not bound)
Tue Jul  7 09:23:50 2020 UDP link remote: [AF_INET]xxx.xxx.xxx.xxx:xxxx
Tue Jul  7 09:24:50 2020 TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Tue Jul  7 09:24:50 2020 TLS Error: TLS handshake failed
Tue Jul  7 09:24:50 2020 SIGUSR1[soft,tls-error] received, process restarting

L’autre information est que dans la partie configuration de mon jeedom, j’ai toujours le dns en eu.jeedom.link. Malgré un arrêt / redémarrage. Côté market, j’ai bien la bonne adresse.
Merci pour votre aide,

Xav

Pour l’url ton jeedom est il a jour ? La suppression du dns en eu.jeedom.link passe par une mise à jour
Pour l’erreur que tu as c’est un soucis firewall/réseaux qui empeche le flux de passer et non un soucis de certificat (l’erreur est trompeuse)

Yes, jeedom en v4.0.59 et openvpn à jour.
Je vais forcer un update.
Pour la partie firewall, je regarde sur ma freebox et te tiens au jus

La derniere version c’est la 4.0.60…

yes je viens de voir la MAJ. Côté configuration, je suis bien repassé sur mon adresse xxx.dns1.jeedom.com
Il me reste à creuser côté freebox pour cette erreur 404

Bon ben j’ai fait la dernière mise à jour 4.0.60 et j’ai de nouveau le même problème avec l’application, je n’arrive plus à me connecter.
Rappel :
Lorsque j’essaie de me connecter au webview de l’application Jeedom (android) , rien ne se passe, ça reste sur les identifiants et mot de passe. Ensuite l’application est déconnectée, c’est à dire qu’à la page d’accueil l’application essaie de se connecter à Jeedom mais n’y arrive pas. Pour info, ça marchait avant que j’aille sur le webview.
Autre bizarrerie, j’essaie de me connecter via chrome de mon portable sur lequel se trouve l’application jeedom, j’ai erreur 404 que si j’ai essayé de me connecter au webview de l’application avant. Je redemarre le téléphone, je ne vais pas sur le webview et j’ai pas de problème pour me connecter.
Autres informations, je n’ai aucun problème pour me connecter à Jeedom via un pc.
Je n’avais pas remarqué ça avant ce matin. Dernière info, ce matin tous mes Jeedom m’ont demandé de m’identifier, alors que c’est normalement enregistré .
J’utilise beaucoup l’application …

idem avec nouvelle adresse dns0

erreur 404 sur navigateur 4.0.60

Idem erreur 404 en eu.jeedom.link, il a fallu que je redémarre le dns et du coup je suis en dns2 .
Cela fait déjà 3 fois que j’ai ce problème, heureusement que je suis à la maison car en 4g j’avais plus rien d’accessible

pareil, mon ip est blacklistée dans jeedom

c’est revenu … :+1:

Idem pour moi sans action de ma part. Hier à 8h41, mon VPN était de nouveau actif et les erreurs TLS n’étaient plus d’actualité !

pareil, aucune action.
Hier après la mise à jour ça ne marchait plus, ce matin vers 9h/10h ça marchait à nouveau …