Détecteur de fumée - Frient

Tags: #<Tag:0x00007fc6ba1b9300>

Bonjour,

Je viens d’acquérir deux détecteurs de fumée de la marque Frient.
https://www.domadoo.fr/fr/peripheriques/5409-frient-detecteur-de-fumee-intelligent-zigbee-30-5713594002330.html?search_query=frient&results=21

Je ne parviens pas à les associer avec Abeille.
Quelqu’un a t-il déjà réussi avec ce Plugin ?

Mon système :
Version de Jeedom : 3.3.59
Rasperry : model 3b (encore sous buster)
PiZiGate+

Merci

Salut

Tu peux suivre ça pour tenter d’avoir un discovery.json: Ajout d’un nouvel équipement — Documentation Abeille 11.02.2021

Hello,

Merci pour ta réponse. Je ne connaissais pas cette méthode.
Mais, à moins que je fasse erreur, il faut que l’équipement soit créer dans Abeille pour cela ?

Or ce n’est pas le cas. J’ai essayé de l’associer plusieurs fois. Rien ne se passe dans Abeille.

Le Firmware de la pizigate était encore en 3.1A. Je viens de passer sur la dernière version 3.20 legacy. Mais rien n’y fait. Et aucun log dans Abeille.

Oui tout à fait. Un équipement doit etre créé dans tous les cas. Ca sera « defaultUnknown » si inconnu.

Aucun log ? Alors mets toi en mode debug, 5000 lignes: Support — Documentation Abeille 11.02.2021

As tu d’autres equipements sous Abeille ou est ce ta premiere tentative ?

Hello,

Je refais un essai, en mode debug et avec les 5000 lignes de log.

Voici ce que je viens de trouver :

[2021-11-27 09:36:02][DEBUG] : message(topic='Abeille1/392B/0500-23-0000', payload='0030')
[2021-11-27 09:36:02][INFO] : Des informations remontent pour un equipement inconnu d Abeille avec pour adresse 392B et pour la commande 0500-23-0000
[2021-11-27 09:36:02][DEBUG] : L equipement Abeille1/392B n existe pas dans Jeedom, je ne cherche pas a le recupérer, param: blocage recuperation equipment.
[2021-11-27 09:36:03][DEBUG] : checkAllDaemons() => ok
[2021-11-27 09:36:03][DEBUG] : cron1: 10900/SerialRead1, 10903/Parser, 10905/Cmd
[2021-11-27 09:36:03][DEBUG] : publishMosquitto(): Envoyé '{"topic":"TempoCmdAbeille1\/0000\/getZgVersion&time=1638002183","payload":""}' vers queue 123
[2021-11-27 09:36:06][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:11][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:16][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:21][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:24][DEBUG] : msgFromParser(): Abeille1, Zigate version 0003-0320
[2021-11-27 09:36:26][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:32][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:37][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:37][DEBUG] : msgFromParser(): Abeille1, permit join, status=01
[2021-11-27 09:36:47][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:48][DEBUG] : Launch of Abeille_pre_update_analysis()
[2021-11-27 09:36:48][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}
[2021-11-27 09:36:48][DEBUG] : End of Abeille_pre_update()
[2021-11-27 09:36:53][DEBUG] : deamon_info(): {"state":"ok","launchable":"ok","launchable_message":""}

J’ai 7 équipements dans Abeille. Des lampes et prises Ikea. Jamais eu de problème.

Mais mon système date un peu.
J’étais encore avec le firmware 3.1A de la zigate, et je suis toujours sous Jeedom 3
Je vais tenter la migration vers Jeedom 4, et passer le raspberry sous Stretch. Peut être que ça résoudra le problème.

Le fait que cet equipement ne soit pas supporté n’a rien à voir avec la version de Jeedom ou du kernel.

Le seul truc à faire pour Abeille, est d’avoir un firmware >= 3.1D. Et quitte à le mettre à jour je te suggere « 3.20-legacy ». Pas de reappairage necessaire dans ce cas.

Ensuite j’ai besoin du discovery.json pour voir comment supporter ce modele. Tu as le lien de la doc pour le faire. La balle est chez toi.
Une fois que tu as le discovery, ouvre un sujet ici: https://github.com/KiwiHC16/Abeille/issues/new/choose

Hello,

Merci pour ton retour.

J’ai fait la migration vers Buster (ça fait pas de mal) et testé avec jeedom 4.1. Mais en effet, même résultat.
Je suis en 3.20-legacy depuis peu.

J’aimerai avoir ce discovery.json. Mais en suivant la méthode pour associer l’appareil, aucun équipement ne se crée dans Abeille.
Pourtant, je vois la zigate clignoter rapidement dès que je lance l’association. Ce qui laisse entendre que la communication fonctionne. Mais rien dans Abeille ni dans les logs.

Salut
Si tu n’as rien dans les logs, es tu bien en mode « debug » ?
Voir: Support — Documentation Abeille 11.02.2021

Pour l’ajout d’un nouveau periph, je te laisse creer un sujet la https://github.com/KiwiHC16/Abeille/issues/new/choose
et on s’y retrouve. merci