Dépendances non installées, comment faire?

Bonjour à tous,

Je souhaite faire parler mon google home avec le plugin googlecast.
Problème en installant le plugin, les dépendances ne s’installent pas. Ca tourne en boucle. Je ne comprends pas d’où vient le problème.

Version plugin : 2020-02-18 08:59:56
Version Jeedom : 3.3.45

D’avance merci

Et on peut voir le log des dépendances pour voir ou ca coince ou on doit sortir la boule de cristal ?

De mémoire il y a plusieurs postes qui traitent ce sujet. Je crois qu’il faut faire une mise à jour de nodejs. Il me semble que cela est indiqué dans le log d’installation des dépendances. Comme souvent rappelé, il faut fournir un maximum d’élément pour aider à résoudre les problèmes. Les logs en font parti.

Voici le dernier log, ce sera en effet plus simple qu’avec une boule de cristal :innocent:

Launch install of googlecast dependancies
-- Current OS version :
Description:	Debian GNU/Linux 8.9 (jessie)
-- Updating repo...
Ign http://httpredir.debian.org jessie InRelease
Hit http://httpredir.debian.org jessie-updates InRelease
Hit http://security.debian.org jessie/updates InRelease
Ign http://http.us.debian.org jessie InRelease
Get:1 http://repo.jeedom.com ./ InRelease [277 B]
Ign http://repo.jeedom.com ./ InRelease
Hit https://deb.nodesource.com jessie InRelease
Get:2 http://repo.jeedom.com ./ Release.gpg [277 B]
Hit http://httpredir.debian.org jessie Release.gpg
Ign http://repo.jeedom.com ./ Release.gpg
Hit http://httpredir.debian.org jessie Release
Get:3 http://repo.jeedom.com ./ Release [277 B]
Ign http://repo.jeedom.com ./ Release
Get:4 http://repo.jeedom.com ./ Sources/DiffIndex [277 B]
Ign http://repo.jeedom.com ./ Sources/DiffIndex
Hit http://http.us.debian.org jessie Release.gpg
Get:5 http://repo.jeedom.com ./ Packages/DiffIndex [277 B]
Ign http://repo.jeedom.com ./ Packages/DiffIndex
Get:6 http://repo.jeedom.com ./ Translation-en [277 B]
Get:7 http://repo.jeedom.com ./ Sources [277 B]
Err http://repo.jeedom.com ./ Sources
Get:8 http://repo.jeedom.com ./ Packages [277 B]
Err http://repo.jeedom.com ./ Packages
Get:9 http://repo.jeedom.com ./ Translation-en [277 B]
Hit http://http.us.debian.org jessie Release
Get:10 http://repo.jeedom.com ./ Sources [277 B]
Err http://repo.jeedom.com ./ Sources
Get:11 http://repo.jeedom.com ./ Packages [277 B]
Err http://repo.jeedom.com ./ Packages
Get:12 http://repo.jeedom.com ./ Translation-en [277 B]
Get:13 http://repo.jeedom.com ./ Sources [277 B]
Err http://repo.jeedom.com ./ Sources
Get:14 http://repo.jeedom.com ./ Packages [277 B]
Err http://repo.jeedom.com ./ Packages
Get:15 http://repo.jeedom.com ./ Translation-en [277 B]
Get:16 http://repo.jeedom.com ./ Sources [277 B]
Err http://repo.jeedom.com ./ Sources
Get:17 http://repo.jeedom.com ./ Packages [277 B]
Err http://repo.jeedom.com ./ Packages
Get:18 http://repo.jeedom.com ./ Translation-en [277 B]
Ign http://repo.jeedom.com ./ Translation-en
Get:19 http://repo.jeedom.com ./ Sources [277 B]
Err http://repo.jeedom.com ./ Sources
HttpError404
Get:20 http://repo.jeedom.com ./ Packages [277 B]
Err http://repo.jeedom.com ./ Packages
HttpError404
Get:21 http://httpredir.debian.org jessie-updates/main Sources [20 B]
Get:22 http://httpredir.debian.org jessie-updates/main armhf Packages [20 B]
Get:23 http://httpredir.debian.org jessie-updates/main Translation-en [14 B]
Get:24 http://security.debian.org jessie/updates/main Sources [344 kB]
Get:25 https://deb.nodesource.com jessie/main Sources [687 B]
Get:26 https://deb.nodesource.com jessie/main armhf Packages [930 B]
Get:27 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:28 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:29 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:30 https://deb.nodesource.com jessie/main Translation-en [162 B]
Get:31 http://security.debian.org jessie/updates/main armhf Packages [743 kB]
Get:32 https://deb.nodesource.com jessie/main Translation-en [162 B]
Ign https://deb.nodesource.com jessie/main Translation-en
Get:33 http://security.debian.org jessie/updates/main Translation-en [391 kB]
Hit http://http.us.debian.org jessie/non-free armhf Packages
Hit http://http.us.debian.org jessie/non-free Translation-en
Get:34 http://httpredir.debian.org jessie/main Sources [7063 kB]
Get:35 http://httpredir.debian.org jessie/main armhf Packages [6675 kB]
Get:36 http://httpredir.debian.org jessie/main Translation-en [4581 kB]
Fetched 1617 B in 1min 56s (13 B/s)
W: Failed to fetch http://repo.jeedom.com/depot/repo.jm0.eu/BSP:/IMX6/Debian_Jessie/./Sources  HttpError404
W: Failed to fetch http://repo.jeedom.com/depot/repo.jm0.eu/BSP:/IMX6/Debian_Jessie/./Packages  HttpError404
E: Some index files failed to download. They have been ignored, or old ones used instead.
-- Installation of python3 and dependancies
Reading package lists...
Building dependency tree...
Reading state information...
build-essential is already the newest version.
python-dev is already the newest version.
python3 is already the newest version.
The following packages were automatically installed and are no longer required:
python-ecdsa python-jwt python-lockfile python-oauthlib python-paramiko
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 262 not upgraded.
-- Installed version of Python :
Python 3.4.2
Your version of python is not compatible with this plugin, installation might not work correctly !
-- Installation of pip for python3 and necessary libraries
Reading package lists...
Building dependency tree...
Reading state information...
python3-pip is already the newest version.
python3-dev is already the newest version.
python-requests is already the newest version.
The following packages were automatically installed and are no longer required:
python-ecdsa python-jwt python-lockfile python-oauthlib python-paramiko
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 262 not upgraded.
-- Installation of audio sox library
Reading package lists...
Building dependency tree...
Reading state information...
sox is already the newest version.
The following packages were automatically installed and are no longer required:
python-ecdsa python-jwt python-lockfile python-oauthlib python-paramiko
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 262 not upgraded.
-- Installation of TTS libraries
Reading package lists...
Building dependency tree...
Reading state information...
libttspico-utils is already the newest version.
The following packages were automatically installed and are no longer required:
python-ecdsa python-jwt python-lockfile python-oauthlib python-paramiko
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 262 not upgraded.
-- Installation of libav/ffmpeg libraries
Reading package lists...
Building dependency tree...
Reading state information...
libav-tools is already the newest version.
libavcodec-extra is already the newest version.
The following packages were automatically installed and are no longer required:
python-ecdsa python-jwt python-lockfile python-oauthlib python-paramiko
Use 'apt-get autoremove' to remove them.
0 upgraded, 0 newly installed, 0 to remove and 262 not upgraded.
-- Upgrade setuptools with command pip3 if not up to date
Traceback (most recent call last):
File "/usr/bin/pip3", line 9, in <module>
load_entry_point('pip==1.5.6', 'console_scripts', 'pip3')()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 356, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2476, in load_entry_point
return ep.load()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2190, in load
['__name__'])
File "/usr/lib/python3/dist-packages/pip/__init__.py", line 74, in <module>
from pip.vcs import git, mercurial, subversion, bazaar  # noqa
File "/usr/lib/python3/dist-packages/pip/vcs/mercurial.py", line 9, in <module>
from pip.download import path_to_url
File "/usr/lib/python3/dist-packages/pip/download.py", line 25, in <module>
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead'
-- Installed version of pip :
Traceback (most recent call last):
File "/usr/bin/pip3", line 9, in <module>
load_entry_point('pip==1.5.6', 'console_scripts', 'pip3')()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 356, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2476, in load_entry_point
return ep.load()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2190, in load
['__name__'])
File "/usr/lib/python3/dist-packages/pip/__init__.py", line 74, in <module>
from pip.vcs import git, mercurial, subversion, bazaar  # noqa
File "/usr/lib/python3/dist-packages/pip/vcs/mercurial.py", line 9, in <module>
from pip.download import path_to_url
File "/usr/lib/python3/dist-packages/pip/download.py", line 25, in <module>
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead'
-- Installation of python library 'requests' with command pip3
Traceback (most recent call last):
File "/usr/bin/pip3", line 9, in <module>
load_entry_point('pip==1.5.6', 'console_scripts', 'pip3')()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 356, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2476, in load_entry_point
return ep.load()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2190, in load
['__name__'])
File "/usr/lib/python3/dist-packages/pip/__init__.py", line 74, in <module>
from pip.vcs import git, mercurial, subversion, bazaar  # noqa
File "/usr/lib/python3/dist-packages/pip/vcs/mercurial.py", line 9, in <module>
from pip.download import path_to_url
File "/usr/lib/python3/dist-packages/pip/download.py", line 25, in <module>
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead'
-- Installation of python library 'protobuf' with command pip3
Traceback (most recent call last):
File "/usr/bin/pip3", line 9, in <module>
load_entry_point('pip==1.5.6', 'console_scripts', 'pip3')()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 356, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2476, in load_entry_point
return ep.load()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2190, in load
['__name__'])
File "/usr/lib/python3/dist-packages/pip/__init__.py", line 74, in <module>
from pip.vcs import git, mercurial, subversion, bazaar  # noqa
File "/usr/lib/python3/dist-packages/pip/vcs/mercurial.py", line 9, in <module>
from pip.download import path_to_url
File "/usr/lib/python3/dist-packages/pip/download.py", line 25, in <module>
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead'
-- Installation of python library 'zeroconf' with command pip3
Traceback (most recent call last):
File "/usr/bin/pip3", line 9, in <module>
load_entry_point('pip==1.5.6', 'console_scripts', 'pip3')()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 356, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2476, in load_entry_point
return ep.load()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2190, in load
['__name__'])
File "/usr/lib/python3/dist-packages/pip/__init__.py", line 74, in <module>
from pip.vcs import git, mercurial, subversion, bazaar  # noqa
File "/usr/lib/python3/dist-packages/pip/vcs/mercurial.py", line 9, in <module>
from pip.download import path_to_url
File "/usr/lib/python3/dist-packages/pip/download.py", line 25, in <module>
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead'
-- Installation of python library 'click, bs4 and six' for TTS with command pip3
Traceback (most recent call last):
File "/usr/bin/pip3", line 9, in <module>
load_entry_point('pip==1.5.6', 'console_scripts', 'pip3')()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 356, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2476, in load_entry_point
return ep.load()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2190, in load
['__name__'])
File "/usr/lib/python3/dist-packages/pip/__init__.py", line 74, in <module>
from pip.vcs import git, mercurial, subversion, bazaar  # noqa
File "/usr/lib/python3/dist-packages/pip/vcs/mercurial.py", line 9, in <module>
from pip.download import path_to_url
File "/usr/lib/python3/dist-packages/pip/download.py", line 25, in <module>
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead'
-- Installation of python library 'tqdm, websocket-client' for plex with command pip3
Traceback (most recent call last):
File "/usr/bin/pip3", line 9, in <module>
load_entry_point('pip==1.5.6', 'console_scripts', 'pip3')()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 356, in load_entry_point
return get_distribution(dist).load_entry_point(group, name)
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2476, in load_entry_point
return ep.load()
File "/usr/lib/python3/dist-packages/pkg_resources.py", line 2190, in load
['__name__'])
File "/usr/lib/python3/dist-packages/pip/__init__.py", line 74, in <module>
from pip.vcs import git, mercurial, subversion, bazaar  # noqa
File "/usr/lib/python3/dist-packages/pip/vcs/mercurial.py", line 9, in <module>
from pip.download import path_to_url
File "/usr/lib/python3/dist-packages/pip/download.py", line 25, in <module>
from requests.compat import IncompleteRead
ImportError: cannot import name 'IncompleteRead'
-- Installation of dependencies is done !

Ta réponse à là!

C’est pas la réponse mais la cause.
En claire jessie n’est plus supporté, il faut passer à stretch ou buster

1 « J'aime »