Demon se desactive

Tags: #<Tag:0x00007f283b64b558>

bonjour
Je n’arrive pas a faire marcher mon rfxcom car le démon se connecte au bout de 3 secondes
Je suis sur une jeedom delta et mon rfxcom est sur son port usb type a
Merci de vos infos

Salut et bienvenue sur community,

Avec si peux d’informations il nous est impossible de t’aider.

Fait un tour sur le post de @akenad et donne nous des infos qu’on puisse savoir ce qui coince :
[Présentation] akenad

voila mon log de surveillance en debug si ça peu aider

[2020-03-15 11:15:06][INFO] : Lancement démon rfxcomd : /usr/bin/python /var/www/html/plugins/rfxcom/resources/rfxcomd/rfxcomd.py --device /dev/ttyAMA0 --loglevel debug --socketport 55000 --serialrate 38400 --protocol 12,13,18,20,21,22,23 --callback http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php --apikey rPdMj05srRxRSpbHvbEflhRr8xKB2xXZ --cycle 0.3 --pid /tmp/jeedom/rfxcom/deamon.pid
[2020-03-15 10:15:06][INFO] : Start rfxcomd
[2020-03-15 10:15:06][INFO] : Log level : debug
[2020-03-15 10:15:06][INFO] : Socket port : 55000
[2020-03-15 10:15:06][INFO] : Socket host : 127.0.0.1
[2020-03-15 10:15:06][INFO] : PID file : /tmp/jeedom/rfxcom/deamon.pid
[2020-03-15 10:15:06][INFO] : Device : /dev/ttyAMA0
[2020-03-15 10:15:06][INFO] : Apikey : rPdMj05srRxRSpbHvbEflhRr8xKB2xXZ
[2020-03-15 10:15:06][INFO] : Callback : http://127.0.0.1:80/plugins/rfxcom/core/php/jeeRfxcom.php
[2020-03-15 10:15:06][INFO] : Cycle : 0.3
[2020-03-15 10:15:06][INFO] : Serial rate : 38400
[2020-03-15 10:15:06][INFO] : Serial timeout : 9
[2020-03-15 10:15:06][INFO] : Protocol : 12,13,18,20,21,22,23
[2020-03-15 10:15:06][INFO] : Find device : /dev/ttyAMA0
[2020-03-15 10:15:06][DEBUG] : Writing PID 18866 to /tmp/jeedom/rfxcom/deamon.pid
[2020-03-15 10:15:06][DEBUG] : Init request module v2.21.0
[2020-03-15 10:15:06][DEBUG] : Starting new HTTP connection (1): 127.0.0.1:80
[2020-03-15 10:15:06][DEBUG] : http://127.0.0.1:80 « GET /plugins/rfxcom/core/php/jeeRfxcom.php?apikey=rPdMj05srRxRSpbHvbEflhRr8xKB2xXZ HTTP/1.1 » 200 0
[2020-03-15 10:15:06][DEBUG] : Init serial module v3.4
[2020-03-15 10:15:06][DEBUG] : Start listening…
[2020-03-15 10:15:06][DEBUG] : Socket interface started
[2020-03-15 10:15:06][DEBUG] : LoopNetServer Thread started
[2020-03-15 10:15:06][DEBUG] : Open serial port on device: /dev/ttyAMA0, rate 38400, timeout : 9
[2020-03-15 10:15:07][DEBUG] : Listening on: [127.0.0.1:55000]
[2020-03-15 10:15:07][DEBUG] : Open Serialport
[2020-03-15 10:15:07][DEBUG] : flushOutput serial port
[2020-03-15 10:15:07][DEBUG] : flushInput serial port
[2020-03-15 10:15:07][DEBUG] : flushOutput serial port
[2020-03-15 10:15:07][DEBUG] : flushInput serial port
[2020-03-15 10:15:07][DEBUG] : Read Socket Thread Launched
[2020-03-15 10:15:07][DEBUG] : Read Device Thread Launched
[2020-03-15 10:15:08][DEBUG] : Send rfxcomd_reset
[2020-03-15 10:15:08][DEBUG] : Write data to serial port : 0D 00 00 00 00 00 00 00 00 00 00 00 00 00
[2020-03-15 10:15:08][DEBUG] : Sleep 1 sec
[2020-03-15 10:15:09][DEBUG] : flushInput serial port
[2020-03-15 10:15:09][DEBUG] : Send get status test
[2020-03-15 10:15:09][DEBUG] : Write data to serial port : 0D 00 00 01 02 00 00 00 00 00 00 00 00 00
[2020-03-15 10:15:09][DEBUG] : Client connected to [127.0.0.1:58576]
[2020-03-15 10:15:09][DEBUG] : Message read from socket: {« apikey »:« rPdMj05srRxRSpbHvbEflhRr8xKB2xXZ »,« cmd »:« add »,« device »:{« id »:« 230907AA »}}
[2020-03-15 10:15:09][DEBUG] : Client disconnected from [127.0.0.1:58576]
[2020-03-15 11:15:09][INFO] : Démon RFXcom lancé
[2020-03-15 10:15:09][DEBUG] : Message received in socket JEEDOM_SOCKET_MESSAGE
[2020-03-15 10:15:09][DEBUG] : Add device : {u’id’: u’230907AA’}
[2020-03-15 10:15:35][ERROR] : Timeout waiting status
[2020-03-15 10:15:35][DEBUG] : Shutdown
[2020-03-15 10:15:35][DEBUG] : Removing PID file /tmp/jeedom/rfxcom/deamon.pid
[2020-03-15 10:15:35][DEBUG] : LoopNetServer Thread stopped
[2020-03-15 10:15:35][DEBUG] : Close serial port
[2020-03-15 10:15:35][DEBUG] : Serial port closed
[2020-03-15 10:15:35][DEBUG] : Exit 0

Bonjour,
Tu n’a pas configuré le bon port USB ! Le bon port est : RFXCom RFXtrx 433XL (/dev/ttyUSB0). Tu ne l’a certainement pas encore dans la liste des ports utilisables. C’est normal !

Voilà un process d’install qui fonctionne:
1/ Dans le plugin RFXcom dans port, tu choisis « Aucun », tu arrête jeedom depuis son interface.
2/ Dans la gestion de ta Freebox, tu vas dans le paramétrage de ta VM tu supprime ton port USB. Tu redémarre ta VM.
3/ Tu attends son démarrage, dans Jeedom tu l’arrête à nouveau !
4/ Tu retourne dans la gestion de ta Freebox, tu revalide ton port USB, tu redémarre la VM
5/ Retour dans le plugin RFXcom dans port, maintenant doit apparaitre « RFXCom RFXtrx 433XL (/dev/ttyUSB0) ».Choisit le, sauvegarde ce choix. Cela doit maintenant fonctionner …!
Par contre il arrive qq fois que la config se perde…il faut refaire la manip.
Il faudrait pouvoir figer la config de ce port. Je n’ai pas encore trouvé comment le faire !
Cdlt, Jean