Démon Gardena-Husqvarna en erreur

Tags: #<Tag:0x00007f384f972a78>

Salut à tous !

Depuis l’installation du plugin, le démon s’arrête juste après avoir été lancé et ne se relance pas.

J’ai bien activé l’api husqvarna sur le site dev ainsi que l’api dans le plugin.

Voici le log du démon :

[2020-08-29 07:35:08][DEBUG] : Passing through key word arguments {'allow_redirects': True}.
[2020-08-29 07:35:08][DEBUG] : Starting new HTTPS connection (1): api.amc.husqvarna.dev:443
[2020-08-29 07:35:09][DEBUG] : https://api.amc.husqvarna.dev:443 "GET /v1/mowers HTTP/1.1" 200 786
[2020-08-29 07:35:09][ERROR] : Fatal error : 'calendar'
[2020-08-29 07:35:09][INFO] : Shuting down
[2020-08-29 07:35:09][DEBUG] : Removing PID file /tmp/jeedom/gardena/deamon.pid
[2020-08-29 07:35:09][DEBUG] : Exit 0

Je ne sais pas à quoi fait référence calendar. La programmation interne du robot ?

Merci pour votre aide

Bonjour,

Je vais vérifier cela.

Serait-il possible que tu me partages un accès pour que je puisse tester directement avec ton matériel?
Il y a peut-être quelque chose de particulier qui m’a échappé.

jamais eu de pb avec ce plugin mais le robot est il a l’heure ainsi que le rpi ou autre qui fait tourner jeedom ?

Je pense avoir trouvé, j’ai poussé une nouvelle version pour régler le problème.
Peux-tu vérifier les mises à jour et l’installer?

Hello Mips !

Je viens de faire la mise à jour et ça marche ! Merci !
C’était quoi le problème ?

Désolé pour ma réponse tardive, je me suis pas connecté plus tôt… en tous cas, un grand merci pour la vitesse à laquelle t’arrives a nous aider !

C’était une erreur de ma part dans le décodage de la réponse sur la partie calendrier des tondes.
Je n’ai pas encore intégré cette partie dans le plug-in d’ailleurs, ça viendra sûrement dans une mise à jour, mais j’avais déjà commencé au niveau de l’api; c’est pour ça que je n’avais pas bien testé cette partie et que je n’avais pas vu le bug.

Quand à apporter du support c’est normal, souvent je trouve vite (en toute impartialité :joy:), parfois ça demande plus de temps mais je fais toujours pour le mieux !

1 J'aime

Ce sujet a été automatiquement fermé après 24 heures suivant le dernier commentaire. Aucune réponse n’est permise dorénavant.