Deconz : installation impossible - prb avec installation du paquet deconz.deb

Tags: #<Tag:0x00007f283cad6cc0>

Bonsoir,

Je viens de recevoir ma clé Conbee 2 et je n’arrive pas à installer le paquet deconz.deb.

J’ai un message pas encourageant :

Connecting to www.dresden-elektronik.de (www.dresden-elektronik.de)|62.116.169.71|:443... connected.
HTTP request sent, awaiting response... 
404 Not Found
2019-11-13 20:26:46 ERROR 404: Not Found.

Le reste du log :

********************************************************
*             Installation deconz                      *
********************************************************
Hit:1 http://security.debian.org/debian-security buster/updates InRelease
Hit:2 https://deb.nodesource.com/node_12.x buster InRelease
Hit:3 http://ftp.fr.debian.org/debian buster InRelease
Hit:4 http://ftp.fr.debian.org/debian buster-updates InRelease
Hit:5 http://phoscon.de/apt/deconz buster-beta InRelease
Reading package lists...

Reading package lists...
Building dependency tree...
Reading state information...
libqt5serialport5 is already the newest version (5.11.3-2).
libqt5websockets5 is already the newest version (5.11.3-5).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
Reading package lists...
Building dependency tree...

Reading state information...
sqlite3 is already the newest version (3.27.2-3).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
It's x86_64 arch
--2019-11-13 20:26:39--  https://www.dresden-elektronik.de/deconz/ubuntu/beta/deconz-2.05.69-qt5.deb
Resolving www.dresden-elektronik.de (www.dresden-elektronik.de)... 
62.116.169.71
Connecting to www.dresden-elektronik.de (www.dresden-elektronik.de)|62.116.169.71|:443... connected.
HTTP request sent, awaiting response... 
404 Not Found
2019-11-13 20:26:46 ERROR 404: Not Found.

dpkg-deb: error: '/tmp/deconz.deb' is not a Debian format archive
dpkg: error processing archive /tmp/deconz.deb (--install):
 dpkg-deb --control subprocess returned error exit status 2
Errors were encountered while processing:
 /tmp/deconz.deb
Hit:1 http://ftp.fr.debian.org/debian buster InRelease
Hit:2 http://security.debian.org/debian-security buster/updates InRelease
Hit:3 http://ftp.fr.debian.org/debian buster-updates InRelease
Hit:4 https://deb.nodesource.com/node_12.x buster InRelease
Hit:5 http://phoscon.de/apt/deconz buster-beta InRelease
Reading package lists...


WARNING: apt does not have a stable CLI interface. Use with caution in scripts.

Reading package lists...
Building dependency tree...
Reading state information...
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
********************************************************
*             Installation terminée                    *
********************************************************

Le démon est lancé et ma clé est vue sous Linux.

Quelqu’un a t il une idée ?

Merci.

Bonjour,

Même souci pour moi, j’allais justement lancer un post :slight_smile:

Il semble que le site ait changé l’adresse des packages. D’ailleurs cette version ne semble plus proposée :

49 Capture d’écran 2019-11-13 à 20.51.49

Oups, pas cool !

Effectivement deconz a l’air d’avoir tout changé mais je ne retrouve pas les nouveaux liens…

Tout est ici :http://deconz.dresden-elektronik.de/raspbian/alpha/
ou ici
http://deconz.dresden-elektronik.de/ubuntu/beta/
ou encore ici
http://deconz.dresden-elektronik.de/win/

Une petite mise à jour du script d’instal et hop c’est reparti comme en 14 comme aurait dit feu mon grand père

2 J'aimes

Top merci on va surtout l’héberger nous je pense pour que ça ne se reproduise plus. Je fais tout ça demain

1 J'aime

Super merci @Loic (et @Yves19 pour les liens :))

Merci beaucoup pour la réactivité.

Ha cool, merci ca me rassure ca vient pas de moi. Petite question pour un noob, sur un rpi on télécharge avec wget le fichier et on l installe ensuite comment depuis jeedom ?
Quelle est la procédure, merci !

Bonjour,
Je viens de pousser une mise a jour du plugin qui devrait corriger le soucis

3 J'aimes

Bonjour. Problème corrigé pour l’installation.

Cependant, je ne sais pas si je suis le seul mais mon démon ne reste pas actif, il tient 10 secondes et se coupe.

Usage:
kill [options] <pid> [...]
Options:
<pid> [...]            send signal to every <pid> listed
-<signal>, -s, --signal <signal>
specify the <signal> to be sent
-l, --list=[<signal>]  list all signal names, or convert one to a name
-L, --table            list all signal names in a nice table
-h, --help     display this help and exit
-V, --version  output version information and exit
For more details see kill(1).
Usage:
kill [options] <pid> [...]
Options:
<pid> [...]            send signal to every <pid> listed
-<signal>, -s, --signal <signal>
specify the <signal> to be sent
-l, --list=[<signal>]  list all signal names, or convert one to a name
-L, --table            list all signal names in a nice table
-h, --help     display this help and exit
-V, --version  output version information and exit
For more details see kill(1).
[2019-11-14 11:00:03][ERROR] : Erreur sur la fonction cronHourly du plugin : Echec de la requête HTTP : 127.0.0.1:8484/api/8609414E38/config cURL error : Failed to connect to 127.0.0.1 port 8484: Connection refused
[2019-11-14 11:10:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2019-11-14 11:15:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2019-11-14 11:20:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2019-11-14 11:20:30][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2019-11-14 11:20:03
[2019-11-14 11:20:41][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2019-11-14 11:20:03
[2019-11-14 11:20:44][ERROR] : Erreur sur la fonction deamon_start du plugin : Vous devez attendre au moins 45 secondes entre deux lancements du démon. Dernier lancement : 2019-11-14 11:20:03
[2019-11-14 11:20:50][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2019-11-14 11:25:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement
[2019-11-14 11:30:03][ERROR] : Attention je pense qu'il y a un soucis avec le démon que j'ai relancé plus de 3 fois consécutivement

On dirait qu’il n’arrive pas à communiquer avec la clé.

J’ai bien désactivé le serial en ssh (je tournes sur un rpi 3b+ en raspbian) et dans le laps de temps ou le démon est actif, j’arrive a récupérer la clef API.

Ya pas mal de monde dans ce cas la pour l’instant tout ce que je sais c’est que c’est deconz qui a un soucis c’est peut etre le bug de la .70

ah ok :confused: dommage.

Je viens de pousser une beta qui fait un fix temporaire la dessus mais c’est vraiment une rustine

1 J'aime

il faut réinstaller les dépendances pour l’avoir ? ou passer par les installation en beta au lieu de stable pour avoir accès aux plugins en beta ? ou c’est juste installer en local et c’est bon ?

Tu suite la doc pour avoir accès au beta (pas besoin du core en beta), tu installes la beta et relance le demon rien d’autre a faire

ça marche merci :slight_smile: en attendant une meilleure version. il faut surveiller ou ce sera une M.A.J. du plugin en stable ?

Je l’ai poussé en stable, en esperant que ca pause pas de soucis chez d’autre personne

1 J'aime

Ok. oui ce serait cool :). Merci.

Après mise à jour chez moi, plus possible d’obtenir une connexion de la Gateway. Tout est OK coté démon et plugin (RAS dans les log) . La Gateway reste malheureusement “Not Connected”.
Une restauration de ma configuration Jeedom sauvegardée juste avant ne change rien puisque Deconz et la Gateway restent en version .70.

Jai moult fois redémarré la box, me suis assuré qu’il n’y avait pas d’autre deconz qui tournait autre que celui installé par le plug in.

J’en perds le peu de Latin qu’il me reste.