Debian 9 amd64 - VM - impossible d'installer jeedom v4 /v3

Bonjour,

Je n’arrive pas à installer Jeedom sur une machine virtuel avec Debian 9.
J’ai suivi la procédure de la doc : https://jeedom.github.io/documentation/installation/fr_FR/index#tocAnchor-1-14-5

Lors de la phase 6 du install.sh, j’ai l’erreur :

2020-04-09 17:58:57 (1,20 MB/s) — « /tmp/jeedom.zip » sauvegardé [46682514/46682514]

/root/core-4-stable/3rdparty/bootstrap/fonts/glyphicons-halflings-regular.svg  bad CRC e23caca4  (should be c9c6ee7c)
/root/core-4-stable/3rdparty/codemirror/addon/fold/foldgutter.css  bad CRC 0977494d  (should be 114a24ca)
...
"Ne peut décompresser l'archive - Annulation".

J’ai bien testé 10x. Pouvez-vous m’aider ?

PI : j’utilise Jeedom depuis 2 ans.
Au début sur un rpi, après avoir cramé 3 cartes SD
=> j’ai testé Docker depuis 1 mois mais impossiblre de faire marcher le plugin Caméra
=> je me rabat donc sur une VM - debian 9, sans succès…

Bonjour,

Première idée, est-ce que tu as bien fait un « su - » avec un espace entre le « su » et le « - » ?

Bison

Bonjour,

Oui, j’ai suivi la procédure du lien.

Merci pour la réactivité ! :wink:

Testé sur debian 10 et même problème avec le script install.sh


/root/core-master/3rdparty/bootstrap/img/glyphicons-halflings-white.png  bad CRC c40a48d8  (should be 43808ba4)
/root/core-master/3rdparty/codemirror/addon/merge/dep/diff_match_patch.js  bad CRC 3e3da8fc  (should be 3daea57e)
/root/core-master/3rdparty/jquery.mobile/css/fonts/fontawesome-webfont.woff  bad CRC 36a1befb  (should be 9b9f663d)
/root/core-master/3rdparty/three.js/three.module.js  bad CRC fa02f57c  (should be 7acbbc5a)
/root/core-master/core/img/imageMaj_stepDeux.jpg  bad CRC 02523e08  (should be 41c35a43)
/root/core-master/core/img/scenario.png  bad CRC c6dcdf90  (should be c0d29e2f)
/root/core-master/docs/images/interact030.png  bad CRC 4a6a5df7  (should be 812e9c42)
Ne peut décompresser l'archive - Annulation

Votre partition /tmp elle fait quelle taille ?

Bonjour @bubu,

Pour buster c’est ici : [RTEX] Debian 10 - Buster - netinst - amd64 - Jeedom V4

akenad :slight_smile:

Bonjour,

La partition (sda1) fait 31 Go (32Go pour tout le système)

Bonjour,

Merci j’ai installé en suivant cette procédure (merci pour le travail effectué), mais j’ai la même erreur « bad CRC ».
Je test maintenant la même installation via HyperV.

Bon, via HyperV l’installation a fonctionné.

Un problème avec VirtualBox sur Windows 10 alors ?

J’avais essayé virtualbox sous Windows 10 mais avec Debian 9 + Jeedom V4. Pas de soucis d’installation.

Si ça se trouve en effet il gère mal avec Debian 10 mais c’est curieux…

Édit : je viens de revoir le tritre et tu essayer bien avec Debian 9
Tu étais bien réparti du même ISO ?

Salut à tous!

Je suis dans le même cas avec la combinaison Windows 10 + VirtualBox + Debian9 ou Debian10.

Je suis passé sur une VM il y a environ 2 mois car mes Raspberry & OdroidC2 plantaient.
Pour ce premier essai j’avais un PC Windows7 que j’avais à disposition et j’y ai installé VirtualBox, j’y ai installé Debian 9.2 64bits et Jeedom. Aucun soucis!

Ce jour je m’énerve ( :slight_smile: ) à installer sous Windows 10 VirtualBox et Debian 9.2 (le même ISO) … jusque là tout est OK, Debian s’installe à merveille.
Puis au tour de Jeedom, tout se passe bien jusqu’au téléchargement du fichier jeedom.zip, j’ai exactement le même soucis CRC et le même message d’erreur.
J’ai moi aussi essayé plusieurs fois pensant que c’était le téléchargement qui avait raté :slight_smile:

Bref, j’ai ensuite fais la même installation avec Debian 10 et c’est pareil.

Puis j’ai essayé Hyper-V et là tout fonctionne, jusqu’à l’installation de Jeedom.
Mais bon Hyper-V ne gère pas l’USB donc pas cool pour y connecter un stick/contrôleur Zwave n’est-ce pas!

Finalement j’ai aussi copié la VM qui tourne sur mon ancien PC Windows7 vers mon PC Windows 10 et tout est OK dans VirtualBox, ça tourne.

J’aimerai vraiment comprendre ce qui ne va pas lors d’une nouvelle installation avec la combinaison Windows 10 + VirtualBox + Debian 9 (ou 10) car mon but est de mettre tout cela sur un Serveur Windows 2016 si ça passe sur mon PC Windows 10.

Toute explications et/ou solutions sont les bienvenues!

Merci,

Sébastien

Regardez ceci:

image

J’ai fais un unzip du paquet jeedom.zip depuis le répertoire /temp.
Puis j’ai voulu faire une copie du répertoire core-4-stable vers le répertoire root/core-4-stable.
Que je fasse ceci dans Putty ou même depuis la console de virtualBox, ça plante!
C’est quoi ça?
Est-ce un problème avec Windows 10? est-ce connu?

Sébastien

Salut,

Bon j’ai finalement réussi a installer Jeedom sur un Debian depuis VirtualBox sur Windows 10.
Mon problème venait de certains drivers sur mon PC qui posaient des soucis. (carte wifi).

Sébastien